Parallels Desktop 3.0 for Mac and Windows Vista Boot Camp 1.3?

Discussion in 'Windows Guest OS Discussion' started by flaiodanny, Jun 7, 2007.

  1. STim

    STim Super Moderator

    Messages:
    945
    While requesting a refund and before uninstalling Parallels, please check if the problem is not there if you shut down/start Vista again instead of rebooting it. Thank you in advance.
     
  2. chief

    chief

    Messages:
    1
    Update Worked for me

    I was experiencing the freezing issue with my Vista Business Botcamp installation with Parallels and spent 10 hours trying to get it to work: re-installed Vista twice, backed up the mac and then clean install of Tiger, Bootcamp and Vista.

    I downloaded the new Parallels version posted in this version and the problem is fixed. No more freezing after booting my bootcamp Vista with Parallels. Sometime it is frustrating to be an early adopter but at least the Parallels team came back with a quick update: thanks.
     
  3. bombastinator

    bombastinator

    Messages:
    30
    we're such weenies Have some friken patience,

    Us mac users are such weenies about incompatibilities.

    With macs everything just works, and we get real use to that. Incompatibilities are the norm with other operating systems, Linux especially. As a frequent Linux user I can tell you that with Linux you can pretty much assume that something is going to break at least temporarily whenever there is a series of patches. They usually get it going again, but it takes at least a few days.

    All you folks screaming about Fusion I guarantee that the same kind of thing is going to happen to you there eventually. The only difference ATM is that Fusion hasn't been upgraded in a while. See what happens at the next update.

    I am actually more supprised that Apple wasn't more careful with the new driver. VM is a major killer app for Apple and it would behoove them to protect it.

    This is not to say that this is a major issue, and I do think Paralles should either get this fixed by mid week or release a statement saying when they think it may be done by. Did anyone notice it was Saturday btw? The engineers are out for the weekend. They may not even know this is happening yet.

    P.S.
    Yes this is an apologist statement, and no it is not my policy to blindly support parallels. I've done my share of complaining too, but Jeeze people!
     
  4. charliez

    charliez Bit Poster

    Messages:
    21
    There should be a clear read me. I needed to reboot not just Vista. But also MacOSX:
    1. Download build 4128
    2. Install build 4128
    3. Reboot MacOS X (seems you need to do this because of services from build 4124 is still running after build 4128 is installed).
    4. Create your Vista VM using custom from Boot Camp partition
    5. Install Parallel Tools, and allow the various drivers to install

    I can see that with 4128 you do the magic by removing kbdmgr.exe at Vista startup, and restore that at VM shutdown.

    This should have been an easy experience.
     
  5. charliez

    charliez Bit Poster

    Messages:
    21
    LOL, I'm in a much better mood now that I've got it going (but without coherence, WTF ?????) That's precisely why people are yelling. People bought Macs so they don't have to deal with Linux incompatibilities, or past complexities of Windows (well there are still many with Vista, but at least it feels more usable like a proper Mac clone).

    The excuse of "deal with it, it could be worse" is not acceptable with Macs. People spend money expecting it to just work. Otherwise, might as well use the other OSs.
     
  6. bombastinator

    bombastinator

    Messages:
    30
    You got a functional work around? Mad props to charliez! You Rock! I'm going to make a new thread with a foot note to our man here with the fix so folks can see it immediately.
     
  7. PuppyPR

    PuppyPR

    Messages:
    4
    Thanks for the fix

    I have installed the new Parallels 3.0 build and the problem with Boot Camp 1.3 was solved. Kudos to Parallels/Swsoft team. I'm still having issues trying to install the Parallels Tools on Vista.
    Charliez, stop crying. VMWare Fusion Beta 4 does not haver support to Unity on Vista, Parallels doest have Coherence on Vista. That is a must for me.
     
  8. PuppyPR

    PuppyPR

    Messages:
    4
    Ok, just restart Parallels and install the Parallels Tools, it works flawlessly. thanks again Swsoft/Parallels team.
     
  9. twynne

    twynne Kilo Poster

    Messages:
    154
    What's everyone else's experience with the performance of a Vista Boot Camp VM as opposed to a normal Windows XP VM?

    On my new MBP (2.4ghz, 2GB memory, 7200rpm drive) the XP VM seems to consume about 20% cpu when idle. The Vista VM idles at about 50% CPU and dramatically higher when doing even the simplest of tasks.

    Is your experience similar or is there something wrong with my installation? If this is expected, is Vista performance likely to improve in future Parallels releases?

    To be clear - the above has nothing to do with Aero and I'm not concerned about running Aero, I'm merely interested in VM performance.

    Thanks,

    Tom
     
  10. Zenara25

    Zenara25

    Messages:
    27
    I'm still having problems with an ACPI driver being installed in parallels then when I go into bootcamp it installs another acpi driver. If my copy of Vista Ultimate was activated already Windows would sure be bugging me alot. I tried upgrading to 4128 and to bootcamp 1.3

    I know that at least one other person on a Macbook Pro with an activated (must not be much fun activating all the time) Vista Business edition is having this same problem.

    I'm on a Macbook Core Duo (not pro or Core 2 Duo)
     
  11. mkrosse

    mkrosse

    Messages:
    3
    New 4128 Build does not fix the problem

    Installed 4128; rebooted Mac; rebuilt VM for Vista Bootcamp. Unfortunately - still no keyboard or mouse - Vista just sits there at logon screen and eventually goes into screen saver mode. It does not respond to any keyboard or mouse input on MacBook Pro with BC 1.3 & Vista Ultimate.
     
  12. dippyskoodlez

    dippyskoodlez Bit Poster

    Messages:
    88
    Try plugging a usb mouse in, and dedicating that to the VM. Once you get parallels tools installed, it works great.

    It just seems getting parallels tools installed is a pain at the moment.
     
  13. DExplore97

    DExplore97

    Messages:
    1
    My process was to uninstall build 4124 and reboot Mac OS X. I then installed build 4128. I booted into Vista Boot Camp and re-enabled keybdmr.exe. Rebooted into Mac OSX and booted into Parallels. Everything worked fine. I even got the iSight cam to work.

    Great posts in this thread. I am a new Parallels user and thanks to this thread, I am very happy with it.

    How cool is it that a fix was posted by Parallels so quickly! I wish othe software manufacturers were so responsive.
     
  14. stuartrice

    stuartrice

    Messages:
    5
    No issues with Vista -- but...

    As I said in another post, I started with a clean installation of EVERYTHING. Parallels 3.0 is running beautifully, with Coherence, networking, etc.
     
  15. flaiodanny

    flaiodanny

    Messages:
    10
    Parallels now works for Vista with me, but I now cannot get Vista to load in Boot Camp 1.3. Anyone else with this problem?
     
  16. allenranger2

    allenranger2

    Messages:
    7
    Aero not functioning?

    Well, I'm able to get BootCamp 1.3 drivers installed on Vista Ultimate, however I'm having it freeze in the first 30 seconds. After reading the forums, I was able to start in safe mode and disable the keyboardmanager, and I'm on Parallels 4128.

    I'm sure that Parallels is looking into this, so I won't bother with that.

    My question, however, is whether anyone's been able to get Aero to work on Vista? I have enabled Direct X support, and both with and without BootCamp video drivers, I'm still not getting Aero. In Device Manager, Paralllels is still my video driver. Anyone having similar issues?

    ** edit: please disregard Aero issue, I have just found out that Aero requires DX9, and at the moment, Parallels is DX 8. **
     
    Last edited: Jun 11, 2007
  17. macloverNUE

    macloverNUE

    Messages:
    2
    MB C2D - Vista/bootcamp 1.2/parallels 3.0

    hi,

    i have the same problem

    i am running vista ultimate under a bootcamp partition. now i installed the latest parallels build 4128. but i cannot bring the mouse or the keyboard alive once the windows logon screen is reached. the system seems to be frozen.

    moreover i don't have the kbdmgr.exe running as i am using inputremapper ...

    the worst thing i did was to set the usb-hid-device to the virtual machine and after that i could not even use the mouse and keyboard on mac os anymore ... :confused:

    any ideas ?

    cheers
     
  18. Gerald Cox

    Gerald Cox Bit Poster

    Messages:
    12
    For me, I have 2 Boot Camp drives (They're actually on one HD but for some reason, Vista created them when I originally installed it.....)

    I just got Boot Camp 1.3 and made a new drivers CD..... I have Parallels 3.0/4128 and I get the message about "non-standard" Boot Camp.... I've tried manually editing the .pvs file...no luck so far.

    I'm "not dead yet" though ;-)
     
  19. mralston

    mralston

    Messages:
    16
    I've got Vista installed on a Boot Camp and had the same problem when I booted it in Parallels Desktop 3.0.

    It boots to the login screen then freezes, keyboard and mouse apparently not working.

    I was about to give up and wait for a patch when I noticed that the hard drive icon on the Parallels status bar was going like the clappers.

    I'm pretty used to Vista going very slowly every so often so decided to leave it for a while. I would hit a few keys and wiggle the mouse every so often. Eventually the keyboard started typing into the password box.

    I logged in to Vista. They keyboard now seemed happy but the mouse was a no-go. Luckily I'm very used to working without a mouse in Windows so that didn't cause me a problem.

    Slowly (very, very slowly) but surely Parallels Tools installed themselves. There wasn't much indication what it was doing other than the warning box you get telling you not to reboot. Every so often Windows would throw up an unsigned driver warning which I would except. After about a quarter of an hour it finished installing Parallels Tools.

    The VM rebooted and it now all works (including the mouse).

    It is still very very slow. I've not used Parallels for a few months due to the lack of Vista support, but I always found that when running a native Parallels VM it runs quickly but when running a Boot Camp installation under Parallels it is very slow. That was the case with XP, and seems to be still the case with Vista.

    I'm going to boot up in Boot Camp mode next and disable Apple's keyboard manager thingie. It gets on my nerves anyway as it remaps a lot of the keys to places I can't find them!

    With a bit of luck I might end up with a Vista install that works well in Boot Camp and Parallels. Or hell might freeze over. :)
     
  20. jeffsure

    jeffsure

    Messages:
    10
    I can't boot into my Bootcamp installation of Vista using Parallels v3.0 either, but I get a different error. I can't even get to the login screen, as I'm immediately presented with this screen:

    [​IMG]

    Booting directly into Vista using Bootcamp works fine. I'm not at all familiar with the Windows file system, but it looks like bootmgr is missing. Can anyone give me hint as to what to do to fix this, or is it even worth trying? Should I wait for v3.1?
     

Share This Page