Parallels Desktop 4 fails to quit normally

Discussion in 'Installation and Configuration' started by swivet, Aug 24, 2009.

  1. swivet

    swivet

    Messages:
    20
    Parallels Desktop doesn't exit normally anymore -- meaning the PDM4 application, not a virtual machine. With no VMs running and no windows open, PDM4 totally ignores CMD+Q from the keyboard or "Quit" from the application's menu bar.

    You can only get PD to exit by force-quitting, or by quitting from the application switcher (CMD+Tab, then CMD+Q with the app's icon selected).

    Search turned up nothing on this. Any suggestions short of uninstall and re-install Parallels Desktop? Did the obvious like perms repair.

    TIA

    Parallels Desktop for Mac, v. 4.0.3844.408728
    Mac OS X v. 10.5.8 on a MacBook Pro w/ 4GB RAM
     
  2. Hello swivet,

    Are facing similar issues with any other applications apart from Parallels Desktop?

    Please provide us the information about which version and build of Parallels Desktop you are using.

    Awaiting your response.
     
  3. Hello swivet,

    Please ignore the previously sent reply.

    Lets try uninstalling and reinstalling Parallels Desktop using the .dmg file.

    Please reply us the status of the issue.
     
  4. swivet

    swivet

    Messages:
    20
    Fixed it for about a day

    Uninstalling/reinstalling from the DMG file fixed the problem with Parallels Desktop not wanting to quit when asked. It was a completely painless fix, too -- took about 5 minutes and disturbed nothing else. Even my app registration remained.

    After a day, the no-quit behavior came back. More curious than bummed at this point. This is easy to work around, I just wonder, "Why me?"

    Occasionally MS Live Communicator 2007 hangs shutdown of Windows because it refuses to exit gracefully. Otherwise, everything functions the way you would hope. Mystified at the moment.
     
  5. swivet

    swivet

    Messages:
    20
    4.0.3846 version update fixed it

    Whatever the cause of this no-quit behavior was -- I don't have the issue any more, since updating to the 3846 release.

    FYI/swv
     
  6. swivet

    swivet

    Messages:
    20
    Then it came back again

    The will-not-quit-when-I-say-quit problem came back again after a couple of days. I also see the same behavior on a 2009 MacBook Pro 15-inch running Snow Leopard. :shrug:
     
  7. Matt Jannusch

    Matt Jannusch

    Messages:
    1
    Same behavior here... Snow Leopard 10.6.1, Parallels 4.0.3846, early 2009 MacBook Pro 15". After having run a VM containing Windows XP, Shut Down Windows, then close the VM window after shutdown, Parallels appears to ignore the Cmd-Q Quit command. The File menu flashes like it registers the menu selection, but Parallels does not quit.
     
  8. pabloS

    pabloS

    Messages:
    1
    same behavior for me

    I haven't been able to quit parallels without using force quit for a while. Everything else works fine- all other apps quit normally and my winxp virtual machine runs fine (also runs well via boot camp).

    Mac OS 10.5.8, Parallels 4.0.3846 using a boot camp partition.
     
  9. Anupama A

    Anupama A

    Messages:
    291
    Hello,

    Please follow these steps in regards to the issue:

    Restart MAC, don't start any applications. Uninstall Parallels Desktop using the .dmg file.
    Now, please follow these steps :

    1. Open Finder.
    2. Go to Applications/Utilities/Disk Utilities.
    3. Choose MAC HD.
    4. Choose repair disk permissions.
    After running the repair disk permissions , restart the computer. Install Parallels Desktop.

    http://kb.wisc.edu/helpdesk/page.php?id=3810
     
  10. This worked for me: http://forum.parallels.com/showthread.php?t=93642. Just switch view modes (from "Window" to "Fullscreen", for example). Quit parallels (suspending the VM). Launch Parallels again, and switch back to your preferred view mode (back to "Window", say).

    Problem solved! (for me, anyway).
     

Share This Page