Parallels Desktop 8.0 and Ubuntu 13.10

Discussion in 'Linux Guest OS Discussion' started by flybabo, Nov 2, 2013.

  1. flybabo

    flybabo

    Messages:
    4
    I can't make Parallels 8.0 works after upgrading to Ubuntu 13.10.
    Apparently, I need an updated Parallels Tools for 8.0 to make this thing works but it appears that Parallels hasn't provided any update for 8.0.
    I bought 8.0 about half year ago - should I buy Parallels every year???
    What a shame!!!!!
     
  2. Nanook

    Nanook Bit Poster

    Messages:
    13
    Same for me. Bought it a couple of months ago and really liked and recommended it. Since PD9 is out I get constant reminders and PD8 is not working properly with my upgraded Ubuntu 13.10 due to compilation errors in the Parallel Tools (huh, no tests with one of the most widespread Linux flavors ?!).
    I ended up setting up a new Ubuntu 13.10 VM from scratch which works now - including data migration etc. etc. etc.. However, not really a recommendation anymore. Setting up a new VM each time after an upgrade of the guest OS is not really an option from my point of view.

    Just my 2 cents.
     
  3. PeterMakBoek

    PeterMakBoek Bit Poster

    Messages:
    3
    Parallels 9 upgrade + Ubuntu 13.10 - issues

    Hi,

    Parallels 9 for Mac

    I installed the default Ubuntu image from Parallels (v13.4 I guess), and activated some tools in it that I use (MySql, Eclipse, MySql workbench, firefox + lastpass + xmarks...).
    Yesterday my Ubuntu upgraded itself to v13.10.
    For some stupid reason, I accepted Parallels itself to get the latest updates too: to v9.0.23350 .

    Problem: I cannot boot any more. After the login screen, I get a message "
    (I tried to upload a screenshot, but the upload files functionality doesn't work - I tried on different browsers)

    System program problem detected..."
    Do you want to report the problem now?
    button Cancel
    button Report problem
    button Close

    Then some text is hidden, I can only see the last part of a screen:
    "tion for monitors"
    "possible modes"
    "at 1680x1050@60Hz (pass 0)"
    "at 1680x1050@60Hz (pass 1)"

    Unfortunately, when clicking on any or pressing enter, everything freezes. I have to press ctr + alt to get mouse movements back alive.
    I can't find a way to launch a terminal to enter commands.

    In other words: I am stuck. Who can help me?
     
  4. usman1

    usman1

    Messages:
    1
    can't make Parallels 8.0 works after upgrading to Ubuntu 13.10.
    Apparently, I need an updated Parallels

    wisedezine
     
  5. flybabo

    flybabo

    Messages:
    4
    You can open a terminal window by Ctrl+Alt->Devices->Keyboard->select Ctrl+Alt+F2.
    And then reinstall Parallels Tools.
     
  6. flybabo

    flybabo

    Messages:
    4
    I installed Parallels 9.0 trial version with updated Parallels tools and then remove the trial version, reinstalled PD8.0.
    It worked except it popped up Parallels Tools installation agent whenever I logged in but I couldn't reinstall PTools but it works.
    I'm not happy with the Parallels' support for the previous version (actually no support other than annoying pop-up for upgrade).
    I'm not buying 9.0, I' rather switch back to VMWare fusion.
     
  7. PeterMakBoek

    PeterMakBoek Bit Poster

    Messages:
    3
    solved - thanks

    This is what I had to find out on top of the doc provided:
    - on MAC: in Parallels I had to manually point the CDROM 1 to the prl-tools-lin.iso
    - in Ubuntu I had to mount the CD ROM (command - if I remember well: mount /dev/cdrom1 /media/parallels/cdrom)
    - then: cd /media/parallels/cdrom
    - run the installer and follow on screen instructions
    - reboot ununtu on parallels, and all seems to be ok.

    Thanks for helping me.


     
  8. endbegin

    endbegin

    Messages:
    1
    Hi

    I was wondering if anyone from Parallels can confirm this? I have not been able to get Parallels tools (with Parallels 8) to work with the latest version of Ubuntu either.

    I have tried other Linux distros with kernel 3.10.x and higher, and it is the same issue. There is a kernel module compilation error.

    Do we have to upgrade to Parallels 9? I just bought version 8 a few months ago!!
     
    Last edited: Nov 29, 2013
  9. newgen23

    newgen23

    Messages:
    8
    The following thread suggest that a new installation of Ubuntu 13.10 works with parallels 8.
    http://forum.parallels.com/showthre...ot-working-launcher-amp-toolbar-missing/page2

    I also upgraded from 13.04 to 13.10 and parallels tools started throwing compiler errors at me. Something about:
    error: implicit declaration of function ‘PDE’

    It looks to me like there could be a minor patch to fix this. Sadly, I don't understand why it does not work.
    prltg.c includes prltg_compat.h, where that PDE crap is defined. Maybe the makefile is broken.

    I also will not buy Parallels 9 for this reason.
     
  10. Nanook

    Nanook Bit Poster

    Messages:
    13
    Hi,

    don't get too excited by my entry :)

    After failing to install Ubuntu 14.04 on my system, i.e. I'm stuck with a unchangeable 800x600 resolution and the Parallels Tools can't be installed due the programming errors (?) in the source code, I tried to install Ubuntu 13.10 again. This worked for the resolution issue so far, however I'm NOT able to install the Parallels Tools due to the error given by the compiler as outlined in the /var/log/Parallels....log file. This might be related to the fact that I recently installed the Parallels Tools 8.0 update as proposed by Parallels via the PopUp...

    Downloading the Linux headers again as described in some other entry didn't help either.

    Sorry,
    Nanook
     
  11. newgen23

    newgen23

    Messages:
    8
    I traced the compiler error back to the file "prltg_compat.h" deeply hidden in the prl_mod.tar.gz
    When compiling prltg.c, it argues that the Function PDE is not defined. In prltg_compat.h you can see the following code:
    #if LINUX_VERSION_CODE < KERNEL_VERSION(2,5,0)
    static inline struct proc_dir_entry *prl_PDE(const struct inode *inode)
    {
    return (struct proc_dir_entry *)inode->u.generic_ip;
    }
    #define PDE(x) prl_PDE(x)


    So, PDE is also called prl_PDE. But I found no definition of prl_PDE für the Kernel 3.11 . PDE stands for "proc_dir_entry" and is defined in linux-headers-3.11.0-20-generic/include/linux/proc_fs.h

    But I am not sure what prl_PDE is supposed to return ... or how to get it from proc_fs.h ... sorry
     
    Last edited: May 12, 2014
  12. Nanook

    Nanook Bit Poster

    Messages:
    13
    Looks strange to me. But analyzing C code is a while ago for me :)

    As stated in a previous entry: I would have expected that a commercial software would support the N-1 release, i.e. PD 8 would be supported even though PD 9 is the current release. And Ubuntu is not THAT "exotic" - rather mainstream - so that you could ignore this distribution for test (assumming that other distributions such as Red Hat etc. don't have that problem. I didn't test that).

    As you said it in another entry, I'm also reluctant to upgrade to PD 9 just because they don't want to cope with PD 8 code errors. Not because of the 50 - 80 bucks but more because I do not want to support such a business practice and because I'm pretty sure that the same happens when PD 10 is out etc. etc.
    While searching through the forum I came across similar compiler errors with Pd 7 when PD 8 was released."
     
  13. newgen23

    newgen23

    Messages:
    8
    Ok. I just installed a fresh Ubuntu 12.04.04 LTS into Parallels and guess what: Exacly the same compiler error like 13.10. After analysing prltg_compat.h, this is not very suprising. All Kernels < 2.5.0 will face this issue. Looks like we will have to switch to vmware or virtualbox, although their support is not really better....

    giving up on parallels for now... lets see if they react to my support ticket.
     
  14. newgen23

    newgen23

    Messages:
    8
    A fresh install of Ubuntu 13.10 also had this compiler error. Same Problem like this thread:
    http://forum.parallels.com/showthre...ouse-not-working-launcher-amp-toolbar-missing

    Thomas posts that Kernel 3.10 had major rewrites in /proc, so Parallels 8 will nor compile with any current Ubuntu Distro.

    It would be helpfull to know, if Parallels decides to abandon the idea of fixing Parallels 8 or if when can expect a solution for our money and when.

    Without any statement, users will be forced to look for alternatives sind Parallels Tools 9 also seems broken.
     

Share This Page