Parallels Desktop 8 WiFi Networking Hijack Problem

Discussion in 'Installation and Configuration of Parallels Desktop' started by BanditoB, Oct 8, 2012.

  1. BanditoB

    BanditoB Bit poster

    I've finally been able to trace back a problem that I've been having recently to Parallels Desktop 8 for Mac, but first a little background information is in order. I'm running a MacBook Pro with Retina Display (10,1), with OS X Mountain Lion 10.8.2 and Parallels Desktop version 8.0.18101. No WiFi issues at home connecting to a Time Capsule and other Airport Express units. Now, onto the problem.

    I recently traveled to one of our other sites and needed to use WiFi to connect to our network (I normally use a Thunderbolt Ethernet adapter in my office). I fired it up and connected to the network just fine, but then noticed that I kept losing network connectivity. The WiFi signal was fine and I was not disconnecting and reconnecting to the access point, but the Mac was simply unable to communicate over the network sometimes. I tried Windows 7 Pro in the VM and it was communicating via the network with no issues at all, even though OS X could not. I thought that there may be some issues with the other site's WiFi configuration, but it is the same as my normal office's, so no dice there. By the way, this is using a bridged connection with the default adapter in the VM. The office WiFi network uses WPA2 Enterprise security with AES encryption and Microsoft PEAP authentication.

    When I got back, I tried the same thing on our network with the same results. Windows VM had no issues over the Mac's WiFi connection, OS X kept losing communication with the network. I started a ping test on OS X to try to see what was going on and it showed that the Mac could see the DNS server for maybe 10 seconds or so and then would not be able to see it for about 20 seconds as the ping request would simply timeout. Then, again for about 10 seconds the Mac would connect and again disconnect. This cycle would repeat over and over endlessly. Very strange. I wondered what on earth could be causing this. I called AppleCare and we removed all the WiFi networking components and reinstalled all of them to no avail. I continued poking around as I got time to and eventually stumbled across the fact that if the VM was shut down or asleep, the Mac would have full WiFi connectivity. Start up the VM and, wham, the Mac would start cycling on and off of the network. I know that I did not have this issue under Parallels Desktop 7, so it definitely has something to do with version 8.

    I called in for support from Parallels and we went through all the standard troubleshooting, reinstalling the desktop tools, tried it in shared network mode, which worked just fine, by the way, and a few other things, but there was no change in what I was seeing in bridged mode to the default adapter. The technician then wanted to see if using one of the virtual NICs would help and it did. Then I had full connectivity in bridged mode on both the Mac and the VM. So, he considered the issue resolved and closed the ticket.

    Here, finally, is my real concern. My system used to work just fine in bridged mode with the default adapter selected under Parallels Desktop 7. I could switch between a wired and wireless connection at will and all would work just fine. Now I have to play around with the configuration and change NICs when changing network connections, which while not that big of a deal is still rather annoying. I don't consider the problem resolved and wish that the technician would have left it open and pushed the issue back to the development team for a real resolution. Does anyone have any thoughts to share about this? Will this post here in the forums make any difference?
  2. simpletcoder

    simpletcoder Bit poster

    I have same trouble too. Your post will useful inform to me.
    (I have PD7->PD8 & Retina MBP & same bridged network trouble)
    Development team have to solve this trouble.
  3. Chris@Parallels

    Chris@Parallels Hunter

    Parallels Support

    Hi from Parallels Support,

    I am asking around about this issue and will update the forum with an answer when I hear back.

    Thanks for adding the discussion in our forums.

  4. Roman Fattakhov

    Roman Fattakhov Parallels Team

    Please use this workaround until the issue is fixed:

    1. Shut down the VM
    2. Open its Configuration > Hardware > Boot Order and paste this flag into "Boot Flags" field:

    3. Start the VM and check the issue. If it is still there, go to Boot Flags again, remove the Boot Flag you have pasted and paste another one:

    4. Start the VM
  5. simpletcoder

    simpletcoder Bit poster

    I tried Roman Fattakhov's way.

    But in case of,
    VM shows message dialog about IP Conflict, and then
    VM's network was enabled but OSX's network was disabled. <- new trouble.

    In case of option,
    Trouble was same(still exist).

    Please update for this problem. I lost many hours because of this trouble.
    Last edited: Oct 14, 2012
  6. xWindows

    xWindows Bit poster

    I've had numerous problems with PD8, and unfortunately the support team are more interested in closing tickets as quickly as possible rather than solving real problems.

    I can't connect to the university wireless network, which uses WPA2 Enterprise security, if I configure PD8 to use a bridged adapter (default adapter). The only way I can connect to that network is by selecting shared adapter.

    Occasionally, PD8 causes wifi connectivity problems at home too. I have to shut down the VM to establish wifi connection. After that, I can restart the VM.

    I've given up on tech support.
  7. Wojda J

    Wojda J Bit poster

    I'm having trouble with a few systems here too. I never noticed it because I'm always wired.

    Similar setup, rMBP, Parallels, WIn7. Wifi doesn't work on Mac, works fine in PC.
    Tried the boot flags, couldn't get it to work.
  8. Dado521

    Dado521 Bit poster

    WPA2 Enterprise

    Same issue. I was able to setup internet proxy to get it to work on the Mac but not the VM. How to I setup the proxy settings on the VM? Thanks.
  9. plevintampabay

    plevintampabay Bit poster

    Thank you BanditoB for starting this thread.

    I too have this problem. I had with PD7 so I upgraded to PD8 in hopes of having the problem get fixed. I could have saved the upgrade cost if I searched this site first.

    I've used PD7 for almost 2 years and I know I did not have this problem all that time. I'll guess and say it started 2-3 months ago. For me it is intermittent - that is, I can have WiFi on both the mac and the Windows 7 (or Win XP) VM, but then after some period of time, I'll loss the WiFi on the Mac. I do not know the period of time, but it seems to be several hours. Exitting PD restores WiFi to the Mac.

    Are the PD developers working on this issue? What do we as users need to do to raise the priority of this problem? Will posting to competitor web sites telling them this problem with PD help?
  10. BanditoB

    BanditoB Bit poster


    Thank you, too, for posting. It's always nice to know that one is not alone in experiencing these issues.

    I'm going to contact support again regarding this issue and see what they can tell me. It's been quite a while since they took all of my troubleshooting logs and whatnot, so they should have been able to resolve this by now.

    I would recommend that you do the same and contact Parallels support directly to report the problem. The more people that complain the higher the probability that the issue will get addressed.

    I have to say that Parallels Desktop 8 has really been a disappointment to me and has certainly taken much of the luster off of Parallels reputation in my mind. Up until version 8, I've never run into any serious issues with the software at all, but 8 has caused me multiple headaches with various problems. I have held off upgrading the rest of the company due to these issues. I'm also getting tired of applying the latest updates to version 8 and hoping that they will fix the problems only to find out that nothing has changed <sigh>.

    At any rate, if I learn of anything more, I will update this post.
  11. Andrew@Parallels

    Andrew@Parallels Parallels Team

    @BanditoB your case had been reported to developers and they are working on a fix. Will update you once we have some news to share.

    @simpletcoder, @xWindows, @Wojda,J, @Dado521, @plevintampabay - guys, please submit the problem reports from your systems (hit Help > Report a Problem) and post the IDs here. It will help us a lot to issue a fix sooner.
  12. billpatt

    billpatt Bit poster

    I've been having this same problem, on multiple Macs from at least PD8 back to PD5.

    The problem exhibits with a regular cycle of lost and regained connectivity on host and VM for me. I've had the problem with Win7, XP, and SnowLeopardServer VMs.

    I've tried the boot flag method with little effect. Usually, after cycling a while, it hangs and I have to restart the host's Airport connection by cycling it off and on. This brings the VM back too, but again, only for a little while.

    Logs don't seem to indicate the cause of the problem.

    I'm a long-time full-time Mac developer, and would be glad to offer my assistance in resolving this issue. Watching the connectivity issue in Activity monitor, it's a very consistent cycle, so some timeout issue would seem to be the cause.
  13. BanditoB

    BanditoB Bit poster


    Thanks for the update! After being referred to a higher-level technician, when they were finally able to call me back, they confirmed that the issue is still being worked on.

    I did a test over the weekend that I've been meaning to do for some time now and have found that wireless networking using Bridged Mode with the Default Adapter under WPA2 encryption works just fine on my home network with no issues. However, at work we use WPA2/Enterprise encryption with Microsoft PEAP authentication on a Cisco commercial wireless system and that seems to be where the conflict lies. Everything's fine on lesser WiFi networks, but under the additional 'strain' of the full-blown commercial system, something's failing.

    Additionally, this network problem shows up when using the Default Adapter or the WiFi adapter under Bridged Networking. Using either of the virtual NICs or switching to shared network mode eliminates the issue. Hopefully this additional information is helpful.

    As Andrew said, if you're experiencing this particular problem, please submit your troubleshooting logs to Parallels and add the report number to this thread. The more we get the better off we'll all be!


    I'm not sure if your networking issue is the same or not. In my case it only came about after upgrading to Parallels Desktop 8. Prior to that, on several different MacBooks, I never experienced any networking issues. Additionally, in my case the host loses connectivity, but the VM does not. I'm not saying that your issue isn't somehow connected, but it does appear to manifest itself somewhat differently. Just some food for thought.
  14. Jean-FrançoisB

    Jean-FrançoisB Bit poster

    Anything new on this issue? The last post is more than 2 months old.

    I am having the same issue. My Macbook Pro's (OSX 10.8.3) internet access is becoming very erratic when my VM is working. If do a ping (let's say the request times vary a lot and sometimes I even get request timeouts. I am usually using Bridged Network mode in my VM (Windows 7). Today, I even lost Internet access on the VM although the host still had internet access. I posted a report to Parallels and here is the ID: 23259949.

    All these network problems with Parallels are really getting me to think to go back to VMware Fusion, which I was using before.


  15. BanditoB

    BanditoB Bit poster


    Thanks for adding your voice to the thread. Every bit helps.

    As far as I know, there is still no fix for this issue. I've retested after each update has been released and am still seeing the same behavior. This is definitely a problem that only cropped up with Parallels Desktop 8. The prior releases were all solid as a rock for me. It is pretty disappointing that we still don't have a resolution to this, yet.

    As a workaround, if you want to select one of the virtual NIC's (Network Interface Cards), vnic0 or vnic1, instead of the Default Adapter, everything should then work as expected. I don't understand what differences there would be between the Default Adapter setting and the settings for the virtual NIC, but something certainly causes problems with the former one.

    Good luck!
  16. Jean-FrançoisB

    Jean-FrançoisB Bit poster

    Thanks BanditoP! I'll try that with vnic1 and see if things are better. Yesterday, I had to reboot my machine twice because of network problems. This is really a lost of time when you are in the middle of your work. I paid for an upgrade to Parallels 8 just to stay up to date, although I did not really need it, and in the end, I should have kept my money and stayed with Parallels 7.
  17. Jean-FrançoisB

    Jean-FrançoisB Bit poster

    When I use vnic0 however, my Mac cannot access my VM. Its name is vm.local and if I enter "ping vm.local" in a shell, it works during the first minutes after I switch to vnic0, but after a while, if I ping my VM again, I get the following error message: ping: cannot resolve vm.local: Unknown host.


  18. BanditoB

    BanditoB Bit poster

    Well, there's been another maintenance release of Parallels Desktop 8, Build 8.0.18480, and I just got through installing and testing it for a fix to this network issue yet again and it's still a no go. It appears that nothing has changed regarding the WiFi hijack issue that I described above. I'm still seeing the exact same behavior.

    I wish that I had better news to report, but, unfortunately, I do not.
  19. Specimen

    Specimen Product Expert

    Can you explain exactly what is the issue in a more summarized way?
  20. Abhijit

    Abhijit Member

    Same Issue

    I have the same issue. My Host (mac 10.8.2) looses network connectivity after coming out of sleep mode.
    But the VM has excellent connectivity.
    In many cases the Host WIFI has Exclamation mark or it shows connected but cannot even reach gateway.

    All along I thought it may be my configuration problem till I stumbled upon this thread.

    There are two guaranteed ways of solving the problem:
    a) Reboot the VM - problem goes away till there is another long sleep
    b) In the guest OS - Set the network to "Host Only" - wait till the host gets full network - then switch back to "WiFi Bridged"

    But this is really painful. Worst part if, if Host is downloading something and goes in sleep then its lost.

    I tried to keep ping to gateway running in a terminal window but after sleep it stops and does not keep the connection.

Share This Page