Parallels Desktop 8 WiFi Networking Hijack Problem

Discussion in 'Installation and Configuration of Parallels Desktop' started by BanditoB, Oct 8, 2012.

  1. boomer88

    boomer88 Bit poster

    I just bought a new MAC mini loaded Parallely-8 and Win7 PRO and have not been able to get wifi on the windows side.(tried the tricks listed above) I'm not tech savvy as most here but hope to be notified when or if there is a fix. I may have to send this MAC back quickly!
  2. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Hi boomer88,

    Your Windows Virtual Machine "inherits" internet connection from the Mac side and you cannot tune it to use a different internet connection other than your Mac does.
    There are three types of networking modes in Parallels Desktop and you can try switching between Shared and Bridged if you're having connectivity issues in the virtual machine.
    Please see page 102 of the User Guide for more information about Parallels Desktop network modes:
  3. boomer88

    boomer88 Bit poster

    Thank you Andrew, I had figured it out but your response is greatly appreciated and may be helpful to some other lost soul in the future... :)
  4. daustinhjr

    daustinhjr Bit poster

    Nearly a year old and this problem still exists in the software. As soon as I turn on bridged mode the mac loses connectivity. Garbage. I'm going back to VMware.
  5. Abhijit

    Abhijit Member

    I found the 100% reproducible steps when HOST looses connectivity while GUEST has no issues.
    Tried it 3 times and issue was reproduced every time.

    Requirements (some are very critical and need patience):
    a) Host: Mountain Lion Latest; Guest: Win7 or Win8 (only 1 guest running to make things simple)
    b) Parallels 9 - Latest
    c) Host connected to WIFI - Guest using Bridged or Shared network
    d) Battery must be very low (say 5%)

    1. Keep the PING to ROUTER (not internet to keep things simple) running on HOST & GUEST and ensure you are getting response
    2. Leave the machine without power and let it hibernate (patience - coffee?)
    3. Once its frozen, put the power cord and start machine. Once HOST is alive - wait for WIFI to connect.
    4. Check the HOST ping response. Its probably dead
    5. In Parallels 9, the GUEST sleeps. Wake up the GUEST - Check the PING
    Surprise: The ping is responding on GUEST but not on HOST.
    6. By this time your machine will be charged 5+%; remove the power
    7. Change the GUEST network to HOST ONLY and set it back to SHARED / BRIDGED
    8. Ping is back on HOST too.
    9. repeat the process from point #1 above.
    >> VOILA <<
    Dev Team, now its up to you.

    Update: Instead of waiting for battery to hibernate, you can try the following:
    a) On HOST run the command => sudo pmset -a hibernatemode 25
    This will ensure you can hibernate as soon as lid is closed (you need to wait for couple of minutes before actual hibernation happens)
    b) Once you have reproduced the issue, reset it back to ORIGINAL (3 for my MBP)
    Last edited: Sep 2, 2013
  6. BanditoB

    BanditoB Bit poster

    Just thought I'd do another follow up to this thread. For me, Parallels Desktop 9 seems to have solved the problem of using the Bridged Network with the Default adapter on WiFi where the host, my MacBook Pro, would regularly lose connectivity, but the guest, Windows 7 Pro, would not! I always had this problem under version 8, but it was the first thing that I tried under version 9 and, so far, it is working as expected!

    It remains to be seen if anything changes when the machine hibernates overnight, but if there are any issues then, I will report back.
  7. Abhijit

    Abhijit Member

    Touch wood, with Parallels 9 and two weeks the problem has not occurred
    Even tried with overnight hibernation.
  8. SrdjanB

    SrdjanB Bit poster

    The problem occurs on Parallels Build 9.0.24172 and new MBP Retina MacBookPro11,3, with OSX 10.9.1

    Macbook is connected via Thunderbolt Display LAN in corporate network and no matter whether WLAN is turned on or off, following happens

    1. Parallels VM started in bridged mode, both guest VM and host Macbook have network connectivity
    2. After ca. 10 minutes, Macbook host looses network connectivity, cannot ping for example, while VM has no issues

    I will check if restarting network services could help as a workaround, until this annoying issue is solved.
    Last edited: Jan 10, 2014
  9. HowardEarly

    HowardEarly Bit poster

    I am seeing a similar issue with Parallels Build 9.0.24172 and new MBP Retina 2013 with OSX 10.9.1. On wired networks I am fine, but as soon as I switch to my corporate network using WPA2/enterprise my MBP 's applications lose network connectivity, but my windows vm continues to be able to connect without issue.
  10. RashadU

    RashadU Bit poster

    I am also having this issue as well - Build 9.0.24217 with a MBP w/ 10.9.2. This issue only occurs when connected to WIFI networks while using bridged mode. Has anyone from Parallel's come up with a way to fix this issue?
  11. Athena Apollos

    Athena Apollos Bit poster

    I too have a Late 2013 MBP w/ Retina running OSX Mavericks v. 10.9.2 and am running Parallels 9 w/ Win7 Pro and my wi-fi keeps dropping on the host side. I have contacted Apple Support and told them that I think it might be Parallels causing the wi-fi drop, but they did not seem to think so. However, I have noticed that I do not have this problem on any network besides my home network (Apple blames my Netgear router), but I only have it when I run Parallels. My VM has a stable connection while my Mac has little to no connection. The DHCP either returns a self-assigned IP address or it keeps rapidly auto-renewing. I run Parallels just to use MS Office 2013 because Word 2011 for Mac is unusable in Mavericks.
  12. chrisflow

    chrisflow Bit poster

    SAME PROBLEM - When parallels is running, wifi speed obliterated on mac mini 2012.

    Running Mac Mini 2012 i7 10.9.4 16GB RAM, latest Parallels with Windows 8.1 VM. When the VM is running, my download speed on Mac side drops from 16 Mbps to < 1 or mostly, it barely functions at all! When I suspend or pause the VM, the download speed on Mac is restored to 16 Mbps! The download speeds inside the VM are abysmal, of course.

    Strangely, disconnecting the Networking in the Parallels configuration does nothing to alleviate the problem. Simply having my VM running will seriously slow to nothing, my internet connection on the Mac side (and the VM connectivity as well). Also, lowering the number of cores dedicated to the VM (down to 2, out of 8) does nothing to help.

    I've had to run a Cat5 cable for months in order to use internet because that seems to be the only workaround to this issue.

    Truly awful. May be time to ditch Parallels because this problem seems ongoing and totally unrecognized by Parallels.

    Last edited: Jul 29, 2014
  13. Devino

    Devino Bit poster

    I'm now doing OSX support for our Company, which has always been a Windows based corporation, as we are recently doing Business on the MAC side of things and are growing quickly on this side. I have tested both Parallels Desktop 9 and VMware Fusion 6. We use WPA2/Ent with 802.1x authentication for wireless.

    Unlike you guys, I have seen NO issues on the host side NIC. But when I enable bridging in PD9 on the guest, my guest seems to have the exact same issues described here: Gets a connection, gets and IP, loses IP, gets DHCP timeout IP/169.254.x.x, gets a connection, gets and IP, and so forth looping around and around. No pings work during this process at anytime when the guest is set to bridged. Host never has an issue.

    VMware Fusion 6, works like a charm. Can switch it back and forth between Bridged and NAT.

    So... Parallels, what do you want me recommending to my users who need to access their Windows VMs remotely from systems they are working on?
  14. marat_t

    marat_t Pro

  15. marat_t

    marat_t Pro

    Hi Chris,

    Please make sure that your router is configured to allow at least 2 IP addresses (Mac + VM) for the same MAC.
  16. bruno1

    bruno1 Bit poster

    Im having the same issue, any news on this, its very annoying to restart the mac every time, several times in the day...

    MacBook Pro (Retina, 15-inch, Late 2013)
    2.6 GHz Intel Core i7

    Version 10.1.0 (28600)

    i was not having this issue in parallels 9, i update to 10, i get constantly this error!, i have pay for an update that doesnt work, it does not make any sense
  17. Goetz

    Goetz Bit poster

    Hi, I am having the same issue. I could trace it back to some degree. I use dhcp reservations in the network (wifi mode, not bridged on parallels). The IP adress for the mac adress for apple is x.x.x.120; the one for the virtual windows adapter is x.x.x.123. When I use a different wifi and come back home I see the IP reserved for the apple Mac address assigned to my windows machine. Parallels seems to have an issue to correctly assign IP adresses to the machines in this case.

    Parallels 10 with Windows 8.1 on late retina mac book pro

Share This Page