Parallels Desktop 9 crashes on Yosemite DP 6

Discussion in 'General Questions' started by JulioC, Aug 18, 2014.

  1. kirkus

    kirkus Bit Poster

    Messages:
    2
    Id: 48858367
     
  2. Matt1505

    Matt1505

    Messages:
    3
    Ok, so see below the output from Console. Looks like a conflict between some duplicated frameworks - I assume previous versions of the OS didn't carry the frameworks natively or implemented them differently. However, I don't know enough about OS development to be able to try disabling one or forcing Parallels to use one over the other.

    I have tried examining the Parallels version of the frameworks - you can drill down through to the plist files which I think probably reference other files to use... there may be something in there to play around with, but there's nothing to say "use this = TRUE" or anything obviously similar.

    For example, drilling down through /Applications/Parallels Desktop.app/Contents/Frameworks/QtWebKitPrl.framework/Versions/4/QtWebKitPrl, the plist file reads:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist SYSTEM "file://localhost/System/Library/DTDs/PropertyList.dtd">
    <plist version="0.9">
    <dict>
    <key>CFBundlePackageType</key>
    <string>FMWK</string>
    <key>CFBundleShortVersionString</key>
    <string>4.9</string>
    <key>CFBundleGetInfoString</key>
    <string>Created by Qt/QMake</string>
    <key>CFBundleSignature</key>
    <string>????</string>
    <key>CFBundleExecutable</key>
    <string>QtWebKitPrl</string>
    <key>NOTE</key>
    <string>Please, do NOT change this file -- It was generated by Qt/QMake.</string>
    </dict>
    </plist>

    Console output below:

    19/08/2014 15:13:55.866 prl_client_app[2642]: objc[2642]: Class WebCoreMovieObserver is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore and /Applications/Parallels Desktop.app/Contents/Frameworks/QtWebKitPrl.framework/Versions/4/QtWebKitPrl. One of the two will be used. Which one is undefined.
    19/08/2014 15:13:55.866 prl_client_app[2642]: objc[2642]: Class WebCoreSharedBufferData is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore and /Applications/Parallels Desktop.app/Contents/Frameworks/QtWebKitPrl.framework/Versions/4/QtWebKitPrl. One of the two will be used. Which one is undefined.
    19/08/2014 15:13:55.866 prl_client_app[2642]: objc[2642]: Class WebVideoFullscreenWindow is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore and /Applications/Parallels Desktop.app/Contents/Frameworks/QtWebKitPrl.framework/Versions/4/QtWebKitPrl. One of the two will be used. Which one is undefined.
    19/08/2014 15:13:55.866 prl_client_app[2642]: objc[2642]: Class WebVideoFullscreenController is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore and /Applications/Parallels Desktop.app/Contents/Frameworks/QtWebKitPrl.framework/Versions/4/QtWebKitPrl. One of the two will be used. Which one is undefined.
    19/08/2014 15:13:55.866 prl_client_app[2642]: objc[2642]: Class WebVideoFullscreenHUDWindowController is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore and /Applications/Parallels Desktop.app/Contents/Frameworks/QtWebKitPrl.framework/Versions/4/QtWebKitPrl. One of the two will be used. Which one is undefined.
    19/08/2014 15:13:55.866 prl_client_app[2642]: objc[2642]: Class WebVideoFullscreenHUDWindow is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore and /Applications/Parallels Desktop.app/Contents/Frameworks/QtWebKitPrl.framework/Versions/4/QtWebKitPrl. One of the two will be used. Which one is undefined.
    19/08/2014 15:13:55.866 prl_client_app[2642]: objc[2642]: Class WebWindowFadeAnimation is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore and /Applications/Parallels Desktop.app/Contents/Frameworks/QtWebKitPrl.framework/Versions/4/QtWebKitPrl. One of the two will be used. Which one is undefined.
    19/08/2014 15:13:55.866 prl_client_app[2642]: objc[2642]: Class WebWindowScaleAnimation is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore and /Applications/Parallels Desktop.app/Contents/Frameworks/QtWebKitPrl.framework/Versions/4/QtWebKitPrl. One of the two will be used. Which one is undefined.
    19/08/2014 15:13:56.246 prl_client_app[2642]: objc[2642]: Class SLTimer is implemented in both /Applications/Parallels Desktop.app/Contents/MacOS/prl_client_app and /Applications/Parallels Desktop.app/Contents/Resources/libprl_shared_apps.dylib. One of the two will be used. Which one is undefined.
    19/08/2014 15:13:56.256 prl_naptd[2604]: Exiting Parallels Network Daemon
    19/08/2014 15:13:56.331 Parallels[2710]: Stopping Parallels Dispatcher Service
    19/08/2014 15:13:56.346 Parallels[2714]: Stopping Parallels networking
    19/08/2014 15:13:56.357 Parallels[2717]: error Cannot find pid for /Applications/Parallels Desktop.app/Contents/MacOS/prl_naptd
    19/08/2014 15:13:56.374 Parallels[2719]: Parallels Networking was stopped
    19/08/2014 15:13:56.397 Parallels[2722]: Unloading kernel extension prl_netbridge.kext
    19/08/2014 15:13:56.617 Parallels[2730]: Unloading kernel extension prl_vnic.kext
    19/08/2014 15:13:56.806 Parallels[2737]: Unloading kernel extension prl_usb_connect.kext
    19/08/2014 15:13:56.992 Parallels[2744]: Unloading kernel extension prl_hid_hook.kext
    19/08/2014 15:13:57.153 Parallels[2751]: Unloading kernel extension prl_hypervisor.kext
    19/08/2014 15:13:57.329 Parallels[2758]: Unloading kernel extension prlufs.kext
    19/08/2014 15:13:57.512 Parallels[2770]: Reset owners for /Applications/Parallels Desktop.app/Contents/Library/Extensions/10.9
    19/08/2014 15:13:57.797 Parallels[2841]: Starting Parallels Dispatcher Service
    19/08/2014 15:13:57.813 prl_naptd[2835]: Starting Parallels Network Daemon (proxy_mode)
    19/08/2014 15:13:57.815 prl_naptd[2835]: Failed to start: error 809; Parallels Network Daemon will restart in one minute or after receiving of some signal.
    19/08/2014 15:13:58.612 Parallels[2858]: Wrong signature of Parallels Dispatcher Service
     
  3. TracyB

    TracyB

    Messages:
    1
    Thank you. That was able to get me back going.
     
  4. Nekrich

    Nekrich

    Messages:
    1
    Same here. Still get Parallels quitting without launching with 9.0.24229&last one.
     
  5. Edwinch

    Edwinch Bit Poster

    Messages:
    1
    Report ID: 48859770
     
  6. Nate T

    Nate T Bit Poster

    Messages:
    1
    I had the same troubles as many of you here. I was able to get 9.0.24229 running by using the following commands in Terminal:

     
  7. kirkus

    kirkus Bit Poster

    Messages:
    2
    99999.99999% sure you're right. Running spctl against the app bundle gives:

    Code:
    spctl -a -t exec -vv /Applications/Parallels\ Desktop.app/
    /Applications/Parallels Desktop.app/: rejected
    source=obsolete resource envelope
     
  8. Robert@CIPA

    Robert@CIPA

    Messages:
    5
    This worked for me...thank you!!!
     
  9. Nelson Quan

    Nelson Quan

    Messages:
    1
    same issue and hope can fix it soon. I need windows
     
  10. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    633
    The workaround has been confirmed. Instructions available at http://kb.parallels.com/122670 help to run Parallels Desktop 9 on Yosemite DP6.
    Thanks all for your active participation!
     
  11. Beachside

    Beachside Bit Poster

    Messages:
    2
    This doesn't work for me ... Terminal responds with:
    Mac-Retina:~ jdoe$ sudo /Applications/Parallels\ Desktop.app/Contents/MacOS/Parallels\ Service.app/Contents/MacOS/prl_disp_service -e
    WARNING: QApplication was not created in the main() thread.
    QFileSystemWatcher::addPath: path is empty

    Anyone else have any luck?
     
  12. Robert@CIPA

    Robert@CIPA

    Messages:
    5
    (Note this is not my workaround it was posted on page 3 of this thread
    http://forum.parallels.com/showthre...-Yosemite-DP-6&p=747450&viewfull=1#post747450)

    Andrew, Thank you for the kb article... it maybe useful to add a comment to the article in case that doesn't work properly.

    If I follow the directions on the KB parallels does not startup but instead gives me "Problem ID: 15381" Unable to start Parallels services.

    I found I have to do the following to make it work.
    1) Start the service as described in the KB. (You should see the following line.. "WARNING: QApplication was not created in the main() thread."
    2) Start Parallels Desktop
    3) click on the terminal window and ctrl-c the service then hit up and enter to start the service again.

    After starting the service the second time you will see the following and Parallels Desktop loads.
    "WARNING: QApplication was not created in the main() thread.
    /Library/LaunchAgents/com.parallels.vm.prl_pcproxy.plist: No such file or directory
    QFileSystemWatcher::addPath: path is empty
    QFileSystemWatcher: failed to add paths: /Library/Logs/DiagnosticReports"
     
  13. Robert@CIPA

    Robert@CIPA

    Messages:
    5
    Is there a reason my post keeps dissapearing?
     
  14. gnomehole

    gnomehole

    Messages:
    2
    I have the exact same issue.
     
  15. MoofMac25

    MoofMac25 Bit Poster

    Messages:
    7
    That does not do the trick for me :(

    sudo /Applications/Parallels\ Desktop.app/Contents/MacOS/Parallels\ Service.app/Contents/MacOS/prl_disp_service -e
    WARNING: QApplication was not created in the main() thread.
    QFileSystemWatcher::addPath: path is empty
     
  16. JohnRav

    JohnRav Bit Poster

    Messages:
    13
    I too was not able to get this "fix" to work. However, I just got it to launch by doing the following: run the command in terminal...then launch Parallels....then while it is launching paste the command into terminal again and hit enter. This finally got it to launch for me.
    Worth a try.
     
  17. D-an-W

    D-an-W Bit Poster

    Messages:
    35
    I realise we have to run the command every time prior to starting Parallels but do we also have to leave the command running in terminal while Parallels is in use?
     
  18. EssaouirAB

    EssaouirAB Bit Poster

    Messages:
    3
    Still Nothing

    Andrew, thanks for the post -- but as you can see, this seems to only work for a small subset of users. When can we expect a fix / when should I be checking the download page? This is crippling.
     
  19. Ricsne

    Ricsne

    Messages:
    3
    Its important to point out two solutions that this thread is currently tracking -

    1) If you use the latest version of Yosemite 10.10 Beta Release 6, and your using the latest version of Parallels Build 9.0.24237, you will need to follow the procedures using the terminal command (and in some cases you will have to perform the "quick switch between starting the Parallels desktop, and re-issuing the terminal command")

    2) If you don't want to have to perform the terminal command, you can locate and download a previous versions of Parallels Build 9.0.24229, and INSTALL it... do not attempt to restore Parallels from Time Machine. That does not seem to work.

    You can also chose to downgrade your version of the Yosemite 10.10 back to Beta 5.

    Hope this clears some of the confusion. I am currently running the latest Beta with the latest Parallels build, and using the "quick terminal commands" listed in earlier threads and so far its functional. I also have a MacBook Pro 2011 (loaded)
     
  20. barnrose

    barnrose

    Messages:
    1
    Parallels Desktop 9 Yosemite DP6 - Script Fix

    Like many I had a problem running Parallels Desktop 9 on Yosemite DP6 and the solution posted helped me.

    However, I don't have a password so each time I had to create a password to run sudo which is annoying.

    So I created this script that runs the command and no password is needed. Its basic as i'm not an expert.

    I put the script in my applications folder and then in my dock and run it and then open parallels and it works. The script closes when you quit parallels. You need to run the script and then open parallels.

    Hope this makes it easier for others and thanks all for your help.


    View attachment Parallels.zip

    *EDIT* I am not an expert so if someone can make it automatically open Parallels after pressing OK it would be great.
     
    Last edited: Aug 19, 2014

Share This Page