Parallels Desktop 9 crashes on Yosemite DP 6

Discussion in 'General Questions' started by JulioC, Aug 18, 2014.

  1. gRobert

    gRobert Bit poster

    What? Parallels BETA 10? We only have normal PD10, maybe BETA is a problem.
  2. Pullen

    Pullen Bit poster

    I installed Parallels Version 10 from the above link as a trial. This seems to fix the Yosemite Beta 6 problem and started successfully, but on my iMac Parallels 10 only uses CPU core 0 and nothing else, so I can not say that Version 10 is something which you should use. I wasn't able to start my Windows 8 with it in the expected time.
  3. gRobert

    gRobert Bit poster

    So add more cpu cores in VM config.
  4. thephw

    thephw Bit poster

    Please resign your software for the new OS version. Like everyone else.
  5. onurgozupek

    onurgozupek Bit poster

    This is a quick but temporary solution:

    open terminal and run:

    sudo /Applications/Parallels\\ -e & sudo /Applications/Parallels\
    enter your account password and press enter.
  6. Pullen

    Pullen Bit poster

    because I didn't change the VM configuration I thought it was still set to 8, but you are right it has been changes (magic) to two cores.
    Now changed it back to 8, but still Core 0 is used more than before. But the others are now included as well.
    Still slower as Version 9 and Core 0 fully blown.
  7. Kulfon250

    Kulfon250 Bit poster

    Problem maybe it's in Beta, but if you have Beta, PD10 don't install like trial, only with buying code :) great :) Beta code it's valid to October 22, 2014 but with don't work program. I have Parallels form 4 version, this move make mi ungry, and i buy VMware Fusion this program work without problem with all Yosemite Beta :) without buying special version without trial.
  8. twynne

    twynne Hunter

    Just download the release version of PD10, install, and during the installation (when prompted for the key) it gives an option for trial.
  9. JulioC

    JulioC Bit poster

    I read that PD10 works on DP6 but I don't plan on buying the new version just to get support that was promised for PD9. The terminal fixes didn't work for me so I guess I'm patiently waiting for a new PD9 build which corrects this issue (many people also have this issue on the latest Mavericks 10.9.5 beta so Parallels better fix this issue fast, because that point update is sure to arrive faster than the Yosemite GM).
  10. KonradN

    KonradN Bit poster

    Hi all!

    I can confirm that this workaround worked on my system, but PD started with the new vm wizzard which I had to cancel. And then the list of existing VMs was empty so I had to open them manually (No big thing but of course not nice).

    The direct download link of PD 10 worked for me. I followed the other link first and was able to find out that I should receive the update for free (bought PD 9 two days ago). Using the direct download link + requesting a test license worked for me. And starting PD now shows me a list of my VMs and everything is as expected again.

    Thank you all for your help / assistance.

    With kind regards,

  11. kingrol

    kingrol Bit poster

    ok that would help out while we wait for a P9 fix, but what's going to happen after the trial period is over or the fix comes in? Will you be able to remove P10 and switch back to P9? I'm sure P10 is great but I really have all I need with P9, which I didn't buy that long ago and only really intend to upgrade every few years when things get really outdated.
  12. Lord3n0ch

    Lord3n0ch Bit poster


    I was able to make it work. Make sure that the first time you launch the command in the terminal and run the Parallel Desktop, execute the command again before the Parallel Desktop terminates. If your timing is precise, Desktop will start successfully.

    The trick is, you have to issue the command in the terminal before you run the parallel desktop and run again before the parallel desktop stops.

    Good luck.
  13. snodman

    snodman Member

    I had upgraded to Parallels 9 from 8 earlier this month when the announcement was made about the free update to version 10 when it got released. Just wanted to say Parallels emailed me a version 10 key today without me even asking for one and the upgrade to version 10 went smoothly and fixed my launch problems with the latest Mavericks developer beta. Parallels 10 is running swimmingly for me on a 2011 iMac 4 core and all my cores still work in Parallels 10. THANKS for the great support! :)
  14. Octo07

    Octo07 Junior Member

    After a few second
    I get this
    WARNING: QApplication was not created in the main() thread.
    then I can see a task name prl_disp_service in activity monitor
    but as soon as i started parallels it goes away.

    If I wait longer
    i get both
    WARNING: QApplication was not created in the main() thread.
    QFileSystemWatcher::addPath: path is empty
    the task named prl_disp_service is there
    I start parallels then I can see the progress wheel turning but it just stay there
    Last edited: Aug 21, 2014
  15. Allber

    Allber Bit poster

    My OS X version is OS X 10.9.5 (13F18) - the latest beta of 10.9.5
    RequestId - 49018306

    I manage to force work the workaround.
    1.Start process from Terminal.
    sudo /Applications/Parallels\\ -e
    Process shows the warning "QFileSystemWatcher::addPath: path is empty" and continue to work, not terminated.
    2.Start Parallels Desktop.
    3.Return to the Terminal. Don't wait till process terminates. Break it by the pressing Ctrl+C.
    4.After break immediately start the process again by pressing key Arrow up and then Enter.

    Thats all. Parallels starts to work.
    In terminal there are the follows errors:

    QFileSystemWatcher: failed to add paths: /Library/Logs/DiagnosticReports
    launchctl: Couldn't stat("/Library/LaunchAgents/com.parallels.vm.prl_pcproxy.plist"): No such file or directory
    nothing found to load
    content-type missing in HTTP POST, defaulting to application/octet-stream
  16. Octo07

    Octo07 Junior Member

    Thank you, it work for me.
  17. Contradel

    Contradel Junior Member

    Any word on the official fix?
    I know I'm using beta software, so I can't complain. But it's fixable by running a terminal command, should be an easy fix for a commercial business.
    I'm a bit worried that Parallels cannot update, as the check for updates is greyed out.

    I have considered the PD10 upgrade, but only after Parallels shows that they care about their previous costumers.
  18. Sukrit

    Sukrit Bit poster

    PD9 crashing with Yosemite beta

    I agree 100% that as a customer who has purchased PD9 a month back I'd like to see some sense of support before reaching for my wallet once again.
  19. suseshar

    suseshar Bit poster

    John Rav's trick works

  20. MartynGil

    MartynGil Bit poster

    Auto Start

    i just created a script to start it automatically and it works fine. no need to keep terminal open.

    Open terminal and paste:

    cd ~
    mkdir parallels
    touch ./parallels/
    chmod a+x ./parallels/

    open in your favourite editor and paste this then save exit.

    if [ -f $root/$instance/ ]
      if kill -0 `cat $root/$instance/` 2> /dev/null
        echo "Parallels Service is already running"
    /Applications/Parallels\\ -e  &
     echo $! > $root/$instance/
    ) > /dev/null 2>&1

    then you need to make it run automatically on reboot:

    sudo crontab -e and paste @reboot /Users/martyn/parallels/
    ctrl + x + y to exit and save in nano

    for some reason on the OS X beta this uses VI as the default editor instead of nano, you can change it using:

    export EDITOR=/usr/bin/nano

Share This Page