Parallels Desktop and M1/M2 Ultra chips

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by Mikhail Ushakov, Mar 10, 2022.

  1. AlbanV

    AlbanV Bit poster

    Messages:
    2
    Were you able to use your inbuild webcam?
     
  2. JoachimV

    JoachimV Member

    Messages:
    21
    Well the intel on the ref site is wrong for M1 Macs as you cannot select anything higher than 8 cores with those machines even with the Pro version. Which isn't that bad on my 10 Core M1 Pro but of course is very annoying on 16+ Core systems.

    So, either deliver the promised specs or correct that info page.
     
    snnrman and madamm like this.
  3. madamm

    madamm Junior Member

    Messages:
    11
    Now there is another player in the VM marktet - an open source software called 'VirtualBuddy' - it virtualizes OSX 12.3 upwards and also OSX 13 beta. With good but not complete graphical UI ( but much better then Parallels, https://github.com/insidegui/VirtualBuddy ). Let us hope (for the next update ) that Parallel will step upon and will go further.
     
  4. snnrman

    snnrman Bit poster

    Messages:
    2
    Well I guess now they have workaround only for $99.99. Fixing PD 17? Nah. Selling bugfixes? Yeah
     
    JoachimV likes this.
  5. chargio

    chargio Bit poster

    Messages:
    5
    I can't install parallel tools 18 in RockyLinux 9.
    Version 18.0.0.53049
    After installing and enabling epel, I run the installer
    Message "An error occurred when installing Parallels Tools"

    The logs complain about mod_probe not being able to find prl_tg in /lib/modules/5.14.0-70.17.1.el9.aarch64

    My laptop is a Macbook pro M1 max w
     
  6. SergioI1

    SergioI1 Bit poster

    Messages:
    3
    I have tried VirtualBuddy and UTM, for me they both have the same issue, where apple id login does not work....
    I need store connectivity to test my app :(
     
  7. Kapi

    Kapi Bit poster

    Messages:
    1
    Hello, I have a problem with the installation process of Windows 11 on my Mac Studio, and I have no idea how to solve it.
    Each time it finishes downloading, the Installation Assistant window pops out and I choose the language and country. Afterwards when I click the Install button an error message pops up saying "Windows setup encountered an internal error while loading or searching for an unattend answer file", I got this error message the 5th time already. Please help me solve it.
     
  8. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    499
    Hello!
    Please provide us with the following information:
    - reproduce the issue once again and generate a technical report once the issue occurs: https://kb.parallels.com/en/9058 . Once done, send me the 9-digit ID of the report, please.
    - provide us with the name of the virtual machine;
    - send us the .iso file for Windows that has been downloaded by Parallels Desktop: it should be located in your Downloads folder on Mac. E.g. in my case it is: /Users/mikhailushakov/Downloads/22000.318.211104-1236.co_release_svc_refresh_CLIENTCONSUMER_RET_A64FRE_en-us.iso
     
  9. FilipR

    FilipR Junior Member

    Messages:
    14
    How many CPU's are supported by Parallels 18 on a M2 Ultra?
     
  10. Grey Shadow

    Grey Shadow Member

    Messages:
    29
  11. DamonC2

    DamonC2 Bit poster

    Messages:
    1
    I just purchased a new Mac Air M2 chip. I have used Parallels for over 10 years to support my legacy Windows 7 and XP programs.
    After installing the V18 upgrade, and running Parallels I get the following message: "Operating System not compatible with this computer"

    Is this an issue of the Legacy Windows OS systems?
    Is there a fix?

    Please help--this is an operational issue for my business.
     
  12. Grey Shadow

    Grey Shadow Member

    Messages:
    29
    There is no way to run "old" VMs that are based on Windows x32/x64.
    Parallels on M1/M2 can only run Windows 11/ARM64-based VMs. No Windows 7/10/11 VMs that were originally based on Windows/Intel
    Solution: Recreate the VMs from scratch
     
    Dmitry@Parallels likes this.
  13. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    705
    To my regret, @Grey Shadow is right. Virtualization technology is powered by the CPU hardware thus having the same architecture, meaning that we can only run an Intel-based OS on an Intel-based computer, and an Arm-based OS on a Mac with Apple silicon (which is Arm too). Due to fundamental differences in x86-64 (widely known as "Intel" but originally created by AMD and called AMD64:) ) and Arm architectures, legacy Windows OS can't be run on new Apple computers - they simply don't have an Arm-based version. Cheer up, however, because Microsoft did invest a lot into keeping backward compatibility with legacy Windows programs, so more than 200,000 of Windows apps originally designed for "regular" Intel-based Windows version still work great in Windows 11 on Arm that Parallels Desktop runs on a Mac with Apple silicon.

    Tl;dr
    Please create a new Windows 11 VM and try installing the desired software, there is a good chance it will work. Feel free to post the software name(s) and maybe I can say for sure whether it's going to work or not.
     
  14. Ron Hammer

    Ron Hammer Bit poster

    Messages:
    5
    I'm wondering what sort of performance improvements people are seeing with Parallels 19 and M1 or M2 chips? I have an M1 Macbook Pro and have just upgraded it to Parallels 19. I'm seeing some performance improvements, but had hoped for more.

    Would I need to create a new VM to get the full benefit of the new version?
     
  15. Ivan49

    Ivan49 Bit poster

    Messages:
    1
    Salve a tutti, vorrei sapere se è possibile installare 2 versioni diverse di parallels sul mio Macbook M1, Grazie
     
  16. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    Messages:
    539
    Ciao,
    Tieni presente che è possibile installare e attivare solo una versione di Parallels Desktop alla volta.
    Grazie.
     
  17. MilanH1

    MilanH1 Bit poster

    Messages:
    1
    Can you help me? In GTA V game shut down after the opening scene when the bomb explodes.
    ID: 436671639
    THX
     
  18. Avinash Bundhoo

    Avinash Bundhoo Staff Member

    Messages:
    472
    Hello,
    Thank you for your feedback.
    Please be informed the issue you have encountered is known to our Development team and we have passed along the provided data to them.

    In the meantime, to keep abreast of potential fixes and updates, you can subscribe to this article https://kb.parallels.com/en/129860 and click on the "get updates" button to be notified of future updates.

    Thanks
     
  19. lostinlodos.

    lostinlodos. Bit poster

    Messages:
    5
    dosbox. I installed DosBox in windows 11 arm and installed windows 98SE into DB. My old win-16 apps run fine, though these are very basic apps and games.

    windows 32 apps should run rather smoothly in ARM windows. Reports show Intel 32 apps often running even better via the windows translation that's built into win 10/11 arm.
     
  20. Dan33

    Dan33

    Messages:
    2
    I am running Sonoma 14.1.2 with Paralells standard and windows 11 pro and have been trying to instal metatrader 5 app and i receive an error.
     

    Attached Files:

Share This Page