Parallels Desktop for Mac build 3036 Beta is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Dec 1, 2006.

Thread Status:
Not open for further replies.
  1. NoComment

    NoComment Bit poster


    sometimes stupidity is endless: just needed to deactivate the windows firewall, now everything works fine when it comes to connecting from outside. still no idea how to switsch the connection type to shared or host.-only.....
  2. grebo

    grebo Bit poster

    I am using CA Anti-Virus on my Windows XP Bootcamp partition - which works fine when I boot into it directly, however I am unable to 'secure' my system using my Bootcamp partition under Parallels.

    The error message reads 'An error was encountered while trying to secure your system. Please try a product update to make sure you have all the required files.'

    Product updates indicate I have the most up to date version. Any ideas?
  3. BillyDee203

    BillyDee203 Bit poster

    I took a cursory look at the forum before posting and unless I missed it I didn't see an applicable response. If this is a duplicate I apoligize in advance.

    I installed the beta on a new 20" iMac. Installed Windows XP Pro on the boot camp partition, installed the Boot Camp tools on the XP installation and then installed Parallels. I keep getting the response "unable to open image Boot Camp". I re-created the VM using the "Typical" choice and made certain the settings for the drive were configured as "Boot Camp" and IU still get the same error (except once in awhile I will get the gray screen informing me to hold the power button down to power down and restart). I know there are people using this so I'm assuming it's something that must be simply misconfigured on my part. I'm using the newest Boot Camp on this iMac and the OS is reved up to 10.4.8.

    The software looks great and once I can get it working with the Boot Camp partitiion is will certainly fill in the very need I have for it.
  4. studodd

    studodd Bit poster

    USB issues...

    Sorry to trouble.. i am new to mac and parallels. I am runing windows XP home ed and tring to download data (SRM training data from a cycling power meter), however, i keep losing the data as the computer takes more that 4s to respond??? does this make sense to anyone? Basicall i attach the power device via a keyspan to the USB whilst in Parallels and XP. it starts ti down load then something happens such that after 4s the data stops transferring.... do i need th update to parallels (only bought from website a week ago)...? help please as i am a computer biff!
  5. scarnie

    scarnie Bit poster

    ...however it is possible with Vanderpool (and AMD's equivalent) processor level extensions.
  6. mcs_service

    mcs_service Bit poster

    Check for a Disk-Image in Explorer that is from Parallels after selecting "Install Parallel Tools". That's where the setup programs of the Tools are.

  7. pcolag8r

    pcolag8r Member

    My experiences; Info to help Debug

    I did figure one thing out that is causing a problem and I can repeat the error.

    My setup:
    Macbook Core Duo w 120gb HD 2g ram
    OSX 10.4.8 all updates
    PDM 3036 Beta
    "One internal hd" partitioned with Bootcamp (ntfs) and OSX
    Bootcamp has WinXPPro with all updates and activated (ntfs)
    PDM installed running a virtual machine with virtual hd no problem (winxppro)

    Problem 1 (repeatable error and fix):
    After downloading 3036 Beta, I wanted to use the bootcamp partition (new feature). When trying to create a new vm and use the bootcamp install, I could not select bootcamp (greyed out). I also tried to add the bootcamp hd to my existing vm and it was greyed out to. Bascially it's greyed out because PDM thinks bootcamp is not installed for some reason. I finally narrowed it down to having an external fw hd plugged in and mounted. When I unplug the fw hd, PDM recognizes bootcamp and when I plug it in it won't. It does the same thing with a usb2 external hd. Keep in mind my bootcamp and osx are all installed on the internal drive. I can use my bootcamp with both of the available methods (run vm with bootcamp partition and use bootcamp as second drive in vm) with no problem as long as my external drives are not plugged in. I hope this helps and would glad to provide further informaiton if needed.

    UPDATE! After starting the vm (bootcamp hd) with the external drives unplugged, I re-attached them and there seems to be no problem. Therefore, it looks as though the problem is with the check that PDM is using on vm creation and startup. The vm seems to function fine with the external drives attached post startup.

    Problem 2 (no resolution):
    I setup PDM (new vm) to use my bootcamp partition. I'm asked to reactivate windows every time. I'm asked to reactivate windows now everytime when I boot directly into bootcamp as well. This sucks. I'm using the profiles created by PDM correctly. This needs to be resolved. For now, I've reactivated Windows in Bootcamp. Then, when I'm in OSX running a vm, I just use the Bootcamp partition as a second hd which works much faster the virtual hd. However, ultimated I only want one Windows install on my system...not two as I now have.

    Hope this helps.
    Last edited: Dec 12, 2006
  8. hairyneanderthal

    hairyneanderthal Member

    Still too unstable

    Some nice features in this beta. Coherence, being able to use Bootcamp etc.. which I had working for a while so I understand their attraction.
    However I sort of think this got released too early.. even for a beta.
    I ran into problems very quickly, particularly with video glitches whenever I did a coherence, full screen or window change.
    The worst problem I have had though is that I have had to do a repair installation on my bootcamp partition to be able to run it from bootcamp again after it BSOD'ed in Parallels. After getting the bootcamp partition working again, even after re-installing Parallels tools for bootcamp it would not run in Parallels anymore, not even in safe mode - it would just give a nasty BSOD.... so I have gone back to 1970 and my harddisk file for the moment. Whilst I don't have anything critical on my Windows side (so thought I should be okay to beta test - I have before without problem) I would still like to keep my Windows available for the moment.
    I am also a little worried that now Parallels has ventured in playing with the partitions that bugs will manifest themselves not just on Windows but on my OSX partition... perhaps I am being paranoid here...

    I have to say though, whilst I have had problems it is great to see Parallels coming up with these great ideas and look forward to seeing the stable release.

  9. Blaster

    Blaster Member

    Please use better file names in the /System/Library/Extensions folder. Currently, Parallels for Mac tramples all over the Extensions folder and installs ambiguously named files such as "ConnectUSB.kext", "helper.kext" and "hypervisor.kext". You are not the only company that installs items in the Extensions folder. All of the Parallels kernel extensions should be named in a way that identifies them as belonging to Parallels. It would be better if all extensions installed by Parallels started with the same prefix so they are listed together and easier to distinguish from files installed by other developers. For example, all the Parallels items in the extensions folder could start with "Pvs" so we have "Pvshelper.kext", "Pvshypervisor.kext", etc.
    Last edited: Dec 12, 2006
  10. thosparker

    thosparker Bit poster

    Beta 3036 Performance

    I thought I'd comment that the new features in beta 3036 are really outstanding, but that my machine has taken a huge performance hit under 3036. Using coherence has even caused some temporary hanging. I hope we see some improvements in future builds.

    I'm running a 17" MacBook Pro, OS X 10.4.8, 2 GB of RAM.
  11. whytyger

    whytyger Member

    AMEN! Some times it is good to be able to uninstall manually.
  12. pcalver

    pcalver Junior Member

    There are many, many similar messages in the forum about this exact issue, and no fix as yet. Many more about problems with activation of Windows for "new hardware" due to switching from Boot Camp to Parallels VM. Again, no response yet from the developers.
  13. Sideways

    Sideways Member

    Santa Please Can I have ?

    Very Happily using 3036. I know lots of development work going on etc, BUT ... it is christmas so I'll ask anyway:

    Please please PLEASE ......

    Can the final released build based on 3036, please include an option to trap Apple Q when operating in Coherence mode.

    I have now lost count of the number of times when I've had Windoze Word in a window on screen, changed to another OS/X app and then thought I was Apple Q'ing the OS/X app with the result that Parallels then shuts down completely.

    Now I know this is classed as user stupidity (guilty) but it would be a HUGE benefit to have an option of what to do when the quit key is pressed while a parallels instance has focus. There's even a tab on the preferences pane with space...

    Oh, and one more please santa.... Can you arrange to have the parallels shared folder to OS/X appear as standard drive rather than as the network shared folders thing


    p.s. I'll leave the pies for Rudolf under the tree ! :)
    Last edited: Dec 13, 2006
  14. Macnuck

    Macnuck Bit poster

    Recap: Parallels Build 3036

    Hi All,

    I was just hoping to peform a recap on issues as I understand them and hopefully many of you more informed people can help make sure I am not misleading anyone.

    Areas of concern:

    a) Reactivation:

    Windows XP SP2 Retail version (Pro or Home): You will need to reactivate everytime when switching between Bootcamp and Parallels. This occurs because Windows XP views each login as a separate computer trying to access the same license of the Windows XP copy. Therefore if you do not like reactivating, wait until the Parallels team is able to fix this issue.

    Windows XP SP2 Corporate or MSDN version: This should only need to be reactivated once as Windows does not verify each version by calling home to MS each launch.

    b) Error on Bootcamp startup - keyboard freezing: The keyboard actually isn't frozen, it just isn't being recognized up front. Plug in a USB keyboard or go in and edit your Boot.ini file to change the "Timeout=-1" to "Timeout=10". This will mean that if a user has not (or was not able) selected the Windows XP profile (instead of the Parallels profile), it will automatically load the Bootcamp profile. This solves one of the most common issues presented in this forum.

    c) Parallels Bootcamp version not Booting up (Message appearing like "Cannot use Bootcamp partition!"): This occurs on running Parallels after a reboot of Mac OSX. From what I can tell, Mac OSX mounts the image of the Bookcamp drive on the desktop. Parallels needs to unmount this image to be able to start the Bootcamp partition within Parallels. It does unmount but fails the first time to load. Exiting Parallels and then running it again appears to now start the Bootcamp partition fine.

    d) Coherency and drag and drop do not work for some (including myself). As I have a Windows XP retail version, I have not gone back into Bootcamp yet and reinstalled Parallel Tools as I am afraid I will yet again have to reactivate Windows on my journey back to Bootcamp, and then again, when I return to Parallels. I have heard this has worked for some but not all. Very excited to get this working but there do not seem to be any post backs on this issue other than the re-install of Parallel Tools?

    e) Install Issues: There are numerous instances where people may not be able to get either Parallels, Bootcamp or both running after the install. Out of my realm as I have not had any issues than those shown above in my post.

    As a side note, it is very upsetting to hear people taken on a mean, or angry tone regarding a Beta release of a product. The Parallels team has worked incredibly fast on making improvements to their product and I am amazed at how quickly they respond to problems and come out with new solutions. I understand people are passionate, but this is still a test version and as such, please treat people on this forum and the development team with respect. The potential of this Beta release is staggering and very exciting and I look forward to seeing it continue to improve and develop!

  15. clarkcox3

    clarkcox3 Bit poster

    Since you are someone that has a working BootCamp partition, would you be so kind as to share your pvs file somewhere?

    I agree wholeheartedly. For as much frustration as it may cause when something doesn't work, THIS IS PRERELEASE SOFTWARE. You shouldn't be using beta software in situations where it not working is a real problem.
  16. snodman

    snodman Member


    Very helpful post. Thanks. Also agree there is no point with the negativity in tone in some of the posts. The team is working remarkably quickly to iron out issues.

    My question - is the BootCamp reactivation bug fixable? Windows itself will always know when it is installed in a VM IIRC. Is a workaround for people without corporate Windows licenses realistic to expect ever? Will we have to buy TWO Windows licenses to move back and forth between BootCamp and Parallels?
  17. microbreak

    microbreak Bit poster

    New Parallels User Experiencing Same BSoD

    Here's my vital's: Macbook Pro 2.16ghz, 2gb RAM, OSX10.4.8, Bootcamp 1.1.2, Parallels build 3036, WinXP Pro SP2 installed in bootcamp as FAT32 originally but then converted to NTFS after reading this forum, Parallels Tools installed when running Bootcamp Native. All Windows updates installed and already activated.

    I run the PDM in OSX and choose Custom>WinXP>Use Bootcamp>768mbRAM. I enter my admin password, and the vm begins. I choose Parallels Configuration>Parallels Configuration, a progress bar on the bottom of the screen runs through and then I get the same BSoD that others have been seeing.

    Any tips? I've read through the entire 37 page forum before deciding to post this but have yet to see the answer to my problem, so forgive me if I missed it.
  18. JoeLake

    JoeLake Bit poster

    I have had luck with running parallels (when it worked) with choosing
    Parallels Configuration> Profile 1

    On to my issue.

    I am unable to load my parallels VM. I am running it off of bootcamp, and it worked fine for a few hours. I wanted to restart and see if I could load into my bootcamp partition (to see if the drag and dropped worked after the fact) and found out I could not get into Windows that way (though it seems that other people are having the same problem).

    I then booted back into OSX and tried to run parallels and now I am receiving this disheartening message:

    Virtual Machine Windows XP cannot be opened since it is already used in another Parallels Desktop window.

    To my knowledge (and I am new to macs so I definately could be mistaken on this) I do not have another Parallels instance up (I have shut down the computer and restarted and then gone straight to my Apps/utilities/parallels folder to run parallels.

    Any help would be greatly appreciated.
  19. claud9999

    claud9999 Bit poster

    XP activation question

    Not having tried this yet, what happens to the activation of the BootCamp partition install of XP if I activate it in Parallels? I wouldn't want to activate in Parallels if it would break the activation for booting via BootCamp. Please clarify...
  20. sfuller

    sfuller Member

    Here's mine from my working Bootcamp install.

    Parallels VM Name = Microsoft Windows XP - Bootcamp
    Boot = c
    OS Type = 135
    Memory = 512
    Memory block size = 10
    Acceleration level = 0
    Enable write-back disk cache = 1
    VT-x support = 1
    Start auto = 0
    AutoShutdown = 0
    Start full screen = 0
    Start dashmode = 0
    Start full screen warning = 1
    PC Speaker enable = 1
    Multi frame = -1
    [Shared folders]
    Shared folders enabled = 1
    Shared folders count = 0
    Video resolutions enabled = 1
    Video resolutions count = 0
    [Floppy disks]
    Floppy 0 enabled = 1
    Floppy 0 = 1
    Floppy 0 image = /Library/Parallels/Tools/vmtools.fdd
    Floppy 0 connected = 0
    [IDE devices]
    Disk 0:0 enabled = 1
    Disk 0:0 = 1
    Disk 0:0 media = 1
    Disk 0:0 connected = 1
    Disk 0:0 image = Boot Camp
    Disk 0:0 cylinders = 0
    Disk 0:0 heads = 0
    Disk 0:0 sectors = 0
    Disk 0:1 enabled = 1
    Disk 0:1 = 2
    Disk 0:1 media = 1
    Disk 0:1 connected = 1
    Disk 0:1 image = Default CD/DVD-ROM
    Disk 1:0 enabled = 0
    Disk 1:0 = 0
    Disk 1:1 enabled = 0
    Disk 1:1 = 0
    [Serial ports]
    COM1 enabled = 0
    COM1 = 0
    COM2 enabled = 0
    COM2 = 0
    COM3 enabled = 0
    COM3 = 0
    COM4 enabled = 0
    COM4 = 0
    [Parallel ports]
    LPT1 enabled = 0
    LPT1 = 0
    LPT2 enabled = 0
    LPT2 = 0
    LPT3 enabled = 0
    LPT3 = 0
    Sound enabled = 1
    Sound = 1
    Sound connected = 1
    Sound device = Default Audio
    Mixer device = Default Audio
    Network enabled = 1
    Network = 1
    Network connected = 1
    Adapter No = 0
    Adapter name = Default Adapter
    Adapter type = 4
    Port = 0x00000300
    IRQ = 3
    MAC address = 001179aade04
    Network2 enabled = 0
    Network2 = 0
    Network3 enabled = 0
    Network3 = 0
    Network4 enabled = 0
    Network4 = 0
    Network5 enabled = 0
    Network5 = 0
    USB enabled = 1
    USB = 1
    USB autoconnect = 0

    Hope this helps. Nothing terribly impressive looking in there.
Thread Status:
Not open for further replies.

Share This Page