Parallels Desktop for Mac build 3036 Beta is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Dec 1, 2006.

Thread Status:
Not open for further replies.
  1. sleepkreep

    sleepkreep Bit poster

    Transferring files

    When I drag and drop a file from Windows to OS X, the file is locked in OS X. I have to manually unlock it before I can move it to the trash.

    Also, there is a small problem with Windows Media Player in skin mode. The transparent parts don't repaint well in coherency mode.
  2. bubbamike

    bubbamike Bit poster

    I'm having the same problem.

    Mac Pro 2 - 2.66 GH Xeon CPUs
    3 GB RAM
    250 GB main internal drive
    250 GB internal drive
    500 GB internal drive
    30 GB external USB drive

    I installed boot camp, installed Windows XP formated NTFS, installed the Parallels Tools for boot camp, updated to 3036 and selected New|Custom and found that the boot camp option is grayed out. After reading the above post I removed all my USB devices except for my keyboard and trackball and still am unable to create a VM using the boot camp partition. Rather a frustrating experience.

  3. wangooroo

    wangooroo Junior Member

    I am running the MSDN edition of XP SP2 and you must activate between boots of the VM or Bootcamp. I believe ONLY the Corporate Edition is not affected by this.
    Last edited: Dec 13, 2006
  4. kd5ftn

    kd5ftn Bit poster

    I'm going to follow up and agree with Wangooroo - the MSDN build of XP - SP2 does suffer from the re-activation issue.

    I had a bootcamp/parallels machine running with a Corporate build fine for a few days, but after BSOD's in Parallels and other issues, I decided to wipe windows and reinstall, this time using the MSDN version. Looks like I may need to switch back to Corporate.
  5. diamondsw

    diamondsw Member

    Sadly, while I previously thought the Parallels Tools worked on 3036, I find they still blue screen when installing the video driver. After crashing and rebooting, Windows boots up with 640x480 (or thereabouts) and I can reinstall the Tools and they work fine.

    Please check how that driver is installed, as it's been problematic for some time.

    Meanwhile, I also had some blue screens when trying to copy files via drag and drop. Most of the time it works, but sometimes it crashes, just implicating a generic "device driver".

    Sadly, although Shared Networking is listed as working better with VPN's, I had no luck using an AT&T IPSec VPN. Thankfully my VPN has an option for SSL tunnelling, which works perfectly.

    Okay, this devolves into a rant from here on out...

    Please work on the interface - things like key commands, toolbar streamlining, how multiple VM's are managed. I've posted a lot on this before, and as far as I can tell, it's being ignored, despite the fact that I've seen many agreeing posts and similar posts time and time again. This is low-hanging fruit compared to your other projects (ACPI, USB 2, Coherence, etc), and you have PLENTY of examples in other emulation and virtualization products. Heavily modal interface that is more and more dependent on a "one-window" philosophy and locking you out of things (changing VM settings while running, for instance), and odd little hacks to compensate for this design flaw (changing network settings from the status bar). Key commands - easy to add to key menu items (possibly hard to trap when in a VM, but you've shown it's possible with the edit key shortcuts).

    Another niggle - Parallels is strewing invisible files all over the place. Its list of virtual machines seems to show up twice - once in an invisible dot-file in my home directory, and once in an invisible folder in my Documents folder. You do a vast number of things in a very "Linux" way, even though it would be either as easy or easier to do them the "Mac" way. As far as storing settings where they belong (visible in Application Support and/or Preferences), this is a conditional or two.

    Please, please, PLEASE keep working on the interface for 2.5.
    Last edited: Dec 13, 2006
  6. slappstah

    slappstah Bit poster

    Can't connect to audio services in shared networking

    Here is an issue I ran across:

    * - In parallels desktop build 1970, I am able to use music services such as Rhapsody, Napster, Yahoo Music in shared networking mode.

    * - Once I installed the beta build 3036, all of these services were unable to connect to streaming audio content while in shared networking mode.

    Not sure if others have run into this, but I didn't see it posted.
  7. kumak

    kumak Bit poster

    Boot Camp options not available

    I have exactly the same problem - boot camp option is not available :-(

    I use boot camp with reFit on my macbook.

    I hope it will work soon.
    Last edited: Dec 14, 2006
  8. blubel

    blubel Bit poster

    IPSec VPN still not working

    I thought that shared networking was improved to support IPSec VPN connection? My Nortel Contivity VPN client still does not work in shared networking mode???:(
  9. pcolag8r

    pcolag8r Member

    Bubbamike, based on what you listed, maybe the fact of another drive being external is not the problem. My guess now is that if you have more than one storage device, bootcamp will be greyed out. Additionally, that one storage drive must be partitioned into the default set by bootcamp. That's my guess.

    Assuming you have bootcamp on your main internal drive with osx (bootcamp default install) maybe you could disconnect the other 2 drives and your external and test it. If you do, let me know the result.
  10. Dan Johnson

    Dan Johnson Bit poster

    Problem with Bootcamp

    Hello I installed the new beta and I when I tried to boot from the boot camp drive it says...
    It cant start because of a computer disk hardware configuration problem.

    Is there any indication that the parallels tools for boot camp worked after install? I noticed there was a parallels hardware config in the hardware device list, is that supposed to be there?


  11. pfloydn

    pfloydn Member

    This is the most impressive piece of software that I've ever purchased

    That's all I have to say. Thanks guys for all of the hard work, creativity, and care. This latest version is amazing.

  12. Hiptrigger

    Hiptrigger Bit poster

    You are on a MBP 17"? - if so what does your xorg.conf look like? I can not get 1680x1050 to 'stick'. Custome rez in parallels, etc. Tried modes with modelines output given by gtf & also stepped-through dpkg-reconfigure xserver-xorg ...1280 rez is best that will stay. I have read eerything in the forums on this topic. Any help appreciated.
  13. sfuller

    sfuller Member

    I believe that it is. I have one on my machine. That lets you tell Windows to load the parallels driver set vs the regular driver set depending on how you are running XP from your bootcamp partition.
  14. ithacalaw

    ithacalaw Junior Member

    Could you explain this to me. I get "not enough virtual memory or paging fill quota is unavailable to complete the operation" when I try to launch. It then tries again to reboot and I go thro' another round of this warning. Tedious. Was working well with 1700
  15. exaurdon

    exaurdon Bit poster

    Coherence Problems When using full resolution of a 30" cinema display

    I have been greatly enjoying the new Beta build of Parallels on my Mac Pro. I have run into a couple bugs with coherence mode.

    #1. If I turn on coherence mode when my 'windows' (Windows XP SP 2) resolution does not match my mac resolution. (I.e. Windows at 1920x1200, Mac at 2560x1600). Parallels 'stretches' windows to the mac resolution. This results in extrememly hard to read text etc.....

    #2. If I set the windows resolution to match my Mac resolution (2560x1600), and then run coherence mode, evertyhign seems to be peachy, nothing stretches, drop and drop works, its beautiful... until I reboot my VM. At this point, Windows goes into a Blue-Screen of death, and reboots itself. I am then given the 'safe mode', 'normal' mode etc choice. If I choose normal mode, windows will again bluescreen and return to this point. If I choose 'boot using last known good configuration, then windows finished booting, puts me into a lower resolution, and sets the color depth to like 8 bits.

    If you'd like more details (screenshots, etc....) please feel free to email me.

    Thanks, and keep up the great work,

  16. CrazyBrit

    CrazyBrit Bit poster


    This is a nice recap of the issues out there, the only one I would add, that is important, is the conflict with MacDrive. With the inability of the Mac to write to NTFS, Macdrive provides us Bootcamp users with the only ability to share files. I keep all of my documents on the mac side, and have no problems sharing information between Bootcamp and OS-X. However, with the parallels drivers loaded, Macdrive is incapacitated on the PC side when booted via Bootcamp.

    If the above issues are resolved, I am purchasing Parallels. Until then, I will stick with Bootcamp.
  17. gmorris

    gmorris Junior Member

    windows and bootcamp


    I installed 3036 and followed the thread for a week. I had my eyes open to it being a Beta and kudos to the Parallels team for working on what will be an extremely neat product.

    After a week and unexplicably, my XP installation started crashing from bootcamp. It was difficult to trap the error which resulted in BSOD and a 'stuck thread' error but could not be traced to anything very easily - some apps were also getting some strange video interruptions and results. The only way it could be avoided was to allow the log on screen to sit for 3 mins or so, but even then it just seemingly delayed the BSOD.

    It appeared to be ATI driver related from XP logs and sequences, but after two days of trying to rectify it by all means imaginable, including removal and cleaning up of apps and xp elements, we were forced to roll back 3036 afer which it still failed unfortunately; we repartitioned/reformatted bootcamp and did a complete reinstall of XP. We now have a stable MBP with bootcamp. Now we are not sure what 3036 does, but we could not identify anything other than 3036 which 'might' have corrupted something in XP at a low level which we couldn't undo. This is theory only but as i said at the top FYI.

    As a side note and intererestingly after reinstalling everything, the ATI driver no longer supports dual monitors in bootcamp as it appeared to before (at least it appears not to resolution wise or signal wise) which was something noted under 3036. I do not believe that this is related but in the final release of parallels I do wonder if dual monitor support will be available. This last para suggests something other than 3036 but the system was very stable before in bootcamp and this is the only thing that has changed :confused:
  18. Shyos

    Shyos Bit poster

    Mine 3036 is running fine!!!


    find all the differnet programmes :p
    Last edited: Dec 16, 2006
  19. phor2zero

    phor2zero Bit poster

    No luck on MBP

    I didn't have much luck with this beta on a MBP. It installed fine, and was capable of booting my bootcamp xp without much trouble. Seemed to run fine as well.

    Coherency didn't work. Basically nothing happened when trying to enable it, no matter what the guest OS screen resolution was set to. (this was very disappointing! why does it seem to work for everyone else?)

    The Parallels tools that I installed in my XP install really messed it up. It would go to a selection screen on boot requiring me to select Windows XP or Parallels configuration. When booting natively, this occured before the MBP's keyboard was recognized, so I couldn't get any further. (this completely eliminated the possibility of using the new feature at all)

    My other big issue is that I'm using an OEM version of XP Pro. I'm not sure how many activation attempts I can make, but I did all my experimenting on an unactivated version. Now that I've given up, I've activated it.

    Other issues not fixed:

    Full screen is kind of pointless when you have to have a window the same size as full screen open on your mac desktop the whole time anyway.

    When exiting fullscreen, it's difficult to get the mouse free of the VM. (have to try ctrl-alt repeatedly)
    Last edited: Dec 16, 2006
  20. ebruchez

    ebruchez Bit poster

    Windows crash when upgrading XP install to SP2 in beta


    I downloaded the beta and it looks great!

    I created a fresh VM, installed XP from scratch (no problem with that), and then proceeded with the automatic updates. They installed fine. Then I got to the SP2 update. This downloaded fine, but it crashed (access 0x00000000) during installation. I repeated the process twice with two fresh VMs and could not get to install SP2 in the beta.

    This install works fine within the latest stable version of Parallels though.

Thread Status:
Not open for further replies.

Share This Page