Parallels Desktop for Mac build 3094 Beta 2 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Dec 21, 2006.

  1. Junior Member

    Admin Authentication

    I have exactly this. I thought that it was due to having two user accounts, but on closer examination it is having a non-admin user and grabbing the OS from bootcamp.

    Suggested fixes anyone?


  2. orija

    orija Bit poster

    bad luck

    I also am still getting the message
    "Unable to open disk image Boot Camp!"

    I am on a MacBook Pro Core 2 Duo.
    Boot Camp is a FAT partition on the local drive.

    I notice now that from the previous beta the Tools which needed to be installed in Windows never installed. On searching around as to why that install failed I found a file called "parallels-bctools-install.log" in it is the following error:

    Set Logging to 2
    bctool_install() finished with rc 5
    Parallels Tools for Boot Camp Setup program cannot find file %s\Driver Cache\i386\ This file is required for successful installation of Tools and can be found on Windows XP installation CD.
    Setup cannot be continued.

    don't know if that has anything to do with anything, but there you go.
    oh and also, cryptically, an empty file was left on my C: drive with the title:

    Need Install Parallels Tools


    At any rate I cannot get this beta to run for some reason. I've deleted and re-installed Parallels twice but no go.
    any help?
    Last edited: Dec 22, 2006
  3. orija

    orija Bit poster



    The Beta Works For Me Now


    edit: or at least... it booted up. will keep you posted.
    edit: booted up but the USB mouse and laptop keyboard weren't recognized. so, no easy fix. but i now know that this or file is part of what is keeping Parallels from working on my machine.
    Last edited: Dec 22, 2006
  4. yogieric

    yogieric Bit poster

    Should I activate Windows XP? (or wait)

    Coherence is so cool! Thanks to all the posts here I was able to get the copy of XP that came with Virtual PC on my old PowerBook migrated to this beta. Virtual PC was so slow it was useless on my Powerbook and when I tried to boot it up my copy of XP there was corrupt so I had to reinstall it. Now I've got 30-days to reactivate windows XP under parallels. I don't know if I'll have to call Microsoft or not. Will the next beta-s/rc-s/final of parallels require re-activation yet again or should I go ahead and activate now?

    I just hate calling microsoft and explaining what/why I'm doing something. And I'm marginally concerned their going to give me grief for trying to move my legal copy of XP from my old computer running virtual pc to the new one running parallels.

  5. vinneh

    vinneh Member

    after reading through all the "bugs" i have come to the conclusion that parallels betas should be harder to obtain.
    some of the problems people are having are caused entirely by their own incompetence.
    these people have no business testing development software, they spam the forum with their idiot questions and make it impossible for the dev team and the people who can actually test the product to communicate.

    example, people who think that because they cant mount the diskimage they downloaded that its incompatible with a certain version of windows. no.

    people who ignore the warnings marked VERY IMPORTANT and fail to remove the earlier parallels tools from their bootcamp partition. READ THE RELEASE NOTES BEFORE SPAMMING THE FORUM

    people who dont even know what a service is under windows, and cant even follow a simple instruction.. GO AWAY.

    i blame digg.
    its a magnet for morons.
  6. charlestrippy

    charlestrippy Bit poster

    how to use Favorites..?

    So, I can't figure it out -

    How do I get it so I can have the windows applications in my OS X dock...the whole favorites thing...

    I can't seem to figure it out...

    please, any advice/help? :confused:
  7. hagen

    hagen Junior Member

    Same error for me

    Exact same error occured in Beta 1 (error loading operating system). In this I uninstalled the tools before running Parallels.

    2.0 GHz Mac Pro, ATI X1900XT, 2 GB Ram, 4 HDDs (boot mac off a Raid 0 Raptor pair), 312 Gb NTFS partion in bay 4. XP Pro with all updates (minus IE 7). Also have Spydoctor and McAfee Security Centre installed; not that the XP boot gets that far.

  8. brkirch

    brkirch Pro

    I was actually able to use this method to get my boot camp installation working. :) After I had copied and renamed the copy to parallels allowed me to boot windows instead of displaying the unable to open image error. Neither the keyboard or mouse worked at first, but after about a minute the keyboard started working. Since the mouse wasn't working I decided to try installing parallels tools to see if it would fix it. Well after selecting 'Install Parallels Tools...' from the 'Actions' menu the dialog that would usually display when first booting windows during an express install appeared. The parallels tools were automatically installed and ever since windows rebooted after that everything now works! :D
  9. luomat

    luomat Hunter

    Do your homework / Show your work

    "Can't figure it out"?

    What did you try?

    Did you try, say, looking in the app preferences panel?

    Or did it not immediately work as you expected it would so you posted to the forum for someone to tell you the answer?

    Unless you give some indication of what you tried, we don't really know.

    Are you using Coherence Mode? Do you have the setting turned on in Preferences?
  10. mkap73

    mkap73 Bit poster

    "Unable to open disk image Boot Camp!"

    I am getting the dreaded "Unable to open disk image Boot Camp!" message when trying to start a FAT32 Boot Camp partition too...

    I am on Windows XP Pro Corporate. What version of Windows XP are others using who are getting the same message?

    MBP C2D 2.33 2gb RAM

    P.S. I got it to work by copying the file and renaming it trick as seen in another thread. I had to install Parallels tools from the menu before my trackpad/mouse would work... Seems to be working (have booted several times natively and from Parallels) with no activation issues...
  11. gripworks

    gripworks Bit poster

    Activation issued

    Well having searched and tried as many different solutions as possible I think I may have a unique problem.

    When trying to boot to bootcamp vm it says I only have 3 days to activate, no problem i figure I can just re-activate, however neither the mouse nor the keyboard work to click the message window leaving me at a loss.

    Any ideas?


    WinXP Pro
    Never got bootcamp to work in previous builds.
  12. vinneh

    vinneh Member

    your issue is not unique, it has been resolved. look harder. :p
  13. charlestrippy

    charlestrippy Bit poster

    i think i figured it out..
    Last edited: Dec 22, 2006
  14. wingdo

    wingdo Pro



    You are correct .... Since Every Intel Mac already comes with the Intel version of OS X you cannot actually buy OS X for Intel. ANY copy running on non Apple hardware is pirated s/w.
  15. wmahla

    wmahla Bit poster

    I installed Beta2 over Beta1. Started my VM. Got the message to update my tools to the latest version. I ran the installer for the new tools. The installer starts and seems to be installing the new tools, but then just sits-- never completes. I force stop the VM and restart, the new tools seem to be there. Everything is fine, the new beta seems faster than beta1, but coherence does not work. The threads about this don't seem to apply to me. When I try to do the 'sc delete "parallels coherence service" I get an error saying that the service is not installed. When I try to install the service by running c:\Program Files\Parallels\Parallels Tools\cohrence.exe" (note spelling error), I get one of two errors - either 1063 can't connect to the service controller" or 1060 "the specified service is not installed". How do I install the coherence service? Thanks!
  16. rajulkabir

    rajulkabir Bit poster

    Interference with DVD mounting?

    Since installing the upgrade, I've noticed that it blocks DVDs from being mounted and visible to the Mac finder.

    I have XP running in Parallels.

    If I insert a DVD, I get Windows Explorer asking me what to do with it. But it never shows up to Mac apps. Once I suspend the virtual machine, the DVD immediately mounts in the Mac world.

    This is definitely different behaviour from what I've seen before. Is it some sort of new feature that I can adjust, or is it a bug?
  17. dechamp

    dechamp Bit poster

    Hey vinneh... your attitude and that of others who have a similar approach to assisting newbies is worse than worthless. These beta's are being released by the developer in order to try to design a product that will work "MacLike" with many hardware/software installations, just like most PC programs have to do. It's a necessary evil when you try to work with Windows. In addition, Boot Camp itself is just a beta.

    What you need is a private forum for you and other 'elite' users where you can laugh or bitch about the problems that some are having without actually having to get your hands dirty.

    There are many PC users that need to run software without having to know what a service is. This software is not a free beta, but rather a fairly expensive utility program that claims to be able to do quite a few tricks. It sorta works, but there are quite a few kinks and I don't think you know how to fix them all.

    In the time it took to beat up on a guy with a question, you might have actually pointed him/her (and many others) in the right direction, of course that would have meant that you would have to look up a reference...

    Don't you ever think about the person before you hit the post key?
  18. Junior Member

    Very well written!

    I would have thought the whole idea of a PUBLIC beta is to get users of mixed abilities trying the software and then watching as issues get identified and homefully resolved. Some issues will be be genuine bugs, other issues will be installation and perhaps configuration problems, and some will simply require more explanatory documentation. A wide public beta program that includes the highly experienced and the not so experienced will simply flush out more problems.

    Well done to the Parallels team. Well done to the users who take the trouble to assist their colleagues in the beta program. To the grumpy few that bitch at others inexperience - lighten up it is the holiday season!
  19. cpuser

    cpuser Bit poster

    Also 3094 Beta 2 can not communicate with my Garmin ForeRunner 305.
    And this device is the one and only reason to have a Windows on my mac. So I have to give an other solution than parallels a chance :mad:
  20. Olivier

    Olivier Forum Maven

    It might be more effective and useful to insist on Garmin so they provide software for Mac OS X too. Needing Windows on your Mac just for this looks... strange. :)

Share This Page