Parallels Desktop for Mac build 3106 Beta 3 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Dec 29, 2006.

  1. LorenFinkelstein

    LorenFinkelstein

    Messages:
    23
    Exactly the same situation here. I sent a crash log into both Parallels and Apple.
     
  2. paco.blasco

    paco.blasco

    Messages:
    24
    Keyboard mapping on Spanish Mac Book Pro ¡s wrong

    Hi all:

    My keyboard on Parallels is completly worng (symbols like -_´¿?=)(/&%$·"!) are in crazy locations.
    Anyone can help?
     
  3. Friend or Foe

    Friend or Foe

    Messages:
    2
    Misplaced buttons in alert sheets

    I have a bug to report... The one thing that has always bothered me about Parallels is that some of the "alert sheets" and panels are wrong. For example, the Action button (default blue highlighted) should be on the RIGHT side, and the cancel button on the left side. The way most of these alert sheets are setup seem like they originated from windows or linux, and in the context of OS X it is wrong and disconcerting. I hope this can be corrected before the next release.

    I've attached some examples of the current behavior (the wrong behavior).

    Thanks and keep up the good work, I love the new betas!

    Edit: Here is a good example of the proper way to setup these things http://wilshipley.com/blog/2006/07/pimp-my-code-part-11-this-sheet-is.html , including a time when the highlighted button is on the left because it is a way of backing out, so on some of my examples I think this is what the team at Parallels may have been going for. But in this case the YES needs to be on the right and the NO needs to be highlighted in blue and on the left side.
     

    Attached Files:

    Last edited: Jan 1, 2007
  4. Bootcamp issues with XP Pro SP 2, OS X 10.4.8

    Hi folks,

    Great work on this software, its really come a long way. That said, I know that Betas thrive on feedback, so here you go:

    My system:
    MacBook Pro
    OS X 10.4.8
    2.33GHz Intel Core 2 Duo
    2GB RAM (factory installed)

    My Bootcamp:
    NTFS converted from FAT32 via windows utility


    1) Parallels Bootcamp Tools failed to remove registry keys when uninstalling
    When I tried to setup a new VM to use bootcamp, it incorrectly reported that the Parallels Tools for Bootcamp were still installed. I removed the registry keys, which solved this problem.

    2) Every time I launch the VM, it tells me not to do anything because it is installing Parallels Tools. This fades away and allows me to login.

    3) I cannot configure the VM from the buttons along the side. I can configure it by clicking the elements in the VM configuration pane.

    4) I cannot launch Coherence mode for some reason. I will scan through this thread for a work around.

    5) I LOVE that I can see the running Windows apps in my Command+Tab list. Bonus points if you can make the icons not suck.

    6) I LOVE the remapping of my key strokes. It feels much more natural

    7) I had to re-activate windows when I first tried running the VM via Bootcamp.

    I'll post again when I've tried this with my existing VM's.
     
  5. PeterH

    PeterH

    Messages:
    13
    Paco, the keyboard definition isn't Parallel's responsibility. It's either Microsoft's or Apple's. The normal Spanish keyboard that comes with Windows will work flawlessly on the full Apple keyboard, but, in my experience, ªº\ and <> are swapped on a MacBook or MacBook Pro. Check that you haven't installed a Mexican keyboard definition or some other Latin American keyboard. You should choose the Spanish national keyboard with international sorting, but if you have a MacBook, those two keys will be swapped. You can fix that creating your own keyboard definition (there's a Microsoft utility to do just that), or I can send you the keyboard definition I created for my wife's MacBook Pro Boot Camp installation of XP. If you are interested and the forum rules allow it, post an email address and I'll send you my keyboard definition, which works flawlessly.

    Regards.
     
  6. paco.blasco

    paco.blasco

    Messages:
    24
    Sorry Peter, but it is a Parallels responsibility.
    On "stable" release the keyboard works perfectly. On 3094 and 3106 versions the keyboard mapping is wrong. So if the mapping depends on the Parallels revision...it is a Parallels problem.

    Thanks in advance.
     
  7. Geesu

    Geesu

    Messages:
    76
    [BUG/REQ] Some applications need mouse pointer to not move

    Is it possible to have an option w/in the parallels tools mouse driver to enable applications to request the mouse not moving outside of the application...

    For example, counter-strike or other variations are able to run in software mode, and run pretty well from within parallels - but the mouse pointer will not be controlled by the game - therefore rendering it playable impossible.

    TY!
    Josh
     
  8. PeterH

    PeterH

    Messages:
    13
    Paco, I don't quite follow what may be happening to you. I'm sort of Spanish myself. I have a MacPro with a Spanish keyboard and Parallels works well. No keyboard issues. My wife, who is a Spaniard, purchased a MacBook Pro in Spain. She doesn't have Parallels, but uses Boot Camp, and we noticed that the two keys I mentioned before were swapped (only in Windows!). So, I created a keyboard definition just for her and that solved the issue. I'm sorry, but I can't legally install my Parallels licence on her computer, so I don't actually know what might happen with the normal Windows Spanish keyboard definition on her system under Parallels.

    Good luck.
     
  9. judisohn

    judisohn

    Messages:
    17
    I'm having stability issues with 3094 too. It stays up longer than 30 minutes...usually a few hours at a time. I used to be able to run Parallels open for days and now I have to be sure to shut it down at night, otherwise it won't be there in the morning.

    I don't get any kind of message...it just disappears. Annoying.
     
  10. BillInSoBe

    BillInSoBe

    Messages:
    84
    Running a continuous ping isn't an ideal solution, however I suppose it'll do until someone from the Parallels team can address the problem.

    I'll need to test to see how running the ping will effect other network related functions I'll be performing at the same time.

    Thanx!
     
  11. paragonconcept

    paragonconcept

    Messages:
    4
    Problem

    I decided to wipe out my existing XP install and retry a clean install. As i am lazy / efficiant, i have the iso copied on my hard drive. I've tried both manual install and express, and it gets to the "Starting windows' then pops with an error of some sort before i can read it and closes the machine out. I've done this install numerous times from the same iso, so i assume this is a bug in the beta. let me know if i can provide any more information.

    ~Thanks
     
  12. LakosCA

    LakosCA

    Messages:
    1
    MacPro issues

    I also have a problem with Parallels on a 2.66 GHz Mac Pro with two internal drives. Both drives have a BootCamp partition - one to work with and one to experiment with !! For the first time, release 3106 allows me to set up a VM with a BootCamp partition (previously it was greyed out). However, when I try to start the VM, it says that Parallels does not support 2 BootCamp partitions.

    Is this likely to be addressed soon?

    Thanks.
     
  13. gibarian

    gibarian

    Messages:
    5
    Yes

    Yes. Don't know what to do.
     
  14. adp92

    adp92

    Messages:
    5
    USB Device Not Recognized-Help

    I am a converted Mac user. I like Parallels as I need it for work related software. I can not get my printer to work. So I am excited that the new beta release supports USB 2.0, however I am getting a message from XP saying that the USB device is not Recognized.

    I have looked through the forum and did not see any possible causes or solutions

    thanks
     
  15. stresover

    stresover

    Messages:
    7
    HP printer and Parallels

    I installed the new version 3106, Beta 3 and my HP printer now works in Windows. Was using 3036 and the printer wouldn't work. Thank you for fixing the problem, Parallels people.
     
  16. grw

    grw

    Messages:
    3
    Gasp...HELP!

    Hi, I just tried updating to the Beta 3. I was running 1970 and having problems printing to an Epson LQ-570e (would not let me erase jobs in print queue- which seemed like it could be Windows or Parallels - any comment? Using Bonjour to communicate with the printer worked). Reading this forum and seeing that other's printer problems were fixed, I decided (at about 2am) to install the Beta 3. Here's where lack of sleep and having two sick toddlers in the background comes in...aaarrgh.

    I installed the BETA and re-activated Parallels. Then it asked for the XP CD to install Windows. This is when my entire cardiovascular system stopped, my eyes bulged, and I realized that the Beta version did not install like the previous UPDATES I had done. So currently I am stopping at this point, and holding my breath....

    I searched in Library/Parallels to see if there is some way to get back my files in Windows XP Pro within Parallels, which I don't see how to do. I have an Access database and Excel files that reference it for my business (I KNOW, I KNOW the first post says to back everything up. I didn't. OK, so I'm bent over...kick me quickly....(I do have it from a week ago, but not tonight). Because I thought it would act as an update, not a fresh install.

    So here is my question: Before I do anything else, is there a way to reverse the install/access a few files in 1970?

    PLEASE HELP.

    PS Parallels team I love your product and am really looking forward to coherence, and hearing from you on this....sorry to distract you from you superhuman pace of improving this. So embarrassed....again my compliments!
     
  17. grw

    grw

    Messages:
    3
    Gasp...HELP! (addendum)

    Sorry, too tired....Here are my machine specs, in case it will be helpful:

    24" iMac, 2.33Ghz, 2 GB RAM, 500 GB HD, running OS 10.4.8.

    Printer is ran via adapter cable from USB to parallel. Printer had worked. But each time I send a print job, it pauses and when I try to cancel the document in the print queue, it says "Access denied." I can delete and reinstall the printer (obviously administrator rights) but even if I do that, including restarting the VM and reinstalling the printer via Bonjour, the print job is STILL IN THE QUEUE!

    Sigh..............will wait hopefully for your reply. Dead in the water until this is resolved. Going to bed, which apparently I should have done several hours ago.
     
  18. technut

    technut

    Messages:
    1
    working for me - thanks!

    Just a quick note to say that beta 3106 is working well for me on my Mac Mini. I did an uninstall of 1970, then installed Bootcamp for the first time (XP Home SP2 OEM - 32GB FAT32), then installed Parallels 3106 using the Bootcamp image and so far so good! My thanks to the Parallels team for a release that works for me. And my sympathies to those who are stuck struggling with issues. I consider myself lucky.

    My wish for the future would be to run Mac apps within a MacVM under Bootcamp! (yeah, I won't be holding my breath for that one)
     
  19. grw

    grw

    Messages:
    3
    Gasp...HELP! (addendum) [post script]


    SORRY.... did more searching, found the ".pvs" file, which opened my previous version 1970. I immediately backed up everything. So files are recovered. So disregard hysteria above.... it is now nearly 3 am.

    Regarding the print problems above...even with latest Beta everything remains the same. This probably means it is a Microsoft problem??? Would appreciate your reply on that.

    And now that I have coherence running: STUNNING! WOW. Thanks. Nice work!!!!
     
  20. George Jetson

    George Jetson

    Messages:
    1
    Constant CD Access

    I notice with the latest Beta 3 Build and Windows XP SP2 that they CD access light in parallels at the bottom of the screen constantly blinks about once per second, even though there is no CD in the drive. I've restarted multiple times with no effect. Even disabling CD access stops it, but once the XP is restarted it comes back on again.
     

Share This Page