Parallels Desktop for Mac build 3106 Beta 3 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Dec 29, 2006.

  1. chrisdressler

    chrisdressler

    Messages:
    14
    Use Boot Camp Option Still Greyed Out (Vista RTM)

    So I just downloaded and tried the latest build (3106) of Parallels and I'm still having the same issue as the previous build. When I try to create a new VM, the option to "Use Boot Camp" is still greyed out. My Boot Camp partition contains Vista RTM. It is a default install of Boot Camp on a MacBook Pro Core2Duo 15". I can boot into Boot Camp just fine, and there doesn't seem to be anything wrong with the partition. Here are the results of "mount":

    /dev/disk0s2 on / (local, journaled)
    devfs on /dev (local)
    fdesc on /dev (union)
    <volfs> on /.vol
    /dev/disk0s3 on /Volumes/Windows Vista (local, read-only)
    automount -nsl [169] on /Network (automounted)
    automount -fstab [195] on /automount/Servers (automounted)
    automount -static [195] on /automount/static (automounted)

    Any ideas? This is a bummer...
     
  2. jwdawso

    jwdawso

    Messages:
    2
    VirtualPC Windows XP Pro works!

    I've been running ubuntu in the Parallels production build. After reading all the great things about this beta, I decided to install it and try to use my VirtualPC XP Pro image. The conversion (using "Import") worked faster than I expected on my Mac Mini 1.5GHz solo. The new Parallels image booted right up. I got the Windows "need to reactivate" message, but clicked on later for that. The Parallels tool installer window came up as well as the Windows "detected new hardware wizard" window. I did what the Parallels tool installer said to do - I hit cancel (twice) on the Windows wizard, and hit cancel on the Windows reboot dialogue. The Parallels tool installer completed, then I hit the "any" key, and the Windows VM rebooted. I logged in again, and this time I did select reactivate the Windows license, which it did without me having to enter the key again.

    Thanks Parallels - awesome job!
     
  3. Synapco

    Synapco

    Messages:
    7
    Beta 3 Comments

    This beta appears to be more stable and responsive. Great work in such a short time. A couple of comments:

    1. Coherence is still causing a problem when I suspend and try to resume. On resume, sometimes it works but most of the time I have to change the View to an OS Window before I can use it. Overall, once Coherence is up and running it appears to work without any problems. By this I mean the Task Bar appears/disappears as intended - finally. :D

    2. The USB devices I use (Lexar Jump Drive and a Hitachi Travelstar) all work and quickly. What is really slick is now being able to suspend without removing the devices and then pulling the devices back to Windows through Devices/USB option.

    In conclusion - I am also testing VMware's Fusion. You have a head start on a very fine product, but, Fusion is pretty good even though it is only a beta 1 product. Watching both products advance is very exciting and rewarding to us mac users. Keep up the good work!
     
  4. bhagiratha

    bhagiratha

    Messages:
    31
    I just did a fresh install of windows XP via Boot camp, installed boot camp drivers and then rebooted back to OS X. Installed Parallels build 3106 and got this error message.

    "Paralles desktop cannot find necessary drivers to configure your boot camp partition. please refer to help>parallels desktop help> using boot camp windows xp installation for troubleshooting."

    Can anyone explain this. Or do I need to install something else.
    Do I still need to install > Parallels-Tools-Bcp-1.0.3-Win.exe on the windows XP partition?

    thanks
     
    Last edited: Dec 30, 2006
  5. Synapco

    Synapco

    Messages:
    7
    Coherency working flawlessly

    Sydbarrett74 - you indicate Coherency working flawlessly. Could you please try to suspend and then resume the VM and tell me if it works? My problem is when I suspend in Coherency mode and then resume at a later date, for the most part, I am forced to open the VM in a window before I can use it. On the other hand, if I suspend from either full screen and or a window and then resume, I don't have any problems. Also, since you appear to be running Vista and I am running XP-Pro, I am wondering if this is an issue. Thanks. :)
     
  6. rbirkby

    rbirkby

    Messages:
    3
    Suggestions for future versions

    1) Can you remap Command+W in addition to the other keys?
    2) When flipping into Coherence, could you temporarily set the Windows desktop wallpaper to a plain white color, rather than a bitmap. A solid color makes moving windows noticeably faster, while the white color helps in perception of the redraw.
     
  7. wangooroo

    wangooroo

    Messages:
    19
    The release notes indicate that Vista in a Bootcamp partition is NOT supported at this time. You can only run Vista in a VM when using a VM Hard disk file rather than boot camp.
     
  8. wangooroo

    wangooroo

    Messages:
    19
    Which OS is in Bootcamp? If Vista you are SOL. Parallels does not support Vista in a boot camp partition yet.
     
  9. Group51

    Group51

    Messages:
    3
    I was about to install this and then I remembered what happened the last time I tried to install an upgrade off the Parallels website.

    I guess that the beta will only work for US users and not UK users with Avanquest licenses? I don't wont to hose my installation again if I can help it.
     
  10. Evinyatar

    Evinyatar

    Messages:
    5
    Upgraded from beta 2 to beta 3. Went fine, except that it kept nagging about installing the parallels tools (even after they were installed). Then booted into BootCamp which went fine too, but after that Parallels won't boot Windows anymore. After the window is resized and one would expect to see the login screen, the window just stays black. Trying to log in "blindly" doesn't seem to work either. I don't get any login sound at all.
    Windows XP Media Center Edition 2005, with all the latest updates from Microsoft.

    [Edit] fixed it by disabling custom screen resolutions.
     
    Last edited: Dec 30, 2006
  11. bayz

    bayz

    Messages:
    14
    I'm still running 32-bit windows XP SP2.
    The only abnormal thing about it is that it is from an OEM install disk, but I don't see how that would make a difference.
     
  12. Stevamundo

    Stevamundo

    Messages:
    407
    Great job!

    Since I learned that the 3106 has USB 2.0 and the CD burning capability and I have an external HD with 1970 already on it. I decided to download this beta on my internal HD.

    First it's very hard for me to download the new Parallels tools. My Morse code adapter didn't work well at all. Let me tell you I was kind of scared. HOWEVER SOMEHOW don't ask me how I managed to upgrade the Parallels' tools and I did a restart. After that everything worked PERFECT! Let me tell you there's something in the Parallels' tools that my Morse code adapter just LOVES!!!!

    Then I tried my serial speakerphone modem and it still works!

    Then I tried burning a CD. The first time either I got impatient or it soft froze. I think I soft froze, because I was waiting for it to finish up the last 15 seconds for ten minutes. I finally decided to force quit Parallels. That was a big mistake. After the force quit I had trouble getting XP to run again. After a couple of iMac restarts I was able to get XP running again. However the revolution was screwed-up.

    After I got the revolution fixed, then I tried to burn a CD again. The second time absolutely went well.
     
    Last edited: Dec 30, 2006
  13. CJConline

    CJConline

    Messages:
    19
    MacDrive bootcamp support imperative + a suggested fix

    Really great work guys!

    However, it is really imperative for all of us that have to still use bootcamp that we are also able to use MacDrive to access our OSX partition when we boot natively directly via bootcamp.

    Perhaps a simple interim solution, which should be easy for the Parallel team to implement would be to have the virtual machine loader just set a software switch which the parallels tools could check and only temporarily disable MacDrive when Windows in running in the virtual machine.

    Under Windows, my MacDrive (ie my OSX partition) is currently mapped to the M: drive under bootcamp, and there are several other Windows only programs that use drive mappings (eg E and F drives) that are folders located within this M: drive (my OSX partition).

    Currently, I am holding off using Parallels until I can be absolutely sure that it will not break my bootcamp Windows which I will still unfortunately have to use for a few programs (not games) even after I migrate most of my other Windows apps across to Parallels.

    Hope this can be fixed really soon.

    Thanks guys,

    Chris
    MBP core 2 duo, 2.33GHz, 2GB RAM, 160GB harddrive
     
  14. don montalvo

    don montalvo

    Messages:
    111
    "Parallels Desktop has detected..." error?

    i upgraded from beta2 to beta3 and for some reason i'm getting this error:

    "Parallels Desktop has detected, that Parallels Tools for Boot Camp (beta1 version) was installed on Boot Camp Windows partition. Please, uninstall Parallels Tools for Boot Camp before using Boot Camp in Parallels."


    i booted into windows and uninstalled parallels tools for boot camp but i still get the error...parallels won't launch. any ideas?

    thanks,
    don
     

    Attached Files:

    Last edited: Dec 31, 2006
  15. mcprop

    mcprop

    Messages:
    3
    Reject password in safe mode

    Parallels works great in 3036. BSOD after Windows startup in both 3094 and 3106. Saw suggestion to bootup in safe mode and then install parallel tools. Got into safe mode but it wouldn't accept my password which is the same one I ALWAYS use. Any ideas for a work-around so I can open safe mode and try the suggestion above.

    MacBook Pro-Intel Core Duo on 10.4.8. Thanks for any help
     
  16. scottD

    scottD

    Messages:
    3
    Can't get BootCamp partition to work

    I installed XP Pro in a new BootCamp partition set up on a new Macbook Pro. The BootCamp version works fine and I've applied all the MS updates to it. Then I downloaded 3106 Beta 3 and got a trial license to do some evaluation. I created a new virtual machine, per the instructions, and set it to use the BootCamp partition. When I try to start it up, it get the message
    "Unable to open disk image Boot Camp"
    I've tried a number of times to generate a virtual machine that works but always get the same result. This is a clean installation which never had Parallels Tools installed. The Users manual that came with Beta 3 says you need to install Parallels Tools for Boot Camp (page 172) but I can't find it and the release message at the start of this thread makes it sound like that is not necessary with Beta 3. Is this correct?
    One other thing is that I haven't activated the BootCamp XP installation yet (I'm still playing around with Parallels and VMWare Fusion to see how I want to set this machine up and which virtualization software I want to buy). Don't know if that matters or not.
    Any ideas why I can't get this to work? This is the first Parallels installation I've tried on this machine. If there is anything else I can check or any further information that would help to diagnose the problem, let me know.
     
  17. phybersplice

    phybersplice

    Messages:
    6
    I have been playing for hours upon hours with 3106 and XP on a Bootcamp Partition on my macbook pro c2d 2.33 / 2gig with the internal 120GB HDD.

    I had setup XP using Fat32. I always got this error that you mentioned.
    I checked in /Windows/DriverCache for sp2.cab and driver.cab. They existed there.

    The only thing I could think of was to convert from Fat32 to NTFS.

    I booted up into Native Bootcamp with XP. I went to the command prompt and typed

    convert c: /fs:ntfs

    Said yes to the prompts and rebooted back into Native Bootcamp XP.

    The drive converted to NTFS, and then I booted back into MacOS.
    I ran Parallels, and it worked!!
    I then had a huge issue of installing the parallels tools, but that's another story.
    I'm still not entirely satisfied with 3106.

    I don't get it though.
    1970 worked fine on a virtual boot file. Beta 1 worked fine with Bootcamp for me with fat32.
    Beta 2 worked as well. As soon as I upgraded to Beta 3, all hell broke loose.

    I even went as far as to Wipe out all partitions on the internal drive, and reinstall MacOSX and XP on Bootcamp.
    I installed 3106 from scratch, and nothing but problems.

    It seems that 3106 does not like Fat32 at all.
     
  18. spudbake

    spudbake

    Messages:
    1
    Re:Beta 3 Comments

    I am having the same issue with coherence when I suspend and resume-On resume, sometimes it works but usually I have to change the view to OS Window and then all works just fine if I go back into Coherence. This was the same in Beta 2 as well.

    Also, one of my windows apps doesn't appear in the dock-It is TC2007- a stock market program. It works fine just doesn't show in the dock like all my other windows apps.

    Other than that, those are my only issues-WinXP on MBProC2D not using boot camp.

    thanks
     
  19. pcorchary

    pcorchary

    Messages:
    17
    So far, So good

    Just trying 3106 today for a few hours no. My needs are somewhat modest .. no bootcamp, etc at the moment. iSight would be nice, but it's not life or death. I like the new key remapping, and i agree with other comments that cmd-W would be nice to map to alt-f4. cmd-P might be nice too.

    Too bad there is no way to connect to VPN in the host OS and then have Windows in Parallels work with in that...

    philc
     
  20. scottD

    scottD

    Messages:
    3
    I'm glad to know I'm not the only one. I'd try switching to NTFS but it is more convenient to me to be able to read and write the bootcamp partition. Maybe I need to wait for the next beta...
     

Share This Page