Parallels Desktop for Mac build 3106 Beta 3 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Dec 29, 2006.

  1. kperry7505

    kperry7505 Member

    VPN and Parallels Desktop

    I successfully use my account in Parallels. In other words Windows XP is running a VPN session while the host OS is not. I had to do some research in the support page of the site to set the MTU size in Windows XP, but it was pretty simple.
  2. Bit poster

    unmounting bootcamp partition is really necessary ?

    I use windows only for unavailable program under Mac OSX. In most of them there is an embedded text editor of quite low quality. I used to share a folder with mac osx and use BBEdit to edit the various files. Moving everything to the bootcamp partition and mounting is as a secondary disk works fine, but i can't anymore use my mac editor. Is it really necesary to unmount the bootcamp partition even to mount is as a secondary disk ?
    BTW the process of requiring the administrator password and wait for the umounting of the bootcamp disk everytime i startup parallel is also a little bit irritating :)
  3. Platinum Samples

    Platinum Samples Member

    I'll be waiting until this is fixed -- I cannot have BootCamp unable to have MacDrive functioning (not while in Parallels). This is a deal breaker for me - I need to run Pro Tools HD under Boot Camp and be able to access HFS+ drives.

  4. Adam Wilt

    Adam Wilt Bit poster

    Installed 3106 on two MacBook Pro Core 2 Duo machines to use Windows XL SP 2 using Boot Camp as the bootable system. One was a fresh install, one had build 3036 already on it, but only with a separate (non Boot Camp) XP VM set up. I set up a new XP VM using Boot Camp on both systems.

    Both systems take a LONG time to boot from the Boot Camp partition compared to the 3036 upgrade system's performance from its own VM disk image). Both ask for my password before starting, and both reload Parallels Tools (with the semitransparent warning window overlaying the screen) on every startup.

    On the fresh install, I was only given networking options for Bridged Ethernet or no networking; on the 3036 upgrade, I had all networking options.

    On the fresh install, Coherence mode was disabled (according to Parallels Tools in the Windows session), and indeed it did not work. On the 3036 upgrade, Coherence works properly.

    On the fresh install, my VM's screen size was fixed: if I drag the window larger or smaller, I got scroll bars (if smaller) or the Windows desktop centered in a black background (if larger). If I reset ANY video parameter in Windows Display Properties--screen size, color depth, etc.--my mouse pointer becomes unresponsive, slowly drifting down and to the right if the mouse is moved; I have to shut down & restart to regain mouse control. On the 3036 upgrade, resizing the screen works properly via dragging the window corner or via resizing in Windows Display Properties, and the mouse remains responsive.

    Uninstalling and reinstalling Parallels Tools (several times) fixed the lack of automatic resizing and the inability to use Coherence mode, but either of these options still breaks the mouse. It may be of interest that on this system, I can still press Ctril+Alt to release the mouse to OS X, and then the Parallels status bar says "Click inside OS Window to capture mouse"; on the 3036 upgrade system, Cntl+Alt does not release the mouse, which simply operates inside the OS Window whenever I move it there (the "Click inside" message appears whenever the mouse pointer travels outside the window).

    When Parallels Tools is installed, the fresh install takes a LONG time from the time with Windows Desktop appears until the Windows Taskbar appears. On the 3036 upgrade, or on either machine with Parallels Tools uninstalled, the Taskbar comes up quickly.

    Does the prior installation of 3036 on the machine that works better offer any clues? Is it possible that some crucial VM setup steps aren't being properly completed on a virgin installation?
  5. mark.burton

    mark.burton Member

    I have a USB Rainbow Superpro dongle (licence key) for a Windows program. Its a USB 1.x key but it is not being seen by Win XP via Parallels.

    It also licenses a Mac version of the same program, could it be that Mac OS X is 'holding' onto it when its plugged in?

    Parallels b3106
    MacBook Pro 2.16Ghz
    2GB Ram
    Mac OS X 10.4.8
    Bootcamp VM
  6. Evinyatar

    Evinyatar Bit poster

    I installed MacDrive 6 after I installed parallels tools and it works just fine in BootCamp.
  7. mark.burton

    mark.burton Member

    I still get the Parallels Tools setup message overlay during startup every time. The tools are installed and up to date and the message goes away after WinXP loads, but it seems like a bug that it keeps coming up.
  8. don montalvo

    don montalvo Hunter

    i have sonicwall client working within parallels without a hitch. so far the pc admins are quite impressed. :)

  9. fearless

    fearless Bit poster

    I have the same problem. New build worked great on a newly installed Windows bootcamp partion--but now the Parallels version is asking for me to reactivate my copy of XP with a new number. I still have 30 days--so I don't want to activate the bootcamp or Parallels versions until someone has found a fix. Has anyone called Microsoft for a new number? Did that work?
  10. conalho

    conalho Member

    Latest beta (build 3106) still not working with Garmin Forerunner

    I downloaded the latest beta build (3106) and wouuld like to make a note that this beta build does not work with the Garmin Forerunner 205. However, at least now the USB device is recognised as "Garmin International" when I go to the USB submenu.

    Hoping for a fix soon!

    However, I also hear that Training Centre for Mac (the Garmin software that works with Forerunner models) will be out by end of January 2007! Now, when that comes out, good bye to Parallels for me! :)
  11. sander

    sander Bit poster

    coherence woks great

    since the new beta 3106 came out, coherence works great.

    i use it all the time arround the day for my programs.
    most used is internet explorer 7 for webpages that aren't visible in safari.
    and outlook 2007 for mail and testing with exchange 2007.

    usb response could be better, i have a feeling that it takes to long.
    when working with explorer 7 and scrolling down it looks like parallels scrolls like 2 seperate images really weird.

    for the rest keep going forward for this great product.
  12. dmp57

    dmp57 Bit poster

    Coherence + Multiple Monitors still does not work

    This is on a MacBook with an external monitor used as the main monitor.

    Coherence mode works ok with "multiple monitors" not checked. But when I check "multiple monitors" and switch to coherence mode, the best that happens is that the program window disappears completely.

    The worst that happened, on one occasion when I was tinkering with this, was a kernel panic. In case it's helpful, here's the report from the kernel panic:

    panic(cpu 1 caller 0x001A3135): Unresolved kernel trap (CPU 1, Type 14=page fault), registers:
    CR0: 0x8001003b, CR2: 0x00000000, CR3: 0x00da9000, CR4: 0x000006e0
    EAX: 0x03d36580, EBX: 0x03b59250, ECX: 0x00000000, EDX: 0x03b87600
    CR2: 0x00000000, EBP: 0x250c3ec8, ESI: 0x00000002, EDI: 0x3c1a5000
    EFL: 0x00010206, EIP: 0x03cdbf21, CS: 0x00000008, DS: 0x00000010

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x250c3ce8 : 0x128d1f (0x3c9540 0x250c3d0c 0x131df4 0x0)
    0x250c3d28 : 0x1a3135 (0x3cf1f4 0x1 0xe 0x3cea24)
    0x250c3e38 : 0x19a8d4 (0x250c3e44 0xe 0x250c0048 0x190010)
    0x250c3ec8 : 0x3d0e76c6 (0x3b59250 0xed64940 0x3d0eb054 0x12a)
    0x250c3ef8 : 0x3d0ea7ca (0x3cd9880 0x297 0x250c3f28 0x3d0e6e2d)
    0x250c3f28 : 0x3d0e87a9 (0x5e59d84 0x3d0eb548 0x3d0eb564 0x2c)
    0x250c3f58 : 0x3d0e6577 (0x5e59d84 0x3d0eac30 0x3d0eac10 0x16a)
    0x250c3f88 : 0x3d0e66b2 (0xd000000 0x0 0x0 0x3e099c4)
    0x250c3fc8 : 0x19a74c (0x0 0x0 0x19d0b5 0x3815f5c) Backtrace terminated-invalid frame pointer 0x0
    Kernel loadable modules in backtrace (with dependencies):

    Kernel version:
    Darwin Kernel Version 8.8.1: Mon Sep 25 19:42:00 PDT 2006; root:xnu-792.13.8.obj~1/RELEASE_I386

    Model: MacBook1,1, BootROM MB11.0061.B03, 2 processors, Intel Core Duo, 2 GHz, 2 GB
    Graphics: Intel GMA 950, GMA 950, Built-In, spdisplays_integrated_vram
    Memory Module: BANK 0/DIMM0, 1 GB, DDR2 SDRAM, 667 MHz
    Memory Module: BANK 1/DIMM1, 1 GB, DDR2 SDRAM, 667 MHz
    AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x86), 0.1.27
    Bluetooth: Version 1.7.9f12, 2 service, 1 devices, 1 incoming serial ports
    Network Service: Built-in Ethernet, Ethernet, en0
    Network Service: Parallels Host-Guest, Ethernet, en2
    Network Service: Parallels NAT, Ethernet, en3
    Serial ATA Device: TOSHIBA MK1234GSX, 111.79 GB
    Parallel ATA Device: MATSHITADVD-R UJ-857
    USB Device: Built-in iSight, Micron, Up to 480 Mb/sec, 500 mA
    USB Device: Bluetooth HCI, Up to 12 Mb/sec, 500 mA
    USB Device: Apple Internal Keyboard / Trackpad, Apple Computer, Up to 12 Mb/sec, 500 mA
    USB Device: IR Receiver, Apple Computer, Inc., Up to 12 Mb/sec, 500 mA
    Last edited: Dec 31, 2006
  13. jp20r

    jp20r Junior Member

    I dwnld 3106 (was on 1970)
    3106 doesnt lauch Win 2K, only XP . my problems , how do i transfer the applications and documents that are stored in (C) W2000 to XP (C) which is empty ?
    Do I use Transporter ? how ?
    thks for yr help
  14. rnomad

    rnomad Junior Member

    Link Down

    The server has been down since yesterday, at least for me. I have tried more than 10 times.
  15. Ainvar

    Ainvar Member

    I get this exact same error when I try to boot my bootcamp xp on ntfs.
  16. demsharp

    demsharp Bit poster

    Anyone found solutions to any Boot Camp problems?

    I've been experiencing a combination of two situations with Build 3106 others have been reporting when trying to get Parallels to boot from a Boot Camp partition.

    I first was getting the "Parallels desktop cannot find necessary drivers to configure your boot camp partition" error, along with the Boot Camp partition (FAT32) getting unmounted from the system.

    After a few reboots and fresh attempts, I began getting the "unable to mount bootcamp disc image" error message instead.

    Somewhere in here, Parallels also placed a 0 kb file called "Need Install Parallels Tools" on the Boot Camp partition.

    Occasionally, it simply freezes the entire Mac.

    I am able to boot into WindowsXP (SP2 Clean Install) normally through Boot Camp, and tried installing Parallels-Tools-Bcp-1.0.3-Win.exe there... It gets about 90% through the install and then bails out after registering components with "Error Code 1."

    Has anyone yet identified a workaround/fix to these problems, as obviously others have been able to get this to work successfully?

    (Using my old Parallels 2.2 virtual disk image, by the way, this build works beautifully and coherence/drag-and-drop are fantastic...)

  17. Deputy-Dawg

    Deputy-Dawg Bit poster

    As several others have reported I get the message that the Parallels Desktop tools are being installed into my Boot Camp Winodows XP partition each time I open Windows XP in a Parallels VM. While this is probably not fatal it is darn strange, time consuming and a bit annoying.

    Also while I no longer have the infinite loop of being asked to re-activiate my Windows XP each timeI change from Parallels to Boot Camp the problem still exists with other MS products, most notably the entire Office suite. My work arround for the moment is to only use Office suite components while in the Parallels VM. This works but does necessitate some disipline and is a bit inconvient.
  18. gavmac

    gavmac Bit poster

    Win2k on Macbook here, all fine, really impressed with the new suspend methods, neat, so fast.
  19. BillInSoBe

    BillInSoBe Member

    Coherence & Suspend --

    I've been able to successfully return to a suspended coherent session, however after the VM is restored I have screen artifacts. Please see the attached screen shot. Please notice 3 items on the attached screenshot:


    1. There are extra pixels added to the bottom of the start bar (located at the top of the screen).
    2. Notice the Properties pane. Notice there is a chunk missing from the left hand side, as well as background displayed to the right.
    3. Notice my internet explorer window now displays the windows background to the right and bottom of the window.

    Closing the IE window does not fix the problem. If I relaunch same thing occurs. Looks like when I get to this state all window placements are slightly off. I can move my mouse over areas and they do not select appropriately. New applications launched get trimmed incorrectly by Coherence.

    Switching to OS Window Mode and Switching back to Coherence fixes the problem. This doesn't happen 100% of the time, but is a problem nonetheless.
    Last edited: Dec 31, 2006
  20. sparker

    sparker Member

    Interesting. I sync with Palm Desktop just fine, and I'm running the pre-beta versions...


Share This Page