Parallels Desktop for Mac build 3120 RC1 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Jan 10, 2007.

  1. bjoern_kah

    bjoern_kah Bit poster

    dear parallel guys

    please tell me the reason why europeans must not use and test your betas? what's the difference between the software in us and europe (uk)?

    your product is great. thats why i bought it. but your betas are better and i would like to use them.


  2. willzyba

    willzyba Bit poster

    Slow Memory Leaking??!

    Hi TIm,
    I don't know how Parallels grabs memory, so I can only presume I'm also watching a gradual memory leak with my installation of Parallels 3120 RC1.

    When I first start up Windows, Parrallels Desktop uses about 210 MB. This gradually rises (without doing anything) to over 270 MB in the space of about 3 minutes without me doing anything.

    I'm also doing some very processor intensive work numerically modeling fluid flow, and while this is running I see the amount of memory being used creep at about faster within 'Activity Monitor' by over 100Mb during a 10 minute simulation.

    Once it has consumed about 500Mb then the memory usage does appear to remains more stable. But only just.

    Starting MS applications like Excel or Word raise the memory usage by about 2MB. This doesn't drop when I shut down the applications.

    I'm on a Mac Pro 2.66 GHz with 3GB of RAM.
    Running Windows XP SP2, with the following config (note the '...' that replace boring zero settings :
    Parallels VM Name = Windows XP
    VM Id = {015137c0-59b4-42e1-95c0-a029a98655bf}
    VM Description = 
    Boot = c
    OS Type = 135
    Memory = 804
    Video Memory = 16
    Memory block size = 10
    Acceleration level = 2
    Enable write-back disk cache = 1
    VT-x support = 1
    Start auto = 0
    AutoShutdown = 0
    Start full screen = 0
    Start dashmode = 0
    Start full screen warning = 1
    PC Speaker enable = 1
    Multi frame = -1
    [Shared folders]
    Shared folders enabled = 1
    Global sharing enabled = 1
    Shared folders count = 3
    Folder0 enabled = 0
    Folder0 readonly = 0
    Folder0 name = Data
    Folder0 path = /Volumes/Data
    Folder0 descr = 
    Folder1 enabled = 0
    Folder1 readonly = 0
    Folder1 name = My Documents
    Folder1 path = /Users/will
    Folder1 descr = 
    Folder2 enabled = 1
    Folder2 readonly = 0
    Folder2 name = Unix
    Folder2 path = /Volumes/Unix
    Folder2 descr = 
    Video resolutions enabled = 0
    Video resolutions count = 0
    Show taskbar = 0
    Relocate taskbar = 0
    Exclude Dock = 1
    Multiple displays = 0
    [Floppy disks]
    Floppy 0 enabled = 1
    Floppy 0 = 1
    Floppy 0 image = /Users/will/Library/Parallels/winxp.copy1/unattended.fdd
    Floppy 0 connected = 1
    [IDE devices]
    Disk 0:0 enabled = 1
    Disk 0:0 = 1
    Disk 0:0 media = 0
    Disk 0:0 connected = 1
    Disk 0:0 image = winxp_plain.hdd
    Disk 0:0 cylinders = 40635
    Disk 0:0 heads = 16
    Disk 0:0 sectors = 63
    Disk 0:1 enabled = 1
    Disk 0:1 = 2
    Disk 0:1 media = 1
    Disk 0:1 connected = 1
    Disk 0:1 image = Default CD/DVD-ROM
    Disk 1:0 enabled = 0
    Disk 1:0 = 0
    Disk 1:1 enabled = 0
    Disk 1:1 = 0
    [Serial ports]
    COM1 enabled = 0
    COM1 = 0
    COM2 enabled = 0
    COM2 = 0
    COM3 enabled = 0
    COM3 = 0
    COM4 enabled = 0
    COM4 = 0
    [Parallel ports]
    LPT1 enabled = 0
    LPT1 = 0
    LPT2 enabled = 0
    LPT2 = 0
    LPT3 enabled = 0
    LPT3 = 0
    Sound enabled = 1
    Sound = 1
    Sound connected = 1
    Sound device = dsp
    Mixer device = mixer
    Network enabled = 1
    Network = 1
    Network connected = 1
    Adapter No = 0
    Adapter name = Default Adapter
    Adapter type = 4
    Port = 0x00000300
    IRQ = 3
    MAC address = 00f0937a9f4c
    Network2 enabled = 0
    Network2 = 0
    Network3 enabled = 0
    Network3 = 0
    Network4 enabled = 0
    Network4 = 0
    Network5 enabled = 0
    Network5 = 0
    USB enabled = 0
    USB = 1
    USB autoconnect = 0

    On a separate note my Shared Networking doesn't work and no amount of installing or re-installing seems to help that.

    Otherwise a great product.

    I'm heading back to the 1940 release to test the above. The new features are great, but I would focus on making it work now - and multiprocessor when thats done.
  3. rjgebis

    rjgebis Hunter

    Not sure if this would be the same problem. But when I have Parallels set to Automatic (Memory settings) and I run two Red Hat and XP (256 and 640Mb). After I close one of the the memory allocated by Parallels is not being releases. Is there any reason for this? Since it is set to Auto?
  4. Doobla

    Doobla Member

    You can get a temp key for use with the beta. Just see the note on the beta release page.
  5. Doobla

    Doobla Member

    It would be great if you would enhance the keyboard remapping a little to allow custom key maps. Alt+Tab and CMD+Tab mixups are getting more frequent as I begin to use coherence mode more often.

    Plus, then we could do some more natural key remappings such as having the CMD key open the start menu instead of control but have CMD+V still paste, etc.
  6. bjoern_kah

    bjoern_kah Bit poster

    thanks. i thought that's the 10 days trial. 1 month is long enough.
  7. Rowboat

    Rowboat Bit poster

    External HD not visible in 3120

    I'm experiencing the same problem and have since rolled back to beta 3 which works fine. Any additional infromation on this issue?
  8. RobertRenneker

    RobertRenneker Bit poster

    Windows XP install?

    Okay, I am back at it today, trying to get Parallels 3120 to run Windows XP..

    Yesterday, somehow the installation process wasn't booting or recognizing the XP disk (funny, it did for the 1970 build?) so it was recommended to me that I make a disk image.

    Thank you, I've move a bit further in the process. Using Custom Install (and Finder to add the .iso extension) Parallels recognized the ISO and I am now at the next screen (blue) Windows XP Licensing Agreement ... stuck.

    Bottom of the dialog box indicates use "F8 = I Agree" however nothing happens when I press F8.. or any other choice.

    How can I proceed?
  9. CountZero

    CountZero Member

    Make sure you F8 key is not mapped to Expose function. Turn it off in System Preferences should do the trick.
  10. RobertRenneker

    RobertRenneker Bit poster

    Windows XP is up and running, so far, so good :)

    Parallels Team.. PLEASE do not make me have to reinstally Windows again when you finish the beta..please, I beg of you.

    Thanks all for your help.
  11. BillJ

    BillJ Bit poster

    I have the same issue with Shared Network... Since upgrading to RC1, the option is greyed out and I cannot select.
  12. Stevamundo

    Stevamundo Pro

    Just backup your VM files.
  13. sandinak

    sandinak Bit poster

    mouse drifting problem

    This remains a problem .. and to date.. I have yet to see anyone from Parallels mention they're working it. It's been asked for in a separate thread.. i am asking here.. Please let us know you're working this and what we can do to help you solve it.

    it's wonderful all the people saying "what problem?!!? works for me" but that only makes it more frustrating that it doesn't work for the rest of us ;-) So please don't bother. I'd be willing to send the parallels guys whatever you need to help .. i've tried some base TS by checking config .. both parallels and windows and have yet to find anything. Tho I must admit .. it's hard when I don't have a working configuration to go from ;-)

    If any of you "I am working" peeps would be willing to share your mouse config .. system config .. anything that we-who-don't-work-and-would-love-to-rock-like-our-peers could use to help us get going would be great.

    Tim: I like the changes I hear about .. lets see if we can get to a place where we can help ya test too.
  14. drval

    drval Pro

    I guess I really can't help because I don't use a mouse, only the trackpad.
  15. dkp

    dkp Forum Maven

    What kind of
    OS (host):
    OS (guest):
    Other peripherals:
    Drivers you have installed in guest:
    Parallels version:
    Parallels config:
    RAM given to guest:
    Symptoms you see:
    Any additional info you think is important:
    Is it possible user error is a factor? Explain:

    Send to

    Try to remember you are a beta/RC software tester and that this is not a help desk. They provide you with an unreleased, known to be defective product, you provide them information about your experience with it; they try to reproduce the problem in the lab. If they cannot then they may request additional information. You may or may not be given a solution. My guess is you will not until the next RC or GA.

    If you are using a released product (1970 is the newest GA release) then send the same information to In this case you deserve and have paid for an answer.

  16. rjgebis

    rjgebis Hunter

    I just noticed (as I reported before ) When I run RH4 the CPU usage hovers around 45-55% on both cores. Since I put my laptop to sleep very often while parallels is running perhaps this has something to do wit it? I also noticed some message in the RH login screen (I do ssh to it from Mac terminal) Here is the message

    set_rtc_mmss: can't update from 48 to 2
    set_rtc_mmss: can't update from 0 to 58
    set_rtc_mmss: can't update from 1 to 59

    Any clues? This is quite high usage when nothing really is running on Mac os Linux accept Parallels. (Well and other Mac services :)

    Update. As soon as I did shut down the RH 4 Mac CPU usage dropped to 3-4%
    Last edited: Jan 16, 2007
  17. mediaholic

    mediaholic Bit poster

    Exposé/Dashboard not functioning periodically in RC1

    Every once in a while, I'll try to invoke exposé or dashboard and it won't work either. I'm running RC1 in Coherence mode and the fix described above also works for me. FYI, I also have Growl installed. I hope you are able to fix this by the major release!

    Also, is it normal for Parallels to take up about 40-50% CPU resources while music is playing?
  18. willzyba

    willzyba Bit poster

    I had a problem getting Windows to power up when I switched to the latest build. What would happen is I would get the normal initial 'Windows' screen with the progress bar indicated Windows is loading, but as soon as it moved onto my specified screen resolution parallels would resize and that would be it.. A black box. The mouse appeared to change, but there was nothing I could see or do.

    To resolve this I hit F8 instantly after launching windows (before you see the Windows loading screen), and going into Windows using Safe Mode. I'm then able to able to install the latest parallel tools for Windows (under VM - I think). Rebooted Windows and everything is fine..

    Basically the latest version of Parallels seems to uses different graphics drivers.

    Hope this helps
  19. henrikl

    henrikl Bit poster

    USB Problem

    I have a problem using the USB 2.0 Device CAS 3 from It used to work in the previous version, but stopped with the latest release. The device is recognized and i hear the bing that registers the USB-Device and then instantly the sound that unregisters it again. The Application (CAS-Studio 7.9c) and the whole windowsxp hangs.
    Great version otherwise....
  20. terryhatmaker

    terryhatmaker Bit poster

    I am running windows xp service pack 2 and the RC1 candidate. This has release has taken my MacBook 2 GHz with 2 GB RAM hostage. I am seeing the RAM usage creep up during usage and the biggest problem is that it takes over any where from 40-60% of the CPU usage. My MacBook sometimes acts like it is hung because there is so little CPU. This occurs with Parallels in the background. I am thinking I want to go back to the previous beta release!

    Terry Hatmaker

Share This Page