Parallels Desktop for Mac build 3120 RC1 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Jan 10, 2007.

  1. Olivier

    Olivier Kilo Poster

    I may be lacking sleep these days, but I don't clearly get what possibly got changed regarding drag/drop support between host and VM, moving from 3106 to 3120? What does 3120 bring regarding drag/drop that previous beta did not have? Thanks!
  2. mr zippy

    mr zippy

    Unbuntu 6.10 Edgy Eft bugs

    Still "ACPI: Unable to locate RSDP" error on boot
    Still no splash screen on startup or shutdown
    Still does not detect shutdown complete, so I have to stop the VM
    Corrupt background on some icons if you set a Panel at the bottom of the screen to transparent background eg.. the show desktop icon has corrupt background, works OK on my laptop (PC based).
  3. jkneen


    latest build worked, just

    In installed Build 3120 last night and then unsuspended my XP VM. All worked and then installed Parallels tools. I shut down and this morning booted up and it crashed as the login screen came up. Tried again and it crashed. I had got a weird network card message on bootup.

    I removed the network card, CD, Floppy and restarted. Managed to login and go the Windows Activation thing. Shutdown and turned on CD, Floppy and Network and restarted.

    All fine but had to re-activate.

    CPU time seems less with this build.

    MBP 2.33GHZ 3GIG
  4. Olivier

    Olivier Kilo Poster

    You really really really should shutdown your XP VM first so that it is completely stopped before installing any new Parallels Desktop build.

    Suspending, then upgrading and the un-suspending sounds risky business because it means un-suspending a snapshot made by a previous release: it might be incompatible to some extent, it might not be auto-upgraded, and what else? Especially when dealing with betas and RC, unless you have a backup of your VM, I would refrain from that experiment. :)

    Now regarding Activation which you also mentioned, I had to re-activate my XP VM too this time (so it was probably not related to you having upgraded while the VM was suspended).
  5. ajcooper

    ajcooper Bit Poster

    fusion still not working

    Just a quick comment regarding support for Logitech Fusion. After installing the latest drivers and enabling the device I was able to see the webcam work - for about 5 seconds before Windows blue screened! Is this a Windows or Parallels issue? The camera/driver works fine on the standard PC.
  6. luz


    Steadily growing Memory Leak in 3120 and 3106

    Hello Tim,

    I see the same problem as rufosx and rhind.

    Parallels constantly increases real memory usage, at a rate of around 100k every 2 seconds.

    You requested an extended report from rufosx, so here is mine:

    I am running 3120 now (but 3106 behaved the same way) on a MBP 17" (Core Duo), 2GB RAM.
    I have assigned 768MB assigned to the VM which is running Win XP SP2. I do not use BootCamp, XP has two virtual hard drives C: and D: of 20GB and 10GB size. I use shared networking, and have shared folders disabled (global sharing as well now, but did not make any difference).

    Interestingly, the constant increase of real memory usage continues even when the VM is put into Pause mode. It stops when the VM is suspended or stopped.

    The memory increase brings my machine to a near full stop after around a day (with a memory consumption of 180MB/Hour my 2GB would be exhaused in theory after 12 hours latest not considering other apps' memory requirement, but the machine is asleep in between so that makes sense).

    I do not use coherence, but usually full screen. However the leak also exists when I use the VM exclusively in OS window mode.
    I have an external monitor I use at work (with the MBP's lid closed, so no dual-monitor situation).

    I have Sound disabled, USB and CD set to manual connect.

    I have HD cache policy set for better performance of Mac OS X.

    BTW: Like rhind, I also noticed that sometimes I can't start any Rosetta app any more - I can't say if this could be related to Parallels because Parallels almost always is running on my MBP.
  7. ajwans


    I'm still seeing CPU utilisation of 60 - 70% while the guest (Linux) is idle through the activity
    monitor on my MacBook 2.0GHz with 2GB RAM. I have heard nothing from the Parallels
    team either through my support requests or this forum to even acknowledge this problem
    although there are reports of it littered all over the forums.

    Can somebody from Parallels please admit this problem exists and let us know if it is being
    worked on? Will it be fixed for the release?

  8. purephase


    Is Vista installed on the Bootcamp partition, or XP? Parallels supports XP but whenever you try to select the Bootcamp partition after selecting Vista as the install OS the Bootcamp option is greyed out.
  9. mr zippy

    mr zippy

    USB Connection to Sony Ericsson phone no longer works (still)

    The USB connection to my Sony Ericsson Phone for updating firmware with the Sony Ericssoon Software Update (SEUS) software still does not work, this works fine with build 1970.

    SEUS detects the connection, asks you to release the C button on the phone - then nothing happens, the USB activity icon does not flash and detection fails.

  10. PeterH


    Boot Camp still greyed out

    I've just installed the Release Candidate version, but my Boot Camp installation of WXP SP2 is still greyed out. I've posted the volumes mount information before, so I guess it's not necessary to repeat it now.

    If I may, I would simply like to ask the developers two simple questions. Will Parallels recognise as a Boot Camp device an MBR disk with one NTFS partition (with WXP SP2 on it) and a FAT32 32Gb partition? My hunch is that this type of partitioning is precisely what might make my Boot Camp installation 'invisible' for Parallels. Supposing the previous question should be answered in the affirmative, here's the second, What is the simplest solution to this problem, other than merging my two partitions using Partition Magic or something like that?

    Thanks for an incredible product.
  11. timd


    I'm STILL getting the "mouse drift to bottom right" problem after entering coherence mode, or changing screen resolution in a running VM. I'm running a Core 2 Duo iMac with a bluetooth Mighty Mouse, but the problem seems to affect USB mice as well. The only resolution is a reboot.

    Great work, but this is still a showstopper for me, unfortunately.
  12. lithe951

    lithe951 Bit Poster

    Other than one cryptic reference to "coherence is broken" does anyone know if coherence is supported on dual screens? That's a major requirement for me and is the main reason I have not applied any of the previous betas - I'm happy with 1970 for now, but would love to free Windows from a single screen and get true drag and drop.

  13. rhind


    In 3106, when you dragged files from explorer to finder, took over and copied the file to OS X for you. No shared folders where necessary. Windows didn't have access to OS X, on intercepting the drag/drop.

    In 3120, your entire hardrive is automatically shared as read/write. Parallels still intercepts the drag/drop, but then copies the file to OS X via the share, not directly which is nice because it uses windows style copying dialogs rather than Parallels ones.

    But it means your entire harddrive is shared and hence read/writabe from any windows .exe that is running which I see as a security risk. Hopefully it still obeys OS X file permissions (I can't see how it can't as Parallels runs as your user, unlike VM ware which runs as root) but I'm still not happy about it because of viruses on Windows so I'll disable this functionality in 3120.

    Hope this clears things up. (I've only copied a couple of items in 3120 so am guessing how it works, but it seems logical to me).


  14. BillInSoBe


    Start on Launch - Quit on Exit Bug.

    OK. I'm sort of tired of reporting the same bug over and over. We're now at RC1 and this issue still hasn't been fixed, which is starting to worry me a lot.

    There hasn't been any response from Parallels.

    If you configure your VM to to Launch when Parallels is started and Quit Parallels after Shutdown you get into an endless loop in which you cannot reconfigure the Virtual Machine settings.

    I cannot configure Virtual Machine drives, shared folders, memory, etc. This is a really big problem that has been overlooked far too long.

  15. Ole


    More than one Windows partitions still not supported also with 3120 RC1

    I am also quite dissapointed about the priority of Parralles how the two windows partition issue is treated. At least a statement would be good if this will be supported or not...

    technical documentation was posted from me here about my configuration...

    I could also not imagine that this is a hard issue to be solved...we will see someday...
  16. STim

    STim Super Moderator


    Actually, it is fixed though not announced. When you're in VM catalogue, highlight the VM you need, press and hold Command and click Select.

    The VM configuration will open but will not autostart.

    Best regards,
  17. STim

    STim Super Moderator


    Most probably you have Logitech software version 10.4 or 10.5 installed. Try uninstalling it and installing the software that comes with the CD without letting it update through the web.

    Best regards,
  18. alessandrobo



    any information relevant to the "boot camp" option grayed out?
    It is still not avaiable in this build (for me at least...)

    In my case, I use an MBR style partition table (see below). I guess what puzzles most of us is how more complicated is to access a partition (any partition) as raw, instead of a file? At some point, you must have a virtual to physical mapping layer, that targets a file, or the bootcamp partition. Can that be made partition schema aware, and allow to choose which one to use? I think that all the people whio have this need are sophisticated enought to have created multiple partitions (typically to create a fat32 "shared" disk s, or to run linux, and we would not complain if there's no UI to select the partition, we would be happy manually changing the configuration file.


    Here is the layout, the last two partition are created as logical volumes on an extended partition (dear old MBR tricks)

    diskutil list
    #: type name size identifier
    0: FDisk_partition_scheme *149.1 GB disk0
    1: Apple_HFS MACOSX 60.0 GB disk0s1
    2: Windows_NTFS WINXP 19.5 GB disk0s2
    3: Windows_NTFS VISTA 19.5 GB disk0s3
    4: DOS_FAT_32 SWAP 3.9 GB disk0s5
    5: Windows_NTFS DATA 46.1 GB disk0s6
  19. cosjr


    I've been struggling with this also. You need to put a blurb on that screen that says to the effect:
    "To make changes to this VM setup command key and click "select"."

    A simple "edit VM setting" would be better.

    And Tim, you forgot to use a quote there about what this is about.

    Thanks for the beta.
  20. Connick


    Latest beta broke my Cisco VPN Client

    Guys, awesome tool. This is the first hitch I've run into.

    I installed the update while I was connected via VPN thru Cisco VPN. I'm on Mac Pro Intel. I uninstalled Parallels and everything worked fine once again.

    Will give it a try without VPN running and see what happens.


Share This Page