Parallels Desktop for Mac build 3120 RC1 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Jan 10, 2007.

  1. wangooroo

    wangooroo Junior Member

    You certainly have no idea how software development occurs. Even MS release candidates for Vista had known bugs.

    Lighten up.
  2. wangooroo

    wangooroo Junior Member

    What is your problem? Everything you brought up to bitch about is well documented in the release notes!
  3. lozano

    lozano Junior Member

    treo 700p sync does not work

    Just confirming that sync still does not work for a treo 700p, mb2pro, 2g. back to beta 1.
  4. idanmashaal

    idanmashaal Member

    About that nasty Memory Leak (RC1) - detailed info.

    Hello All !

    My iMac is MA200 - 1GB Ram (single dimm), Core Duo (not 2)

    Please note, that I limit parallels memory to 484MB instead of Automatic and disabled the Live screenshot in dock (in parallels preferences)

    I'm using Windows Server 2003 Standard edition (SP1).
    In Parallels Virtual Machine settings, I give it 384MB of RAM, 16MB of Video, and Caching is for Mac OS X.
    Never used or will use Boot Camp.

    The hdd is 16GB Plain (fixed size).
    Network - Bridged.

    I upgraded to RC1, rebooted iMac and then started Windows, upgraded tools, and restarted VM.

    After Windows restart, I watched activity monitor and windows' task manager.
    No other programs launched.

    Windows Task Manager is idle, everything is flat and fine.
    Parallels in Activity Monitor, is consumes more memory every 3-5 seconds (about 0.1MB)
    After 3 minutes it's at 405.75MB, Virtual Memory is growing also, but slowly.
    When I look inside parallels process (inspect and then choose memory tab) I see that Private Memory size is growing too. at the same time Real memory is growing.

    I repeated this test running Coherence, and without Coherence, with the same results.
    I even tried to uninstall parallels and parallels tools and do a clean installation - same results.

    I hope this info will help you isolate this NASTY NASTY memory leak, because this makes the whole SYSTEM unresponsive after 25 minutes.

    I just created a blank VM - removed everything possible from VM's settings. (only had memory =384MB, 16MB video) all the other settings as above.
    I started it up, and recieved "No Boot device available, press Enter to continue."
    I didn't press enter, but waited to see what happens, and guess what.....
    IT Grows every 3-5 seconds, at the same delta. (0.1MB).
    I tried with caching to Mac OS X and caching to VM - same result.

    This is one nasty leak, and it has to be fixed ASAP.

    If you need more info, don't hesitate to ask.

    Thanks in advance,
    Idan Mashaal
    Last edited: Jan 12, 2007
  5. STim

    STim Bit poster

  6. dkp

    dkp Forum Maven

    I rebooted my system 2.5 days ago, started XP in Parallels and Solaris 10 in VM Fusion. All have been running continuously since. There has been no appreciable change in memory or cpu usage. I clearly do not have the memory leak - so if there is any information I can provide about my installation I'd be happy to do so.

    I was running iTunes last evening listening to streaming audio (OS X) while installing Studio 11 on the Fusion Solaris instance from DVD. When that completed I ran some tests on the compiler and otherwise put the laptop to heavy work. In Parallels I was monitoring the task manager and had an Outlook webmail client running. And I was reading this forum in Firefox in OS X. Performance was quite good the whole time and while free mem was down to 27 meg, there were no problems with anything. I was quite amazed, to be honest.

    The base config is MacBook Pro, 2g ram, core duo, 3120 RC1, XP with current service paks. I do not allow Parallels to autoattach any hardware as that tends to confuse the two os's. I have no external hardware except a mouse. Networking is shared so that my Cisco VPN can manage all connections and it was running with a live connection for the webmail client in XP.

    All I can say is, when Parallels is running well it runs *really* well. Hopefully these sporadic problems will be solved soon.

    I'm Parallels's happiest customer and glad of it.
  7. wkharris

    wkharris Junior Member

    Build 3120 and Blackberry 8703e


    At last I can now use my Blackberry 8703e via USB with the Verizon Access Manager software to use it as a tethered modem - it works!!!!

    Keep up the great work on your product!
  8. idanmashaal

    idanmashaal Member

    Hi Steve,

    I think there is no leak now - Tested with the blank VM.
    Thanks for the tip.

  9. ricksanchez

    ricksanchez Bit poster

    No VM Catalog

    I am having the same problem, although i had been using the 1970 build until now.
  10. rjgebis

    rjgebis Hunter

    I could not agree with you more.!!!!!!!!!!
  11. dizzydeane

    dizzydeane Member

    TANX! ... Fidelity Active Trader Pro streaming problem is fixed in both Full Screen & Coherence views with Default, Ethernet & Airport Express Network Adapters. Whatever U tweaked in the Network Adapter code worked. Congrats.

    PS: When flipping between Coherence & Full Screen views the size of open windows are not sticky.
  12. rhind

    rhind Member

    I completely agree on this too. 20% on a C2D MBP 2.33GHz seems excessive for an idle WinXP system.

    I currently shut my virtual machine down whenever I'm not using it because of this. (It would be nice to leave it running).


  13. dylanharris

    dylanharris Member

    IcyBox USB drive now unrecognised

    I've got an laptop hard-disk in an external IcyBox USB case. I've not had a problem with connecting it to Windows under the previous betas of Mac parallels.

    However, under RC1, Windows recognises the device is plugged in, but no drive letter appears, and disk administrator doesn't realise it's a disk. I can no longer access the drive.

    This is a problem in both Windows 2000 and XP. These are existing virtual machines.

    The Mac sees it fine, but that doesn't do me much good because the drive is formatted using NTFS.
  14. BlueTrance

    BlueTrance Junior Member

    Thank you!! It seems that was enough for me too. :)

    Who would have ever imagined something like that...
  15. alexbet

    alexbet Junior Member

    No Coherence on 3120

    I had NO problems whatsoever with the beta so far. Now, with this built coherence mode stopped working. When I click on the coherence button, the whole window flashes and nothing happens.

    Another thing is that the network card activates after about a minute when Windows XP boots. I don't know what is causing this.

    Like I said before, I didn't have any problems so far with any of the previous builts.
  16. collinong

    collinong Junior Member

    Please, just let us choose a volume to boot from!

    I completely agree. Parallels won't recognize my separate Windows hard driver either.

    would the devs just post something on this problem. I've read the threads for the RC and last 2 betas since the Boot Camp booting became available and at first they asked for some partition listings, but to my knowledge have since never responded at all with anything on the topic. Anything would suffice for now:
    "We're aware of the problem and are working on it."
    "There is a specific technical reason why we can't let the user choose a partition for Parallels to attempt to boot from." (optional: "And the reason is...")

  17. drval

    drval Pro

    Have you sent this note to
  18. brokenbottle

    brokenbottle Bit poster

    I had the same problem you did because I didn't uninstall the boot camp tools from Beta1 prior to booting it in beta2. As of last weekend no one had reported a sure way to fix it so I just removed the bootcamp partition, created a new one and reinstalled it. Bootcamp worked fine in the beta 3 release, haven't tried it in RC1 yet. I'm waiting to read more about other people's experiences with it first.

    FYI, it seems unlikely that any future release of Parallels is going to "fix" your bootcamp partition. You'd be better off just fixing it with a reinstall if you want to actually use it.
  19. seancorfield

    seancorfield Bit poster

    One problem I saw with 3106 that is still present in 3120 is that something - some interaction that I can't isolate - causes cmd+tab and expose to stop working.

    I *think* it's something to do with the dock integration but I have tried all sorts of different settings in windows and os x in terms of notifications and manipulation of the dock without success in isolating it.

    Switching manually to Parallels (by clicking the dock icon) and then back to an OS X app seems to restore the correct behavior.

    Sorry that's a bit vague. I'm still trying to isolate the cause - as soon as I find something, I'll report it as a bug. A colleague with an almost identical configuration has never encountered this issue on build 3106.

    Hmm, one difference is that he does not have growl installed whereas I use it a lot. But the loss of cmd+tab happens even without a growl notification popping up as far as I can tell...

    Other than that (minor but annoying) glitch, everything else seems to work perfectly. Awesome product!
  20. aclaver

    aclaver Member

    Logitech IO2 Pen still not working

    Sorry, the Logitech IO2 pen is still not working in 3210RC1. The USB drivers load and it appears correctly in the Device Manager but the pen management util (appearing in the system tray) shows RED which means the pen is not recognized.

    It's a shame since it works correctly in VMWare Fusion's first beta - you'd think that Parallel would be able to get it right after the ginormous number of betas.

    I agree with the folks that find it hard to believe that Parallels could label this a release candidate with so many serious deficiencies. It still seems like a Beta 4 to me...

Share This Page