Parallels Desktop for Mac build 3150 RC2 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Feb 1, 2007.

  1. jp20r

    jp20r Junior Member

    Russell, Hi I have 2 problems u might help: (MBP CD, 2 Gb , W2k SP4 ), working w/ VB6 and Visual Studio 2005 - all files and programs are on C on win2k.
    1 / received a .RDP file to connect w/ an overseas database and W2k doesnt recognize it (neither Winzip when i extract) the logo doesnt appear, only a blank cornered page w/ the Win logo on it. do you have any idea or solution ?
    2 / I have also installed XP Sp2 , but I dont know how yo access to all the files and programs that are on C on the W2K ? therefore XP is of no use. by the way XP unzip the RDP file and recognize it, but cannot connect !
    thanks for yr help
    jean Pierre
  2. gegervision

    gegervision Hunter

  3. Josh Wolf

    Josh Wolf Bit poster

    From the FAQ:

    Q: Shared Networking doesn't work for me after upgrade. How do I fix that?
    A: Reboot your Mac. If it doesn't fix the problem, go to System Preferences -> Network. You will be prompted to configure new Network Interfaces. Agree to configuring, close System Preferences and start Parallels Desktop again. All should work fine.

    Has this actually worked for anyone? I never get prompted to re-configure.
  4. jp20r

    jp20r Junior Member

    Gegervision :
    thank you so much, I now have my remote connection !, thks again !

    - if by any chance you have also a solution to my other problem: I have also installed XP Sp2 , but I dont know how yo access from C: on XP to all the files and programs that are on C: on W2K ? and do i really need XP as what we doing w/ VB 6 and VS 2005 work perfectly w/ W2K ??

    - BTW, i'm looking for VS 2005 developpers: for connecting XML links to a VS2005 developpment for the Travel industry . (
  5. phazer

    phazer Hunter

    When you load parallels it gives you a start menu. There is usually a sidebar on the right to start it... that is missing....

    My problems seem to be occurring only away from work... my VM is on the domain... so I wonder if it is not a parallels issue... but I didn't used to have problems like this.

    What it is, is it can't start in Coherence... it does but it's terribly buggy. I can't click on anything or do anything. I have to switch to OS window mode then back to coherence... but only when I'm not on the network with my windows gets stuck at synchronizing offline files.

    Again, this didn't used to be an issue for me before the 3150 RC2 update
  6. rhind

    rhind Member

    You'll have to add the image for your Win 2K drive C as a second hard-drive of your WinXP virtual machine but don't you'll have to ensure that you acutally shutdown the Win2K VM before starting the WinXP one (don't just suspend it as you may corrupt the hard-drive).

    If you run both at the same time, then if you set up bridged networking on both, you should be able to use windows file sharing to access both machines form one another.

    I am doing VS2005 development but currently am very busy for the next 3 to 4 months. Feel free to e-mail me details at, but not sure if I can be of any help in the short term.


  7. eighteentee

    eighteentee Junior Member

    Build 3150 exhibits serious stability issues in either XP or Vista. Constant crashes and lock-ups together with extremely poor performance compared with build 1970. I'm running on a Macbook Black with 2gb RAM.
  8. jbrowdy

    jbrowdy Member

    Tools Crash

    I am not getting a response in another thread about a Bug, so I'll report it here. Please read: This Thread.

    Thank You
  9. darreln

    darreln Member


    I would agree with you. I run Vista Ultimate, and performance has been very sluggish at best. Almost feel like back in the oldern Virtual PC days ;-)

    Running a MBP 2Gb RAM, latest iteration.

  10. dailo

    dailo Member

    Turning off visual effects in Vista makes it run like a champ in Parallels, granted not ideal but its much faster. Once Parallels Implements 3D support, I think it will run a lot smoother.
  11. drval

    drval Pro

    GUI-related issues have always been a central concern, esp as increasingly sophisticated and resource-demanding features begin to be implemented.
  12. CountZero

    CountZero Member

    Have you tried the native RDP client on the Mac?
  13. srcshelton

    srcshelton Bit poster

    Parallels 3150 destroyed my XP installation :(

    I'm not sure if I was very unlucky here, or I've uncovered a subtle bug in 3150:

    I had been using the previous Parallels beta (RC1, presumably) to boot XP to try to configure a Wireless bridge device, and as such changed the Bootcamp VM's networking settings to Shared, but using en0 rather than auto-detecting the interface.

    I upgraded to 3150/RC2 and started the VM - which booted just fine but Parallels warned me that networking wasn't available after Windows reached its login screen. I shutdown the VM via the Windows 'Shutdown' button in the bottom-left of the login screen, edited the VM to change networking back to autodetect, and restarted the VM.

    This is where things have broken: Now, if I try to start the VM *or* if I try to start XP directly via rEFIt, it stops immediately stating that the system registry is corrupt ("Windows could not start because the following file is missing or corrupt: \WINDOWS\SYSTEM32\CONFIG\SYSTEM") :(

    This error occurs immediately after Parallels chooses its profile when running as a VM, or as soon as NTLDR has bootstrapped when running for real.

    I'm hoping that the XP CD's Repair feature might be able to recover the system - but Parallels RC2 has definitely caused a serious problem in this instance.
  14. jerome_istin

    jerome_istin Bit poster

    Windows XP Activation not solved with build 3150, please help!

    Hello folks !

    I just installed yesterday the build 3150. I had a OEM Version of Windows on my bootcamp partition.

    Once Parallels was opened using bootcamp, I had a "Windows need to be reactivated within the next 3 days" message box. I told myself that I was logic, because it was an OEM version.

    So I get a brand new XP2 Home Edition full version software ($200!) that can be (normally installed several times before needed to be reset), installed it on my bootcamp partition and activate it. I went back to Mac OS X, reinstalled Parallels and discover that I have the same message box :eek: ... Questions:

    I read that this activation problem was solved in build 3150. What's happening?

    I read several posts about the problem but no really a solution (at least one working). I tried to change the MAC address in the Parallels VM, doesn't solve the problem and I can't use Internet in Mac OS after the mod.

    I think my mistake was that I activated Windows in bootcamp and not in Parallels first. So now, I don't have the problem of reactivation in bootcamp but only in Parallels. Somebody also write that I can call Microsoft and ask them to reset my activation. If I do that in Parallels, will I be able to use the bootcamp version as well? Or I will "invert" the problem?

    Thanks in advance for your help in this matter!


    I'm replying to myself hoping that I will find the solution to my problem...

    Yesterday, when I installed b 3150, I did it a first time with my OEM version of Windows on bootcamp. After that, I uninstalled it, installed Windows and reinstaled Parallels. I think in between in cleaned all the preferences files for Parallels.

    Maybe not, and Parallels still think that my OEM version is there. Does somebody knows where this information can be stored? Which preference file I forgot to delete?

    I would really enjoy Windows in this new version of Parallels for more thant 3 days

    Thanks again for you potential help!
    Last edited: Feb 13, 2007
  15. brute

    brute Bit poster

    'More than one partition...' problem solved!


    I've been having the 'More than one partition' problem on boot with Parallels, and can verify a culprit (thanks to another member who posted earlier).

    If you have an external hard drive on a USB2 port, (in my case, I'm attached to a usb hub with a drive attached to it) Parallels will religiously alert you to a 'More than one partition...' problem.

    Once the drive was unplugged, I was able to boot into Parallels again, with no problems. I've replicated this several times, and can verify that this is problem and the solution works.

  16. jp20r

    jp20r Junior Member

    Thanks for yr tip - I'll try to connect that way as well ( as it finally worked on PC side), but so far I couldnt connect thru the Mac side, if u know the RDC screen , under User and Password there's a Domain to fill in, and I dont have that info ? is that important for the connection - I dont see the same request on the PC side soft.
  17. jbcaro

    jbcaro Member

    jerome_istin posted:

    I did my activation in bootcamp first. After installing RC2, and being informed in parallels that I needed to reactivate, I called MS and told them that I was just reinstalling using Parallels software on a Mac and they promptly gave me another activation key. No fuss, no muss. Couldn't have been easier unless there was no activation required.

    Now XP works in bootcamp and Parallels without any more activations.

  18. jerome_istin

    jerome_istin Bit poster

    Thanks a lot for sharing your experience!

    I call them right now!
  19. Svirsky

    Svirsky Junior Member

    I need help fast. I am using rc 3150 activation key expires today. System does not accept the actual key code from the Parallels version I paid for online from Parallels. So at the moment I am without Parallels please help fast,

    reply to my email;
  20. Josh Wolf

    Josh Wolf Bit poster

    You should contact Support directly for that kind of thing, not post here in the hope that someone will happen to see it.

Share This Page