Parallels Desktop for Mac build 3170 RC3 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Feb 15, 2007.

  1. jbcaro

    jbcaro Member

    Do I need to uninstall RC2 and/or Parallels Tools before installing RC3?

  2. BillInSoBe

    BillInSoBe Member

    I've never had any issue with Parallels getting through a normal work day (8-5). If I start Parallels at 8AM I can generally run normal business apps (Outlook, Word, Excel, IE (for SharePoint), GotoMeeting) until 5 or 6PM with no issues.

    The issue starts to show it's head if I leave Parallels running. A good example is I installed 3170 Sunday the 11th... let's say 5 - 7PM. I left Parallels running (with no apps) and closed the lid on my MacBook Pro (Core Duo, 2Ghz, 2GB RAM) putting it to sleep. Got to work by 8AM and worked until mid-afternoon. Parallels unexpected shutdown around 2PM on Monday (the next day).

    This is highly repeatable, however it's not something I like doing. I have 2GB of RAM. I dedicate 512 to my XP VM. During the course of any day I generally have Firefox, MSN Messenger, Parallels, Overflow, TextEdit, Address Book, iCal, Mac Mail and Activity Monitor Running.

    In Windows I generally have Outlook running then switch between various applications during the course of the day. Windows memory usage is never very high.
  3. drval

    drval Pro

    I have never seen this kind of behavior and I leave my MBP C2D 2 GB running Parallels 24/7. I use 1024 for my XP VM.
  4. sdavissm

    sdavissm Junior Member

    Coherence doesn't work either.

    Transporter worked like a charm on my old Virtual PC XP installation. I was able to retrieve the one thing I wanted out of there and haven't had access to since I got my Intel based laptop. YEAH!
  5. drval

    drval Pro


    Can you describe in a little bit more detail what does happen when you try to use Coherence?
  6. na9d

    na9d Hunter

    SWEET! Parallels now recognizes my Logitech IO2 pen! I now have no more need for my Windows desktop. That was the last thing. It's just now sitting there happily running BOINC all day long! :D

    Thanks, guys!
  7. brlandy

    brlandy Bit poster

    mouse right click

    I just upgraded to Parallels 3170 (I was on 1970) and decided to look at the keyboard mapping options. I am using a MacBook Pro. Until now I had used the default key settings. I am using a Win2K guest.

    What I would like to do is use a Ctrl-Click to simulate the right mouse click, without a shift. I would like to use the Command key for hotkeys as well as multiple select. I never use the Windows keys, so don't mind losing that functionality.

    I thought Parallels now allowed this -- I told it to swap Ctrl/Command, and told the right-click to use Ctrl only (no shift). However, this also impacted the right click sequence -- although I had picked Ctrl, it mapped to Command.

    I then tried to set the right click modifier to Command only, thinking that this would then map the mouse into Ctrl. However, Parallels requires Ctrl or Alt to be picked. I cannot pick only Command.

    I also noticed that non-Ctrl modifiers did not work for me. For example Alt-Click, Alt-Shift-Click, etc.

    Finally, I tried AutoHotKey and KeyTweak to try to remap the Win keys into Ctrl in Windows. However this only worked for Ctrl-based hotkeys; it did not work for multiple select.

    Can Parallels be changed to allow key mapping this way? Or any way to get one of the key remapping applications to work correctly?

  8. Blaster

    Blaster Member

    Interface issues with sharing

    I already turned off both Global and Local sharing options in the VM configuration, but it still keeps prompting me every time I drag and drop. And even though I click "Do not show this message again" and then click No, it still keeps prompting me. This is really annoying. In my opinion, there should be no need for this prompt at all. Parallels should simply use the settings from the VM configuration screen. If the options have already been disabled in the configuration, then Parallels should not keep nagging the user.

    I had to read the Help file in order to find out the meaning of these choices. Why don't you just display this information right in the interface? So instead of just Global and Local, the choices should be displayed as:

    __ Global Sharing (shares the whole Mac filesystem)

    __ Local Sharing (shares only your Home folder)
    Last edited: Feb 19, 2007
  9. sdavissm

    sdavissm Junior Member

    When I try Coherence, nothing happens. I've tried starting it both by the button at the side of the parallels window and by the menu item. Parallels Tools won't install either. Nothing happens when I start the installation. Eventually it freezes. The VM was created from the boxed version of Parallels (build 1970). I imported an old Virtual PC VM and Coherence worked there as did the install of Tools. I'd use that one, but XP won't activate without a call to India and that was painful the last time.

    UPDATE: I got it to work. I noticed that Parallels Tools Center was running. So, I did a fresh reboot, click on that icon and clicked on Exit. I also disconnected the two shared folders I had. Then went up to the menu and did an install of Tools. The install worked and now I have coherence! YEAH.

    UPDATE 2: I LOVE Coherence! However, now it asks me for my administrator password when I start up and when I shutdown the VM.

    UPDATE 3: That password problem just disappeared.
    Last edited: Feb 21, 2007
  10. cosjr

    cosjr Bit poster

    Keynote vs MediaShout

    If Keynote did anything near what MediaShout does, I would be quite pleased. The two apps use an entirely different approach to presentations. I do use Keynote every single week for presentations to teach a class. For this purpose, it can't be beat. (Beautiful graphics, easy builds etc.) Keynote is more in the style of Powerpoint. MediaShout is a totally different thing. No way to compare them. You'd have to try out the MediaShout trial version to understand the differences. MediaShout is more of a database driven "quick change artist" "live" presentation application.

    I really wish Keynote had the guts of MediaShout. Mediashout looks like a cut and paste, held together with glue and staples compared to the Keynote interface. Hoping someday Keynote will grow up.

  11. jbwjim

    jbwjim Junior Member

    Lost USB in Bootcamp VM

    Since installing RC-3, I have lost all my USB Connections in my Bootcamp VM. Works fine in my XP VM. Also, USB works fine if I boot up Bootcamp by itself. Any Help?? Thanks in advance..... JIM:confused: :confused:
  12. newf709

    newf709 Junior Member

    Just want to let you guys know that I could not do a fresh install of XP with this build. I had to install 1970 to install XP then I installed RC3 3170. Still needs work guys!
  13. NotSoLucky

    NotSoLucky Bit poster

    Non Working Keyboard and Mouse

    I posted the following when RC2 was released. I just installed RC3, upgraded the Parallel Tools and tested again. The problem persists. The keyboard and mouse do not work unless they are specifically selected from the USB menu, at which point they become unavailable in MacOS X.

    Could you fix this for RC4? Seems like a rather basic necessity and other seem to suffer the same bug.

    The following report applies equally for RC1 and RC2. In the case of RC2, the Parallels Tools in the VM were updated to the RC2 versions before testing.

    I've been attempting for some time now to enable the keyboard and mouse functionality of a Windows XP VM under MacOS X 10.4.8 in a 17" Intel MacBook Pro. The VM in question is an image of a Dell laptop I own. I attempted for a long time to use several versions of Transporter to create the image with little success. Eventually I used VMware Converter to create a VMware disk image and the used Transporter in MacOS X to convert the VMware disk image to a Parallels VM. This worked the first time.

    I am using an Apple Wireless (Bluetooth) Keyboard and Mouse. I've tried the following both with the wireless devices on and with Bluetooth disabled. I've tried using both the laptop keyboard and trackpad, and the wireless keyboard and mouse, both with the same result.

    Upon booting the Windows XP VM I can use the F5/F8 keys to select boot options. In addition, after clicking on the VM to capture the keyboard and mouse I can use Ctrl-Alt to release the focus, so I know Parallels and at least the boot loader are receiving keyboard input.

    Upon the Windows XP, after capturing the keyboard and mouse input by clicking on the VM, the keyboard does not appear to work. The mouse mostly does not work. Moving the mouse over the VM changes the icon to that of Windows and moving out of the VM changes the icon back to that of MacOS, but trying to click or drag inside the VM produces no result. Neither does using the Actions -> Send Keys menu to send a Ctrl-Alt-Delete key combination to the guest OS.

    If I select from the Parallels USB menu to enable the wireless keyboard in the VM I can then use that keyboard to login into Windows XP, while the mouse still had problems. If I then go into the Windows XP Device Manager and disable the Parallels Mouse Synchronization Tool device (under Mice and other pointer devices), then the wireless mouse works within the VM (as long as its selected via the USB menu). The wireless keyboard and mouse are listed in the Parallels USB menu as "Apple Wireless" or "Apple - Composite". While the wireless keyboard and mouse are enabled in the VM, they cannot be used in MacOS X (like any other USB device enabled in the VM). While this is the case, I can use the laptop's keyboard and trackpad to work in MacOS X or attach an additional USB mouse.

    In the Windows XP Device Manager, under Keyboards, the PC/AT Enhanced PS/2 Keyboard (101/102-Key) displays an error. Opening its properties shows a message of "This device cannot find enough free resources that it can use. (Code 12)". The Resources tab of the properties shows the following conflicts "Input/Output Range 0060 - 0060 used by: PCI bus" and "Input/Output Range 0064 - 0064 used by PCI bus".

    The Standard floppy disk controller shows a similar error (Code 12) [although the VM configuration does not have a floppy device] of 03F0-03F5 and 03F7-03F7 used by PCI bus.

    The ISAPNP Read Data Port shows a different error of "This device cannot start. (Code 10)".

    There doesn't seem to be any other errors. Other functionality such as networking, changing resolution and folder sharing seems to work. I tried to use coherency but it crashed the system, so I won't test that until I get the keyboard and mouse working well.

    I've attempted removing all non-essential devices (DVD/CD, USB, Sound, Floppy, etc) from the VM hoping that it would remove whatever device is causing the conflict without any luck.

    Does anyone have some idea on how to solve this problems to get the keyboard and mouse sharing between guest and host OS without resorting to enabling USB devices?
  14. joem

    joem Forum Maven

    The keyboard and mouse MUST be owned by OSX, and not the VM. With tools installed, Parallels will pass mouse clicks and movement and keystrokes to the VM. If the VM attempts to take over or directly access the keyboard or mouse, they will not work. This is by design and can't be changed.
  15. Stevamundo

    Stevamundo Pro

    Thank God that can't be changed. That's probably the reason why my Mac Morse code system works with Parallels.
  16. ltning

    ltning Bit poster

    Hi NotSoLucky,

    not having read any communications from you on this issue from the other threads, I'll risk repeating what others have said (or ignoring other advice) in trying to help here:

    My experience is that it is NOT a good idea to image a "real" installation - no matter which hardware it comes from - and try to use it in a virtualization environment. Or on other hardware, virtualized or not. The differences between your Dell and the Parallels environment are massive - different CPU, motherbaord chipsets, timers, graphics adapters, disk controllers, peripherals, you name it. And subjectively I'd have to say that considering how (excuse the french) fu**ed up a standard XP installation on a Dell is in the first place, I'm surprised it works even on the hardware it's indended for (though my experiences here are varying at best).

    While I do see why you'd wish to do something like this, I'd strongly suggest you install a plain XP in a Parallels VM, and if the problem persists here, there's obviously something else going on.

    If this is not an option for you, I'd suggest trying to boot the XP in safe mode, and presuming the keyboard/mouse works as it should then, take care to disable or replace with standard drivers *all* relevant (and non-relevant if it still fails) devices/drivers.

    Good luck....
  17. JLadd

    JLadd Bit poster

    I am still having this problem, too.

    I agree.

    Even when I completely removed Build 1970, down to prefs files in all accounts and the system, Parallels would quit unexpectedly when changing to full screen.
  18. NotSoLucky

    NotSoLucky Bit poster

    You did not carefully read what I wrote. As I stated, the only reason I am giving ownership of the keyboard and mouse to the VM is so that I can use them inside the VM. The reason I am doing this is because Windows XP is not recognizing or using the keyboard and mouse input Parallels passes the VM. The is the problem I am reporting. Giving ownership of the keyboard and mouse to the VM is simply a workaround the problem.
    Last edited: Feb 20, 2007
  19. NotSoLucky

    NotSoLucky Bit poster


    Thanks for your reply. You may well be right, but if that is the case then the whole effort and point of Parallels' Transporter tool is lost on me and it is arguably misleading.

    I can't install from scratch, as I don't have the install media. I've tried booting in safe mode in the past and with RC3 with no result.
    Last edited: Feb 20, 2007
  20. gmichaud

    gmichaud Bit poster

    App showing multiple times in the dock

    I still have the problem with an app showing multiple times in the dock - MindManager X5 from MindJet. Also, this bug seems to prevent the application from closing - it restarts everytime I close it, and the icon reappears multiple times.

Share This Page