Parallels Desktop Networking FAQ and Troubleshooting Guide

Discussion in 'Parallels Desktop for Mac' started by serv, May 19, 2006.

  1. Fatfish

    Fatfish

    Messages:
    12
    This Barmy

    First off I have a little quirk on my LAN, if I don't enter a specific DNS server into the airport/network settings I can't access the web in OSX, but things like skype and ichat work OK.

    Prior to the release version of parallels I had to remove this entry from my airport settings and then I could connect to the internet just fine with XP, of course I had to enter it again to have the internet work with OSX and when I did it stopped working with XP.

    OK I thought, I can live with this after all it's a beta, and everything will be OK in the final release.

    But oh no. now I can't connect to the internet at all with XP, even in host only

    Tried DHCP, it assigns me an address of 10.37.129.x (which is in the range assigned in parallels for host only - by the way) XP contol panels says it has been assigned 169.254.35.51

    If I try a manual DHCP of 169.254.35.51 in network settings my network status goes orange, if I try a manual DHCP of 10.0.0.x which is the range I use for all my macs XP stil says 169.254.35.51

    I have now tried all these combinations, with host-only, airport adapter and default adapter settings, with a specific DNS server in the airport settings and not, and in the adapter settings and not, with and without a router address, with a client ID and without, and with IPv6 turned on and off but nothing works. I've even tried 3 different subnet masks 255.0.0.0, 255.255.255.0 and 255.255.0.0

    The only thing I haven't done is manually set the DHCP in XP, but I can't figure out how to do this, I know very little about windows so maybe I just can't find out how, but I suspect manual DHCP might be disabled by the parallels adapter

    Anyone any ideas what I should try next.
     
  2. serv

    serv Parallels Developers

    Messages:
    810
    Fatfish,

    Lets start with Host-Only networking... Parallels HostGuest Adapter in your Mac should be configured to use DHCP (it is after installation). Make sure you don't have Internet Sharing active, configure your VM for Host-Only networking and boot XP. In an XP click Start button, then 'Run...', type in 'cmd' and click 'OK'. A terminal window should appear, type 'ipconfig'. Now, what address your XP has got? It should be in 10.37.129.x range (default range for Parallels Host-Only), if not check the following:
    1. Open a Terminal in Mac OS X and type 'ifconfig'. You should see en2 as UP and RUNNING and having address 10.37.129.2. If this is not the case, try rebooting your Mac.
    2. In a Mac Terminal type 'ps axuww|grep prl_dhcpd'. Is /Library/StartupItems/Parallels/prl_dhcpd process shown? If it's not look into Mac system.log if there are messages from prl_dhcpd.
    3. Make sure you have the latest Tools installed in XP. Reinstall in necessary.

    Just noticed your local network is 10.0.0.x. Please check that netmask is not 255.0.0.0, otherwise Host-Only adapter ands up in the same subnet which may lead to unexpected behaviour. In this case you may need to change Parallels DHCP settings to use different network (say, 192.168.129.0). Remember to renew Parallels Host-Guest Adapter DHCP lease after the change.

    When you have Host-Guest networking working we'll look into bridging to AirPort.

    BTW, 169.254.35.51 is the address XP assigns itself when DHCP is failing.
     
  3. Fatfish

    Fatfish

    Messages:
    12
    Thank you for the reply Serv

    Following your instructions:

    Ensured Parallels adapter was set to 'using DHCP'
    Was given address 10.37.129.2, subnet mask 255.255.255.0, router field is blank
    Ensured internet sharing (OSX) was off
    Configured VM for host-only networking
    started XP > run cmd-ipconfig
    XP has address 10.37.129.3 subnet mask 255.255.255.0, no specific DNS or default gateway
    Still no connection.

    Although I received the IP address you were looking for when runnng XP/ipconfig, I ran OSX/ifconfig and confirmed the information there you were looking for

    Not really sure what subnet and subnet masks are all about so here is some info
    My various macs function just fine with either 255.255.255.0 or 255.0.0.0 as the setting in the network prefs, my router however reports it is within the 255.0.0.0 subnet, so I don't know if this is a problem or not. It didn't seem to be though prior to final release.

    This is what I did
    Parallels prefs/DHCP:- set range to 192.168.129.1-254 (wouldn't let me set it at 0-254) and subnet at 255.0.0.0 renewed lease and was given an address of 192.168.129.3
    Restarted XP, ipconfig reported the address as 192.168.129.4
    Tried the same again with subnet of 255.255.255.0

    None of this made any difference.

    My understanding of how all this works is very limited, I keep returning in my own mind to my quirk with needing a specific DNS specified in OSX network prefs. I'm not sure that I explain this very well but here goes.

    If I don't specify a DNS server on any of my macs, I am still connected to the internet because Skype, ichat, remote logging, idisk etc still work but I can't access web pages in my browser.

    Prior to the final release of parallels, if I had a specifc DNS server specified in my airport network settings I could use skype in XP, but had no access to web pages in iE7. In order to view webpages in IE7 I had to delete the specific DNS server from the airport settings and restart the OSX. On restart there were no web pages available in OSX, but on starting XP I could use IE7

    To return to using OSX and viewing web pages, I had to re-enter a specific DNS server, web would return in OSX and stop working in XP without a restart. But just to recap skype was available at all times in XP

    With all this in mind I have tried all your suggestions in 4 ways
    With a DNS server specified in airport settings but not in the parallels adapter
    With a DNS server not specified in airport settings but specified in the parallels adapter
    With a DNS server specified in both
    With a DNS server not specified in both

    Of interest is that after installing the release version, I can no longer use skype in XP which I could before, even when I had no web pages

    Any further help would be appreciated.
     
  4. serv

    serv Parallels Developers

    Messages:
    810
    Fatfish,

    I wasn't clear enough on the point, I'll clarify a bit.
    A netmask of 255.0.0.0 for 10.0.0.0 network is an overkill (you don't have ~16 million host on your local network, right). I'd stick with 255.255.255.0.
    Your Macs and your router must be configured with the same netmask. You'll don't have to worry if Macs use DHCP.
    255.0.0.0 is an invalid netmask for 192.168.129.0 network. Again, set it to 255.255.255.0.
    Don't bother with DNS settings for Host-Only Networking. Host-Only Networking will only allow your XP to connect to Mac. In a terminal in both XP and Mac type 'ping <192.168.129.x>' where x corresponds to the other peer. Are replies coming in? If yes, your Host-Only Networking is OK. If no, you may need to turn of XP/Mac firewall for a moment.

    Now, if you have DHCP server in your router you should normally configure Macs and VMs to use DHCP. I don't quite get it why you have to fiddle with DNS settings at all. OK, try setting XP to bridge to AirPort and boot it. In XP terminal type 'ipconfig'. Did XP get the right address? if yes, try 'ping <gateway/router address>'. Does it work?
     
  5. Spanko

    Spanko

    Messages:
    1
    Networking for MacBook, answers and questions

    This is how I finally got the Internet connection working for Windows XP within Parallels, on my MacBook.

    The MacBook is connected to the Internet through wifi.

    In the OS X preferences, I started Internet Sharing from AirPort to Built-in Ethernet.

    The Parallels VM is set to use Bridged Ethernet: en0 Ethernet Adapter, for a Network Adapter.

    I did not have to configure my router to accept another MAC adress and such; it appears this connection is between OS X and Windows, not directly between Windows and the router.

    I decided to post this in case it'd help someone, but also to ask if this is really how things should be set up. Reading this thread, it seems I should instead do Internet Sharing from AirPort to Ethernet Adaptor (en2) in OS X, and then Bridged Ethernet: Default Adapter in the Parallels VM? Or should there be an en2 in the list of Bridged Ethernet adapters? There isn't, for me.
     
    Last edited: Jun 19, 2006
  6. Verdi

    Verdi

    Messages:
    3
    Want to purchase but not until this works

    Please help. I've tried all of the various combinations suggested here and still can't get networking to work properly. If I use bridged networking I can get Windows XP online but it steals my Macs IP address. Host-only with internet sharing doesn't seem to work at all. What's so frustrating about all of this is that I never even had to mess with it at all in Virtual PC - it just worked.
     
  7. Fatfish

    Fatfish

    Messages:
    12
    Thanx serv

    I changed the subnet setting on the router to 255.255.255.0
    xp would ping osx, but had to turn off the firewall in xp to allow OSX to ping XP

    still no connection in host only settings

    switched to bridge to airport and everything appears to work OK, rather strange, but there we go.

    Thanx for all the advice.
     
  8. suzerain

    suzerain

    Messages:
    4
    parallels ignores host os networking setup?

    Hi there:

    I was wondering if anyone else has an answer for this? I thought Parallels would be the 'killer app' for web development under OS X, but I too am finding that Parallels' guest OS cannot see the fake domains I have set up on OS X using Netinfo Manager. I would like to run Parallels to use XP and Internet Explorer, and see my fake domains, which are hosted under OS X on the same machine. This used to be possible with Virtual PC, and I was expecting it to be possible with Parallels when I bought it.

    Cheers,

    Marc
     
  9. serv

    serv Parallels Developers

    Messages:
    810
    Marc,

    Can you please elaborate on what is and what's not working in your case:
    1. An XP (I guess) VM is bridged to AirPort and receives an IP via DHCP just fine.
    2. VM can access your local network and the internet (through your router).
    3. Can VM ping OSX by IP address? If not, can you turn off OSX firewall temporarily and check again?
    4. Can OSX ping your VM? If not, also try disabling firewall in VM.

    Now, what exactly you have configured in Netinfo Manager?
     
  10. Verdi

    Verdi

    Messages:
    3
    I finally got host-only with internet sharing working - after following someone's tip to reboot the Mac.
     
  11. suzerain

    suzerain

    Messages:
    4

    Answers below:

    (1) Yes. It seems to be getting an IP with no problem.
    (2) I don't know (or care) about it being on my local network, but I can see www.google.com from IE in Windows.
    (3) I can ping my MacBook's OS (192.168.1.100) from the DOS prompt without issue.
    (4) I can ping Windows (192.168.1.103) from the OS X command line.

    About NetInfo Manager: It's just the 'OS X way' of doing stuff like overriding hosts, and so forth. On my MacBook, I have apache running, and supplying fake virtual domains for the various sites I work on (I am a PHP developer). So, I have http://www.mysitename.me configured to point to 127.0.0.1, so that I can type that in a Web browser and test my PHP scripts locally as if they ere running on a 'real' domain.

    This means I can work in a 'real' server environment when I am offline sitting on a mountaintop or something.

    One could also use this to block ad-serving domains, and so forth, if one was so inclined.

    So, I think I have my answer: It seems like the goal of the 'bridge' feature in Parallels Desktop is to make it as if this VM is *another* node on my network, rather than some child process of OS X.

    Though the former is very clever, and useful for other situations, I guess I would prefer the latter, because the only thing I want Windows for -- at all -- is to test my web sites in IE's crappy CSS renderer.

    So if I switch to something like 'host only' mode, does this mean that Parallels will just route through my Mac's networking, as if the whole XP environment itself was on level terms with, say, Safari? (And therefore honor whatever network settings, proxies, etc., that I am enabling on OS X?)

    (I have tried experimenting with host only mode, by the way, and I haven't yet been able to make it work, which is why I haven't answered this question on my own.)
     
  12. serv

    serv Parallels Developers

    Messages:
    810
    Marc,

    127.0.0.1 is a special address, it always refers to the host itself, the host being a real machine, a VM or whatever is running an IP stack. Using 127.0.0.1 from VM refers to VM, not OSX. OSX and XP run two separate IP stacks.
    I'd suggest you point your fake DNS entries to 192.168.1.100 (OSX IP) to achive what you want.
     
  13. aelman

    aelman

    Messages:
    5
    Can't get networking working since RC2

    So I haven't been able to get my VM networking to work since RC2; I was hoping the final release would fix it but it hasn't.

    Under RC1, I was able to get the VM to work bridged via Airport to my company's 802.11x-protected network. RC2 broke this -- DHCP does not respond to the VM. The final release exhibits the same behavior. Bridging to the wired network works, but I hardly ever have my MBP plugged into the wired network, so that's not a good solution.

    I'm more than happy to use host-only networking with Internet Sharing, but I also can't get that working. When I use host-only networking, with OR without Internet Sharing turned on, the VM is unable to get a DHCP response and self-assigns an IP address (169.x.x.x).

    When I look at the network status in the Network control panel, the Parallels Guest-Host Adapter is colored red, and says that the "cable is connected but your computer does not have an IP address..."

    I looked in Console.app and found the following message on boot (I've rebooted many times in this process, this message appears on each reboot):

    prl_dhcp[196]: Can not bind to en2.

    A couple of lines down, I have occasionally seen the following message:

    bootpd[9760]: interface en2: ip 192.168.2.1 mask 255.255.255.0

    but not consistently.

    I've tried manually bouncing the en2 interface using ifconfig. I've also tried manually killing and starting the prl_dhcpd process. It doesn't seem to make a difference.

    Any ideas would help.
    Thanks!
    Adam
     
  14. serv

    serv Parallels Developers

    Messages:
    810
    Adam,

    Have you rebooted your Mac after installing Parallels? If not, do it now.
    Make sure Internet Sharing is off (turn it on then off to make sure). Set Parallels Host-Guest Adapter to use DHCP if you changed that, and click Renew DHCP Lease button. Parallels Host-Guest Adapter should get this IP address: 10.37.129.2. Did it?
    If not in a Terminal issue 'ps axuww|grep prl_dhcpd'. Does it list /Library/StartupItems/Parallels/prl_dhcpd?
    If yes, on to Host-Only with IS.

    Turn on Internet Sharing. in OSX Terminal type 'ps axuww|grep natd' and 'ps axuww|grep bootpd', both processes should be listed. Now boot your VM. See if your VM got an IP like 192.168.2.2. If not, repeat ps commands and see if bootpd or natd has disappeared.
     
  15. suzerain

    suzerain

    Messages:
    4
    bummer...


    That's a bummer.

    Setting the fake DNS entries to the real IP address won't work. This is a laptop; I travel all over the place (sometimes at 3-4 WiFi hotspots per day), and my IP addresses change like crazy. Sometimes, I won't be online at all, and there will be no IP address. 127.0.0.1 is the only constant in the equation.

    Now I wish I was home with my old PowerPC Mac, so I could test this with Virtual PC. I recall it working, but I haven't used it in years. Alas, I'm traveling, so I can't verify it.

    Anyway, thanks for responding.
     
  16. lehmkuhl

    lehmkuhl

    Messages:
    3
    suzerain,

    I just started using Parallels for web development testing on my MacBook Pro. It's working great, but I've run into the same issue you're dealing with. I've got several VirtualHosts set up in Apache in OS X, but I use my /etc/hosts file (rather than NetInfo Manager) to point them all to 127.0.0.1.

    What would be really handy is if Parallels would set up an IP address in the guest OS that would always point to the host OS, regardless of the actual IP addresses of the host OS and guest OS. Something like 127.0.0.101, maybe? It would be equally helpful to have IP addresses on the host OS set to always point to gues OS's - again, maybe something like 127.0.0.201 for the first guest OS, 127.0.0.202 for the second, etc.?

    I'm no IP whiz, so this may just be a pipe dream. But it would be extremely handy.
     
  17. serv

    serv Parallels Developers

    Messages:
    810
    suzerain and lehmkuhl,
    If you need static IPs for your Mac and XP the simplest solution would be to use Host-Only networking. In most cases Parallels DHCP service would always assign the same addresses for Mac (10.37.129.2) and XP VM (10.37.129.3).
     
  18. rammjet

    rammjet

    Messages:
    14
    - deleted -
     
    Last edited: Jun 27, 2006
  19. aelman

    aelman

    Messages:
    5
    serv --

    Here's the weird thing. prl_dhcpd is definitely running, but I cannot get an IP address for the Parallels Host-Guest Adapter.

    A couple of additional notes:
    I tried this at home over the weekend and it did seem to work. The difference is that the Airport network at work is protected with 802.11x, while my home network is protected with a WEP key only.

    At work, if I have the Airport turned on, the Parallels Host-Guest Adapter says in Network Status:
    "The cable is connected, but your computer does not have an IP address and cannot connect to the Internet." On the configuration page, no IP address is displayed even after I hit "Renew DHCP lease" If I turn off the Airport, the Parallels Host-Guest Adapter turns orange in Network Status and says it has a self-assigned IP address (169.x.x.x), but still won't get a "real" 192.x address even if I click "Renew DHCP Lease."

    I'm guessing it's something weird with 802.11x. Any ideas?

    Thanks,
    Adam
     
  20. serv

    serv Parallels Developers

    Messages:
    810
    Adam,

    Parallels Host-Guest Adapter is totally unrelated to AirPort. It's good prl_dhcpd is running, but it may still not serve DHCP clients if Internet Sharing is active. To verify that IS is completely disabled open OSX Terminal and issue 'cat /Library/Preferences/SystemConfiguration/com.apple.nat.plist' . Somewhere in the middle of the text you should see these lines:
    <key>Enabled</key>
    <integer>0</integer>
    <key>PrimaryInterface</key>
    There are several 'Enabled' keys, you need the one above 'PrimaryInterface'. Now, the integer should be '0'. But sometimes it gets stuck at '1'. If it is, try enabling then disabling IS.
     

Share This Page