Parallels Desktop Networking FAQ and Troubleshooting Guide

Discussion in 'Parallels Desktop for Mac' started by serv, May 19, 2006.

  1. donnie

    donnie Member

    Build 1884 Breaks en2 Internet Sharing

    I have repeated this three times and got the same result each time. :eek:
    1. Uninstall Parallels.
    2. Installl Build 1848. Check Internet Sharing in System Prefs and en2 shows up in Internet Sharing as a port to share TO.
    3. Install Build 1884 RC Upgrade. Check Internet Sharing in System Prefs and en2 has disappeared from Internet Sharing as a port to share TO.
    What gives? (Note: purchased Parallels for Mac after trying Build 1862 in which Internet Sharing worked fine. Unfortunately, did not keep the dmg.)
  2. donnie

    donnie Member

    I left out a step:
    1a. Uninstall Parallels.
    1b. Reboot.
  3. alexbet

    alexbet Junior Member

    Can't see workgroup computers or shares

    Hi All,

    I have a Mac Pro with Parallels 1892 installed and XP Pro as a guest system. Everything worked fine yesterday. I could see the VM in my workgroup from the MAc and I could see the shared folders on it (I have shared folders on the VM in XP). I could also access the IIS on the XP from Safari in the Mac without any problems.

    Today (I probably did something), I can't see any of the shared folders on the XP from the Mac, nor can I access IIS on the VM from the Mac. I have rechecked everything 100 times, the workgroup is set correctly on both the Mac and the VM, the shared folders are set correctly also, and I just can't understand why I can't see the shared folders from the Mac. I can also ping the XP from the Mac, but I still can't see the shared folders. Please help, I am desperate. BTW, I can access the internet fine from both the host and the guest. Here is my configuration:

    Using a router with DHCP
    Mac Pro (host) IP:
    Win XP (guest) IP:
    Both IPs are set to be static
    Bridged Ethernet to "en0:Ethernet Adapter"

    I am very savvy in Windows networking, but I am very new with the Mac, so I might have done something to prevent the Mac from seeing the workgroup computers and shared folders. Just FYI, the workgroup name is correctly setup in "Directory Access" for SMB/CIFS. I don't know what else I should set in order to see the Windows workgroup computers/shared folders because I just swithced to a Mac.

    Please help, I really don't know what to do any more. Thank you in advance.

  4. sydbarrett74

    sydbarrett74 Member

    Hi there,
    I have a Mac Pro with 4GB of RAM (Parallels has disabled 2GB of that) and am running Vista in a VM with 1484GB of RAM allocated to it. When I go to Vista's Device Mgr, I see that the network adaptor has a yellow exclamation point. Looking further, I notice that no driver is installed. When I view the VM's properties, a RealTek 8029(AS) is specified. Is this the kind of NIC that Mac Pro's have, or just something generic Parallels chose? Here are further considerations:

    I have a Linksys WRT54GS broadband router which gives out IP's via DHCP in the range 192.168.100-254. I changed the IP for the bridged adaptor in the VM's properties from 10.37.x.y to reflect the Linksys' range. Should I not have done this?
  5. dneville

    dneville Bit poster

    Accessing Windows 2003 Server Question

    Hi All,

    I have Parallels running with Windows XP and it all seems to be running great except for one very annoying issue. I'm unable to access the main Windows 2003 server. I can access all the other workstations in the orginization fine but get a RPC not started error when I try to access the main server. I thought it might have to do with the encryption for communication but I tried to disable it with no changes.

    Help Please
  6. cyoung_mi

    cyoung_mi Bit poster

    Orinoco Usb Wifi Bridged

    I have XP installed on my VM on a Macbook Pro OsX.

    I've used my Built in Airport bridged into my VM just fine..

    But I'm trying to use a Lucent ( Orinoco ) Usb wifi device, that has an external
    antenna connection..
    But there are no OsX drivers for this device, but it works just fine in XP.

    How do I bridge this device Connection backwards so I can connect with
    OsX though this Connection??

    Last edited: Oct 8, 2006
  7. Jay

    Jay Bit poster

    This shouldn't be so difficult!

    Intel Imac. Broadband connection via comcast. Parallels installed and activated. Xp installed, can't activate because I can't get internet access. Or is it that I can't get internet access because XP isn't activated?

    Read every post I could find on parallels/windows internet access issues and still can't get on line.
    Many of the posts are very obtuse to the less than expert user. Parallels info and all these forums, hours of working on it, checking all the settings by looking at every post and help guide I could find here----- to no avail. I'm no expert, but I'm not a total neophyte either.

    A single computer user with broadband access should not have this much difficulty getting parallels/xp on line!! Why does it have to be so convoluted?

    I'd actually be relieved it it was just a matter of xp activation. i read about activating xp by phone--can one really do this?

    Is there any hope??
  8. joem

    joem Forum Maven

    If your broadband connection is directly via a cable modem, the modem may not contain a DHCP server; check the manual. If it doesn't, you have two choices. The best from the point of safety would be to interpose a firewall router between the modem and your Mac. The second best choice would be to set up host only networking and share the broadband connection in OSX to the Parallels adapter.

    Instructions are in the Parallels manual.
  9. Kjemtrud

    Kjemtrud Bit poster

    Cross Networking Problem

    Ok.. so here we go.

    I have a MacBook Pro, 2 gig of ram. At work and home I connect to the internet and mail through my airport through my Mac desktop.

    When I'm running Parallels, I need to connect to our companies domain in order to use the only program I need windows for. So I do my control alt delete thing (hint for anyone wondering, you need to use function+control+alt+delete). I log in to the network via my airport... everything works just fine (internet connection) execpt when I try to access the server, and files on the server. If I do that I need to plug in directly to my ethernet port. So your saying no big deal.. just plug in the ethernet port.. But when I do that to access the files my program needs, it shuts my internet down on my mac side.

    Anyone have any clue?!?!
  10. dtempleton

    dtempleton Junior Member

    Accessing the 'private network'


    . Host-Only Network
    In this mode your VM is attached to a private network accessible by MacOSX but invisible to the outside world and can not access outside world either, but… read on.

    um... *how* do you access the guest OS? We want to tie our OSX/BSD box to access some PC apps via the command line, and have found copSSH server to allow this on the PC.

    A private network would be great, but... what is the address to use? Am I over thinking this?
  11. bamsaleg

    bamsaleg Member

    I would like to share my experience and how I made things works. It may help other...

    What was the problem
    1) For some reason, my customer network does not like Parallel in Bridged Mode

    2) To make things work I first try shared networking. I could pingusing an ip address but not browse the internet

    3) so I looked in a real PC the DNS ip used by users logged in (ipconfig/all to get this info)

    4) back on my Mac, in the network preferences I entered this IP for the DNS server information of the Parallels NAT "network"...

    It works now perfectly.

    You may want to give it a try ;-)

    FUNKSTICK Bit poster

    Connected to local network but no internet

    My 1970 parallels windows xp says it is connected at 100mbps but Exlporer will not connect to the internet. Since I too am using a MacPro, am I to understand I need build 1892? and if so will I have to uninstall my build 1970, then install this new 1892 and re-serialize (is that a word?) ? Do I need to get a serial number specific to this build? Or can I just upgrade from 1970 to 1892? Forgive my cluelessness.
  13. mason

    mason Bit poster

    Able to access net but not all ports?

    This seems a little different from most, and is likely an issue with the Windows XP vm and not Parallels, but it still seems worth asking...

    I can access the net fine, either with bridged or shared networking enabled for my WinXP vm. What's weird is the following:

    - one of our test servers here is running on both port 8080 and port 8081
    - on my Mac I can access both, no problem (e.g.
    - in my vm I can access the one on 8080, not the one on 8081

    I'm fairly not confident it's not a firewall issue, having disabled the Windows firewall and there isn't another one installed.

    I tried telnet with the same results:
    telnet 8080 == success
    telnet 8081 == fails

    Is there anything involved in the Parallels networking setup that might cause this? I'm running build 1970, just upgraded this morning in the hopes that it might fix this problem. Any suggestions for how to check where the blockage is happening would be much appreciated! Thanks.

Share This Page