Parallels does not delete snapshot files, insufficient VM storage to launch Win10

Discussion in 'General Questions' started by DanielW37, Nov 7, 2023.

  1. DanielW37

    DanielW37 Bit poster

    Messages:
    2
    Hello! I'm running Win 10 via Parallels 16 on my 2019 MacBook Pro
    Everything was great until I enabled the SmartGuard feature. I was careless enough not to specify the snapshot rules, so Parallels actually took 3 snapshots of my VM, accumulating hundreds of GBs. Eventually, I'd get a notification "not enough storage" on a regular basis:
    upload_2023-11-7_21-30-13.png
    When I realised that was the issue, I disabled the feature completely and deleted all the snapshots through the manager tool. But my VM kept taking up more and more space. I tried resizing my WIn 10 VM to give it more storage but got this notification.
    upload_2023-11-7_21-25-8.png

    But when I click on the left button, there are no snapshots to manage...
    I went to the parallels folder, revealed the package contents in Win10.pvm, and found that there is an hdd.0 image that weights 252GB, the maximum storage allocated to a Parallels VM:

    upload_2023-11-7_21-29-2.png

    Now, I tried placing the 252GB file into the bin, but it still says there is not enough space.
    upload_2023-11-7_21-33-12.png

    At this point, I can't seem to find a solution, and am really fearful I might have to bid farewell to all my files, games, etc. stored on Win 10. I've searched everywhere for an answer, but to no avail. My last hope is that someone here went through the same thing and can help me..
     
  2. Adeboye Adeotan

    Adeboye Adeotan Staff Member

    Messages:
    338
    Hello Daniel,

    Please collect a technical report while the issue is being reproduced (click the Parallels icon > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in reply to this post.
     
  3. DanielW37

    DanielW37 Bit poster

    Messages:
    2
    Hi Adeboye, I can't seem to send a technical report - this is the error that I get when trying to collect the daya
     

    Attached Files:

Share This Page