Parallels + Hibernation = OSX Kernel Panics

Discussion in 'Parallels Desktop for Mac' started by golanbenoni, May 1, 2007.

  1. golanbenoni

    golanbenoni Bit poster

    50% of the time or more, when placing OSX into Hibernation Mode (where memory gets recorded to disk, and power is shut down - as seperate from sleep mode) I run into Kernel Panics on wake-up. This has never happened before my installation of Parallels, and I'm convinced the two are related.

    1) Is anyone else experiencing this problem?
    2) Is this problem currently known, or being tracked by an open bugID?

    Please advise.

  2. Eru Ithildur

    Eru Ithildur Forum Maven

    No problems here... What have your logs to say?
  3. David5000

    David5000 Pro

    As a longtime Mac user, I am unfamiliar with Hibernation Mode--as far as I know there is only sleep. How are you putting your Mac into hibernation?

    Thank you,

  4. smudge

    smudge Member

    Safe Sleep as it is called by Apple is the default setting for newer MacBook Pro laptops. Might be with just MacBooks but i'm not 100% sure. This is so you can sleep your mac and swap batteries. Previous laptops couldn't do that.

    This isn't a setting the user can change via the GUI but can be done via Terminal.
    sudo pmset -a hibernatemode 0 will switch to normal sleep mode. Adjusting the settings via the Energy Saver to another preset (Normal, Better Energy Savings, Better Performance) will reset it back into Safe Sleep mode.

    golanbenoni: Try switching to normal sleep mode and see if it panics on wake.
  5. golanbenoni

    golanbenoni Bit poster

    This needs to be formally replicated in Parallel's lab, and fixed. I'd be interested in seeing a response from the parallel's folks.

    As an aside, I am not interested in a "light sleep" mode, where power is still being consumed from my battery to keep memory active. I find that it unnecessarily consumes battery cycles, thereby lowering my overall battery life. There is also an issue with the MacbookPro's in that they sometimes will awake inside a bag simply from movement.

    I don't have this problem unless I fully hibernate to disk.
  6. smudge

    smudge Member

    MacBooks also have a feature that will awake the computer as soon as the lid is opened. Since this can cause wakes when you don't want them to, like in a storage bag, here is the command to turn off that feature.

    sudo pmset -a lidwake 0

    Now to wake you computer, the lid has to be opened and you either need to press a key on the keyboard or plug in a USB device.

    To see all the current settings of the Power Management options, type pmset -g (type pmset -g cap to see what options are supported on your specific Mac model).

    Since you are wanting to use the deep sleep to conserve battery power, all this is moot but still useful information.

Share This Page