Parallels + IIS + Samba = Cached .NET Pages, Why?

Discussion in 'Windows Guest OS Discussion' started by lgriffin, Dec 3, 2007.

  1. lgriffin

    lgriffin

    Messages:
    7
    Hi,

    I'm having a rather pressing and urgent problem. I am developing .NET sites on my guest OS ( windows XP with IIS 5.1 ) and i have a Samba share setup on the host OS ( leopard ) that contains the .NET files. I am mapping that samba share through IIS and I'm able to view the files and everything works great except for a couple odd problems, the most important i'll list below:

    - The .aspx pages are sometimes cached and if you save a file then preview it locally you don't see those changes. Restarting IIS seems to fix the problem but it's hardly a productive workflow.

    I've tried disabling the caching options in IIS and in the registry through the DisableMemoryCache DWORD but nothing seems to work. Does anyone have any ideas? Did any of that make sense?
     
    Last edited: Dec 3, 2007
  2. sandro

    sandro Parallels Developers

    Messages:
    512
    hi,
    i guess you having here troubles with non IIS cache but SAMBA caching mech. Try to place your files on local guest OS storage and check whether issue reproduced.
     
  3. lgriffin

    lgriffin

    Messages:
    7
    Samba Cache

    Yes i thought it was the samba cache also, and no the issue doesnt happen locally. How do i change the configuration of the samba cache?

    Thanks for posting by the way! I hope you have a solution!
     
  4. sandro

    sandro Parallels Developers

    Messages:
    512
    Unfortunately i couldn't to give a complete solution because didn't have experience with such issues. On my samba server under FC7 i see in manual to smb.conf for example follow option:

    csc policy (S)
    This stands for client-side caching policy, and specifies how clients capable of offline caching will cache the files in the share.
    The valid values are: manual, documents, programs, disable.

    These values correspond to those used on Windows servers.

    For example, shares containing roaming profiles can have offline caching disabled using csc policy = disable.

    Default: csc policy = manual

    Example: csc policy = programs

    Maybe it's a way to solution...
     

Share This Page