Parallels Keeps Asking for Registration

Discussion in 'Installation and Configuration of Parallels Desktop' started by Tim Hill, Oct 12, 2011.

  1. Tim Hill

    Tim Hill Bit poster

    On the latest build of Parallels 7 for Mac ...

    Why on earth does Parallels KEEP on asking me for registration information? I've entered it AT LEAST a dozen times on my Mac, and it still pops up. When i re-enter the info, it then tells me "You are already registered, registration information updated" Well, if i was already registered, why were you asking?

    This is just plain stupid and frustrating. I just powered on parallels, and it asked me before I started a Windows VM, then asked me AGAIN 5 minutes later when I started creating a new Mac OS X VM.

    Yes, I'm annoyed. I really don't like product registration systems that inconvenience legitimate paying users just so Parallels can make it harder for piracy. Piracy is bad but creating systems that frustrate legitimate users is far worse imho.

  2. jesaf0000

    jesaf0000 Bit poster

    Same thing here. Even if I close the window and choose the option to not register it will pop up again in a day or so.
  3. DBev

    DBev Bit poster

    Same with me. Very annoying.
  4. JSmehil

    JSmehil Bit poster

    Same problem here.. looking for a fix
  5. DobieC

    DobieC Bit poster

    I have the same problem too. Can they just get rid of this crab system!
  6. robertlob

    robertlob Bit poster

    I had the problem a few versions ago... took a call to tech support to get it to stop. Don't remember the solution, however. NOW, I just installed the latest build of Parallels 9 and the same thing is happening again. On two out of three machines I bought licenses for. There is no active "close" button on the window so I can't get rid of it. The minimize button hides it, and the VM opens properly. But it's still a nuisance. OSX Mavrick with Windows 8.1 VM, using the Star8 application to make Win 8.1 work like Win 7. Parallels includes that in part of the installation process. Other attempts on the internet to tweak Win 8 into thinking it's Win 7 simply don't cut it. As it comes out of the box, Win 8 and 8.1 are the most unintuitive, ugly, operating systems I've seen in 30 years, and all by itself Win 8 will help increase Mac OSX sales tremendously if they don't get over it and get back basics.
  7. vothan

    vothan Bit poster

    2011 ???????
  8. Looran@Parallels

    Looran@Parallels Parallels Support

    Hi Everyone,

    This problem also may be caused by proxy being turned on and being used on the host side.

    Please follow the steps outlined below to resolve your issue:

    1. If you have proxy turned on in your Mac - please turn it off at:

    System Preferences -> Network - > Advanced - Proxies;

    And restart your Mac.

    2. Open Applications -> Utilities -> Terminal and run the command below:

    cat /etc/hosts

    3. Examine the output for similar entries (the output may be slightly different):

    4. In case such entries are present in your hosts file, remove them. To do it:
    In Terminal run:

    sudo perl -pi -w -e 's/;' /etc/hosts
    echo “ localhost” | sudo tee –a /etc/hosts”

    5. Register Parallels Desktop and restart the application
  9. rule225

    rule225 Junior Member

    Hi Looran@Parallels,

    I'm getting the very same error: Registration window keeps popping at every launch of the application, even when I fill in the right information.

    I'm not using any proxy and have basic network configuration. Only change is that i upgraded from Snow Leopard 10.6.8 to Mavericks 10.9.3 and I've used the migration assistant to migrate my user data.

    I've opened the ~/Library/Preferences/com.parallels.Parallels Desktop.plist file and discovered the Register.Welcome next show key set at: Mar 13, 2011, 8:03:34 PM

    I've tried removing every preference, application support files and reinstall Parallels Desktop: Nothing works.

    Any help or advice?

  10. nhoklee

    nhoklee Bit poster

    yes, i failed too, can anyone help me :(
  11. SergioA1

    SergioA1 Bit poster

    These posts were quite a long time ago, but how was this resolved? I have waisted an entire trial on this issue and am officially offline with virtual machine! Well I have fired up a VMWare trial to keep me up for another 30 days while this gets resolved.

    I don't use a proxy or firewall and my host file is clean, if I use network utilities to do a traceroot -
    traceroute: unknown host
    traceroute: unknown host
    traceroute to (, 64 hops max, 72 byte packets
    1 ( 1.170 ms 1.514 ms 0.978 ms
    2 * * *
    traceroute: Warning: has multiple addresses; using
    traceroute to (, 64 hops max, 72 byte packets
    1 ( 3.030 ms 1.186 ms 1.332 ms
    2 * * *

    Any help would be appreciated!

Share This Page