Parallels Memory Limit??

Discussion in 'Windows Guest OS Discussion' started by davidcross, Mar 20, 2008.

  1. davidcross

    davidcross

    Messages:
    1
    I'm running an Ubuntu 7.10 host but I cannot get any guest machines installed. I consistently get the error:
    ----
    Parallels Workstation experience problem when trying to allocate physical memory in PAE mode. The current version of Parallels Workstation supports up to 4 GB of physical memory. To fix the problem you have to change the auto detected memory size to 4096MB. Add to your boot loader the following option "mem=4096M".
    ----

    I've tried to add that option in Grub, but haven't had any success. I only have 3.5 GB of RAM in anyway, so it doesn't seem like this should be a problem. Any clues?

    David
     
  2. Hugh Watkins

    Hugh Watkins

    Messages:
    943
    not my world
    but for WinXp on Mac OS small is beautiful

    924 mb from 2gb ram
    32 gb vm

    Hugh W
     
  3. mdlueck

    mdlueck

    Messages:
    76
    We have a system with 4GB of RAM, and we got that same error message.

    I edited the /boot/grub/menu.lst file to add the suggested kernel opt.

    (Note: The line starting with "kernel" ends with "mem=4096M")

    title Ubuntu, kernel 2.6.20-16-generic
    root (hd0,0)
    kernel /vmlinuz-2.6.20-16-generic root=UUID=20383353-5db7-4ba1-b961-7d832fdf03d2 ro quiet splash mem=4096M
    initrd /initrd.img-2.6.20-16-generic
    quiet
    savedefault

    In your case since you have only 3.5GB of RAM, might adjust the number down 512MB, so possibly try mem=3584M
     
  4. mdlueck

    mdlueck

    Messages:
    76

Share This Page