Parallels on multiple users??

Discussion in 'General Questions' started by mdawg0916, May 10, 2007.

  1. mdawg0916

    mdawg0916

    Messages:
    3
    Hello everyone,

    I have a total of two users on my iMac. I installed parallels on user 1 (which has admin rights) and everything works great. When I switched over to the 2 user (which has admin rights) and when I tried launching parallels is prompting me to install windows. I guess I missed something, but is it not possible to use the Win XP VM from user 1???

    *Update: I have an iMac OS X Tiger and running Windows XP on Parallels desktop.

    Thanks in advance.

    mdawg
     
    Last edited: May 10, 2007
  2. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Have you tried putting the Parallels files in a folder that has everyone rights?
     
  3. mdawg0916

    mdawg0916

    Messages:
    3
    Hey Eru Ithildur,

    Thank you very much for the reply. I did the quick install, I think that's the option, and let parallels install everything by default. Since it's installed can I move all files to a folder with everyones rights? Or do I need to reinstall?

    mdawg0916
     
  4. Mike@Parallels

    Mike@Parallels

    Messages:
    112
    Hello,

    This is rather easy. Just perform the following:

    1. Put your VM (.pvs and .hdd files) to some place visible to other users of Mac. I usually place them to Users->Shared.
    2. Change the permissions of the .pvs and .hdd files in the following way: right-click the file, choose "Get Info…". In the window opened expand the "Ownership & Permissions" group and "Details" subgroup. Set the "Read & Write" access to "Others".

    After that you'll be able to use the VM with other users of your Mac.

    Best regards,
    Mike
     
  5. dar969

    dar969

    Messages:
    1
    Similar problem.. not working at all

    Help, new to Mac
    Mac OS X 10.4.9, 1.8Ghz Intel Core Duo, 2 GB ram
    Installed WinXP SP2 thru recommended installation. Works fine on my desktop.
    WHen i try to run with my other family members desktops.. it wants me to install from scratch.
    I "duplicated" all the files in the me/documents/parallels folder including the
    Microsoft Windows XP.pvs
    WinXP.hdd
    Unattended.fdd
    Windows Applications (folder)

    and put the copies in a folder in the users/shared folder.
    I follow the instructions in the response above and on page 172/3 o fhte user manuel.

    No luck. When I try to open Parallels thru another desktop/user I first get this error:
    "Unable to lock out the config...file /users/shared/...../Microsoft XP.pvs"

    then after clicking on ok.. i get the following message:
    "floppy image file / ......Windows XP/unattended.fdd could not be found"

    yet its right there, in the same folder...
    am I doing something very wrong?
    this is frustrating..
    thanks for any help
     
  6. Intersecting

    Intersecting Parallels Team

    Messages:
    19
    2 dar969
    Click on the devices -> floppy -> connect image connect it to the "Unattended.fdd in the folder in the users/shared folder". ;)
    Best regards.
     
    Last edited: Jun 7, 2007
  7. Dave Marsh

    Dave Marsh

    Messages:
    2
    Hi, my question seems to be identical to the initial user above, but your reasonable reply doesn't seem to work.

    I've just upgraded to Parallels Desktop 3.0 build 4128. I setup my Win XP volume in my Admin account just to test it out. Everything works fine there. However, it is my intention to place a copy of this tested configuration/HD in the Shared folder for the individual user accounts on the laptop to use as needed. I don't want to MOVE the working volume into the shared folder, so I will have a way to replace the users Win XP volume when they damage it eventually (which I expect they will).

    I created the following folder for the common Parallels Desktop environment:

    /Users/Shared/Parallels/Windows XP/

    and copied the following files from my Admin account into it:

    Microsoft Windows XP.pvs
    unattended.fdd
    Windows Applications (Folder)
    winxp.hdd

    I changed all the permissions in this shared folder to:

    Owner: system (Read & Write)
    Group: wheel (Read & Write)
    Others: Read & Write

    I've tried various permissions and owners options, with no success. I opened the pvs file in Text Edit to check on any paths in there, and found only one for the fdd, so I changed it to this shared folder location.

    When I attempt to open this new Shared folder Parallels environment by double clicking on the pvs file while logged into my Admin account, it opens up the duplicated winxp.hdd volume just fine, so I know the copied volume was not damaged when it was copied.

    When I log out of the Admin account, log into the Guest account (with either admin or standard permissions enabled for this user), go to the /Users/Shared/Parallels/Microsoft Windows XP/Microsoft Windows XP.pvs file, and double click on it, Parallels starts up.

    However, it immediately displays the following error message:

    "Virtual machine cannot be started because of the following problem:
    Parallels Desktop is unable to access the virtual hard disk image file
    /Users/Shared/Parallels/Microsoft Windows XP/winxp.hdd. The file is missing, corrupted, or used by another application. OK"

    If I click on the Hard Disk 1 configuration setting, it shows the correct path to the volume. If I Remove the Hard Disk 1 image file from the configuration, and select Add to add it back to the configuration, it applies the update correctly, so it's accepting the winxp.hdd as a real image file.

    Trying to startup with the pvs file again, returns the same error. Logging out, back into the Admin account, and double clicking on the Shared pvs file, starts up Windows XP just fine.

    I considered that something might be amiss with the Guest account, so I created a third Temp account, logged into it, double clicked on the Shared pvs file, and received the same error message as for the Guest account.

    This is clearly a permissions error of some sort, but the permissions seem to be set correctly (i.e., ALL set to Read & Write).

    I'm trying this on a MacBook Pro (first generation Core 2 Duo) with 2GB RAM, running MacOS X 10.4.9. Everything is up to date and clean on this laptop (i.e., Disk Utility, Disk Warrior find nothing wrong with it).

    So, any other ideas? The only thing that should be different here between the accounts is that the installation occurred in the Admin account. Are there any other files in the Admin account's Library that I need to copy over to the Guest user's Library? I've even tried copying the Admin account's ~/Library/Preferences/com.parallels.Parallels.plist file over, with no benefit.
     
  8. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Hmm... It sounds like you are locked out of, or are unable to lock out, the .hdd file. Did you try a re-boot? Sometimes that will clean things up.
     
  9. Dave Marsh

    Dave Marsh

    Messages:
    2
    Thanks for the quick reply. I tried both a Restart and a Shut Down and Restart, but neither helped. I still get the same error when double clicking on the pvs file in the Shared folder to start up Parallels in the Guest account.
     

Share This Page