Parallels opens up VM to do text file edit.

Discussion in 'Linux Guest OS Discussion' started by SteveM22, Sep 3, 2019.

  1. SteveM22

    SteveM22 Bit Poster

    Messages:
    1
    I'm running Parallels 15 under macOS Mojave with three linux VMs (Ubuntu 16 and 18, and CentOS 7). When I try to edit a text file using emacs (which exists on my macOS machine), Parallels insists on opening a new VM to use emacs there. This was not the behavior prior to upgrading last week, and definitely not what I want. I am not using coherence. How do I permanently prevent this undesired behavior?
     
  2. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    103
    Un-check "Share Linux application with Mac" in VM's config.

    Screen Shot 2019-09-05 at 12.02.27 PM.png
     
  3. wingdo

    wingdo Kilo Poster

    Messages:
    320
    Go to a text document you want to open, right click, go to "open with", click on "other" (at the bottom of the panel), and be sure to pick the actual Mac version of emacs. That should resolve the issue. If it doesn't you would be forced to disable app sharing as tech support suggests as somehow their contextual menu is overriding the Mac default.
     

Share This Page