Parallels staff: Please comment on Garmin compatibility

Discussion in 'Parallels Desktop for Mac' started by firestarter, Sep 18, 2006.

  1. bdodds

    bdodds Bit Poster

    My Nuvi 360 worked until I updated it to the 3.6 software... :mad:

    EDIT: It's now 7-31-07 and I still can not use the Nuvi 360 in Parallels. I have changed over to VMWare and all is well. Parallels Support staff never once even responded to any of my many requests for help.
    Last edited: Jul 31, 2007
  2. w5pcw


    I loaded MapSource City Select North America v7 a few days ago with virtually no problems. I have successfully downloaded waypoints and tracks and saved the documents for both my Garmin eTrex Summit and GPS V. I have not yet uploaded maps or waypoints but expect to do so soon. Also, I have not yet done live GPS tracking. Soon I expect to load the software for my wife's C320 and give it a test run.

    I am using a MacBook with 1 GB of RAM, Parallels Desktop Build 3188 and Windows XP Home. I bought the boxed version a few weeks ago and quickly upgraded to 3188 with no problems other than my own lack of knowledge. I use a KeySpan USA-19HS USB Serial Adapter. It worked the first time for both GPS receivers. The only nuisance I experience is occasionally having to unplug and reinsert the USB connector.

    I do admit to reading a lot of threads on subjects like GPS and USB. I also admit to a lot of false starts that forced me to read more and experiment until I got it right. I am a new user of Parallels so have had to climb up the learning curve quickly. I bought Parallels specifically to use mapping software that is readily available for Windows. I successfully loaded Microsoft Streets & Trips and use it regularly.

    The bottom line is that Parallels works for me and so far has met my expectations. It allowed me to return to the Mac platform after six years and bring some Windows applications with me. (My first Mac was a 512k and I still have Version 1.05 of Excel.)
  3. MrMacHead

    MrMacHead Bit Poster

    My nuvi 350 works perfectly with Parallels 3188/XP VM, as does MapSource. I have done nuvi software updates and uploaded waypoints created in MapSource.
  4. Cass


    Etrex Legend C (USB)

    Build 3188 seems to work, well to a certain degree, i have managed to get parallels to see the device, download waypoints to mapsource and run the updater, which confirmed i was running latest version of the software .. XP blue screens on me when adding maps to Etrex Legend C (USB) from metroguide v6 ... im currently looking into v7 to see if there is any change ... but for now im beginning to see the light of day, i had almost given up hope ... Nice work Parallels, your getting there :)

Share This Page