parallels switches the keyboard language !

Discussion in 'General Questions' started by ParallelsU109, Apr 25, 2018.

  1. ParallelsU109

    ParallelsU109 Bit Poster

    Messages:
    4
    I'm French and use the French keyboard layout on my Mac. I occasionally use the American keyboard, so I've it in the keyboard layout menu (not sure of the english name, it's the one on the right next to the date with the little flags)
    Sometimes, when I am in "coherence" and I click on a window from a Windows 10 program, to switch to Windows, the keyboard layout automatically switches to American.
    First , I thought that I was using a wrong shortcut inadvertently (I do not alway notice straight away the change of keyboard, especially as most keys are in the same place), but the keyboard shortcut for changing language was off. Then I saw it from the corner of my eye : when I clicked on a window , the little flag changed from the French to the Amercan one. This is very inconvenient. I use Parallels to be able to switch from Mac to Windows, and I have to look at the little flag to know if I've switched to American each time I go back to Windows.
    It seems that happens since I use Windows 10, though I'm not 100% sure. Windows is installed in French as is Mac OS . (high sierra)
     
    Last edited: Apr 25, 2018
  2. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,361
  3. ParallelsU109

    ParallelsU109 Bit Poster

    Messages:
    4
    nope. automatic answers from keyword in my message do not work. how surprising.
     
  4. ParallelsU109

    ParallelsU109 Bit Poster

    Messages:
    4
    ok no answer anyone? the keyboard switches to american and this is a real problem because the american keyboard has the letter "Q" where the French keyboard has the letter "A'"; and with many shortcuts, "command + A" means select all and "command +Q "means quit.
     
  5. KevinM25

    KevinM25 Bit Poster

    Messages:
    1
    Interesting that Parallels has no answer for this. I am experiencing this with Ukrainian now. I have English (US), Ukrainian, and Russian installed on my Mac, and also in Regions/Settings in Windows 10. If I select English or Russian on the Mac, the Windows keyboard in the VM changes properly. If I change to Ukrainian on the Mac, and then click on an app in the Windows 10 VM, it changes both the VM and the Mac back to English or Russian - whichever was the last I had set. Yet if I change Windows to Ukrainian, it changes the Mac too.

    This auto-switch to English is annoying. Anyone find a solution? (And yes, I want the VM to always follow the Mac).
     
  6. OivindA

    OivindA Bit Poster

    Messages:
    1
    Same problem here. Switches to Norwegian keyboard layout whenever I swap from mac to windows. I need the english layout to get certain characters for coding ("<" and ">", kinda crucial) that are missing from the norwegian keyboard layout as I have an english mac keyboard.
    Please respond with a solution soon!
     
  7. JackD6

    JackD6 Bit Poster

    Messages:
    1
    I experienced the same problem on my Mac. I am using OSX Mojave 10.14.5, and I installed a Windows 7 VM. My keyboard was switching from Qwerty British to Dvorak. This bug is really annoying, but I can (I think) safely say that I have found the solution!

    1) Go to Control Panel
    2) Search for 'Language'
    3) Click on "Region and Language"
    4) Select the tab "Keyboards and Languages"
    5) Click on the button "Change keyboards..."
    6) Select the tab "Advanced Key Settings"
    7) Click on the button "Change Key Sequence..."
    8) Set "Switch Input Language" to "Not Assigned"
    9) Set "Switch Keyboard Language" to "Not Assigned"

    And now you should have no more problems! I hope this helps!

    (PS changing the keyboard in the Windows VM changes it on my native OS as well which is why the problem exists/why this works as a fix)
     

Share This Page