Parallels Tools 4.0 install fails: Cannot install Shared Folders Driver

Discussion in 'Installation and Configuration of Parallels Desktop' started by ddolezal, Nov 24, 2008.

  1. bi11

    bi11 Hunter

    Paragon should have no effect on shared folder access support in Parallels.
  2. Elric

    Elric Parallels Team

    Those who have not ever succeeded with installing Parallels Tools and stopped with error "Failed to Install Shared Folders", or those who recieves an error about failed to uninstall Shared folders driver and after that nevermore succeed with installing Parallels Tools:

    Please register at and create a support ticket. Then post me via private message the number of ticket. Please specify in the ticket do you have problem with never installed Tools or with failure to reinstall tools due to Shared Folders.

    Or if you have an existing ticket with this problem, please post me its number.
  3. alexr

    alexr Bit poster

    Maybe this will help. I am getting "Failed to remove root enumerator device necessary fir Parallels paravirtualization driver" message while the setup is rolling back.
  4. jknight

    jknight Bit poster

    I have been waiting for weeks and have not been helped. I am extremely dissapointed with Parallels Support. At this point I do not think it is wise to upgrade from 3.0 to 4.0.
  5. Elric

    Elric Parallels Team

    It's strange. Have you received my last two private messages I've sent you?

    1) Elric,
    I have not received a message from you with a fix. How do I make a ticket? I am quite frustrated because I have been without XP for several days now.
    Thank you,

    Hm.. you should receive a message from the parallels support system with invitation to register at the support system. Then after regestering you should be able to see the ticket in the support system.

    For me works logging in at with registered e-mail address and password.

    Just in case I've sent a test message

    2) I belive that it is not a prerequisite, may be you should register at
    Last edited: Dec 15, 2008
  6. jknight

    jknight Bit poster

    I was told by tech support via e-mail that they were passing my case along to a level 2 engineer. I was never contacted.
    Last edited by a moderator: Dec 20, 2008
  7. Elric

    Elric Parallels Team

    jknight, there is a ticket to you 629136 (opened at Nov 29)..
    I believe that since you have not received the solution sent in this ticket, you should register at support system and create a new ticket. Then please post me a number of ticket and we will immediately resend the solution..
  8. hnair

    hnair Bit poster

    I updated Parallels 3.0 to to 4.0, and I am stuck like others with the parallels Tools installation. At the end of the installation process, I get an error message that says:

    "Failed to install Parallels Shared Folders driver" error message.

    On OK, I get an "Failed to uninstall Parallels Shared Folders driver" - followed by a "Rolling back installation" and a restart of the system.

    Then, the next message says "Failed to remove root enumerator device necessary fir Parallels paravirtualization driver".

    Looking at this forum, it seems several people have this problem, but no solution is posted.

    *NOTHING* can be done on the machine as no mac folders can be accessed, nor, the internet or any network visible.

    Please help ASAP.

    Harikesh Nair.
  9. Elric

    Elric Parallels Team

    Thanks for the report, I have read the private message and we have sent the possible solution, please check the ticket.
  10. Mamel

    Mamel Bit poster

    Same problem here...

    i have the same problem here...
    Ticket ID: #647013

  11. John@Parallels

    John@Parallels Forum Maven

    Thank you, we will reply as soon as possible
  12. bi11

    bi11 Hunter

    Why does everyone having the problem with shared folders have to create a ticket and get a private solution? Wouldn;t it be better to post the solution here?
  13. Elric

    Elric Parallels Team

    There may be several troubles that prevents installation of Parallels Tools

    1) Missing registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce" (which leads that some drivers may not install) (check for this is done in upcoming updated)

    2) Missing or incorrect value "DevicePath" in key "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion" (which leads that _no_ any driver may be installed) (check for this is done in upcoming updated)

    3) Trouble with permissions or just disabled "Plug And Play" service, which leads that DeviceManager is absolutely empty and doesn't show anything). This may also occur due to virus on PD30 machine. This issue should be fixed by hands after contacting with support.

    4) Trouble with corrupted drivers cache (this is frequent reason and we are considering to publish knowledge base article for this issue). This one could be resolved with having at hand copy of driver for "Parallels Shared Folder" and installing it manually, or by cleaning up Windows Inf-files cache. Sorry, I'm afraid to give this solution for now. It is absolutely safe, but relatively time consuming - about 5-10 minutes to recache inf-files

    The solution is just too complicated...
    Last edited: Jan 2, 2009
  14. fbaldeva

    fbaldeva Junior Member


    I am having the same "Failed to install Parallels Shared Folders Drive." I am running Parallels 4 build 4.0.3810.
    My ticket number is 657516.


  15. Padde

    Padde Bit poster

    Hi all readers of this forum,
    Just do as Elric asks you, create the ticketnr and send him an email. They helped me within 15 minutes. Worked perfectly. Thanks guys!
  16. talsop

    talsop Bit poster

    ticket 674200

    Same issue. Parallels Tools won't complete its install. It gets to the Shared Folders Driver and errors out. Then it backs up the install and reboots. Everything else works fine but I can't use Coherence mode.
  17. Ben Chong

    Ben Chong Bit poster

    My turn

    Ticket: [Parallels #676065]

    Second time I'm having trouble with 4.0

    First time was the upgrade from 3.0

  18. rffegley

    rffegley Bit poster

    Parallels Tools fails to complete Upgrading version 3 to 4

    I upgraded a windows XP bootcamp VM from Parallels 3 to ver 4. When I tried to install Parallels Tools it ran through to near the end and then hung. I had to crash out. Now I can only run Windows from Bootcamp.
  19. galochka

    galochka Hunter

    Have you met any error messages during upgrade or you created new Virtual machine based on Bootcamp?

    In case you upgraded VM which is based on Boot Camp from PD3 to PD4, please try to create new VM

    Start Parallels Desktop -> File -> New -> Custom ->and on the step "Hard Disk Options" select Boot Camp

    After that please try to install it once again.

    In case it failes once again -> Virtual machine -> Start -> Control Panel -> System-> Hardware -> Device Manger -> and check the devices with yellow triangles -> try to update driver (right click )
  20. don rauch

    don rauch Bit poster

    I have the same problem! Please help!

    Has there been a solution to this problem yet? If so where would I find it?

Share This Page