Parallels tools in RC3 3170 won't install

Discussion in 'Parallels Desktop for Mac' started by MSUDVM, Feb 15, 2007.


    MSUDVM Member

    I upgraded my VM 3150 to 3170. Prior to the upgrade, I uninstalled my Parallels tools from 3150, installed 3170, and then tried to install Parallels tools in the new version, Nothing happens. I restarted my VM in safemode and again, nothing happens. So far this is the first version that I am unable to install the tools. Any thoughts?
  2. RCF2616

    RCF2616 Member

    Same thing...

    20" IMac (late 2006) 2 GB, WinXP, SP2

    I've sent this to, but am bring it up here in the event that someone else may be having the same problems.

    I installed 3170, and Windows started apparently normally. I did not see a message telling me to update Tools, though, which I thought was strange.

    Remembering my experience with v. 3150 and previous, I went to install Tools with Windows in Safe mode after having gone through removing the previous Tools install with Control panel. Restarted Parallels as instructed. Windows XP started, progressed to the point where the black screen normally shows up momentarily, but instead of the black screen, I got the BSOD saying that Windows XP experienced a problem, which stayed about 1 second and then Windows automatically restarted again, unsuccessfully.

    I then started Windows in Safe mode successfully. Thinking that it was the Tools install causing the problem, I tried to remove Tools using the Control panel. The uninstall started, but the a dialog informed me that I must complete the previous install by restarting the VM. I did so, and restarted in safe mode and tried to finish the operation with the same result. I looked at the Windows Parallels folder and the files were still there and were apparently the new Tools, with files dated 02-15-2007.

    I Deleted the 3170 files and re-installed the 3150 version. I went to remove the Tools with XP in Safe mode and got the same results as above. I can still start successfully in Safe mode with or without network option, but still with the safe mode cripple.

    I had installed the Bootcamp drivers in version 3150 to get the ISight functionality; could this have anything to do with the problem?

    Where do I go from here?:confused:

    By the way, friends, if you included your configuration (Mac model, Processor, memory, BootCamp or Not-BootCamp, Mac OS, and Windows OS) with your trouble report, it would help the folks at Parallels duplicate and resolve the issue more easily. I've noticed several varieties of Mac machines mentioned; each may have it's own unique behavior with Parallels due to the differences in configuration.
  3. CountZero

    CountZero Member

    I have no problem upgrading from 3150 to 3170. Parallels Tools installs just fine, without even needing to do the Safe Mode thing. But then, my VM is not Boot Camp so that may have something to do with my lack of problem.
  4. Lev

    Lev Bit poster

    I have never uninstalled a previous version of Tools, and haven't run into problems yet. For 3170, as soon as WinXP loaded up, i got a message about upgrading tools, and it ran normally.I, too, do not have a bootcamp partition (another story). For the record, MBP 2.16GHz Duo, 2 Gb ram, 20 Gig windows.
  5. RCF2616

    RCF2616 Member

    Parallels 3170 Tools Problem

    Apparently it's something with my machine setup then, because this is the first time I've had a problem with the Parallel betas.

    I'm not running Bootcamp, but I am using the Bootcamp drivers for XP as was recommended in previous threads to get the Apple ISight camera working in 3150; that is the only thing different about my setup from previous beta configurations. Perhaps the Bootcamp drivers are interfering with the Parallel tools with the new 3170 version??

  6. darkone

    darkone Forum Maven

    try mounting the ISO file that parallels uses to install tools, manually as your CD device. The ISO can be found in /Library/Parallels/Tools and is called vmtools.iso

    MSUDVM Member

    Thanks for the reply. Sorry for the ignorance, but how do I "mount the ISO image"?

    Also, does anyone know where I could go in my Windows registry to remove leftovers from the Parallels Tools uninstall? After I could not load tools in 3170, I went back to 3150 and now I can't load the tools there either (time piece runs for a few seconds and then nothing happens). It seems that the uninstall of the 3150 tools may have messed something up on the windows side since I am unable to install tools now after removing 3170 and reinstalling 3150! Thanks everyone for your thoughtful help!

  8. petro

    petro Member

    I've been having a BSOD whenever I try and install Parallels Tools in one of my WinXP virtual machines. I've setup a second WinXP VM, and successfully installed Parallels Tools in it, but installing it in my old one with tons of apps and history blue screens every time.

    Installing Parallels Tools works under release 1970 just fine. Every time I move back to that release after trying newer betas, it still works fine.

    I've tried removing Parallels Tools from XP, rebooting, and going to the Actions menu and installing Parallels Tools.

    I've tried mounting the ISO image. The moment I do, BSOD.

    I'm still digging through the forums (i've been doing so this entire beta cycle) and haven't found the magic answer. Any suggestions of what else can be tried would be appreciated!
  9. petro

    petro Member

    Ah hah! I finally figured out a way to do this. In MacOS, mount the Parallels Tools ISO that's in /Library/Parallels/Tools of your MacOS hard drive.

    Copy those files to a new folder on your mac.

    Copy that new folder to the Windows XP virtual machine. To do this step, I had to setup Windows sharing in my MacOS sharing preference pane. I then connected to the Windows shared folder from my WinXP virtual machine.

    Run the installer file PrlTools.exe in that directory from inside your WinXP virtual machine. Voila! Finally I have Parallels Tools, and everything appears to work fine!
  10. RCF2616

    RCF2616 Member


    Apparently the Parallels tools program glitched the first time I tried to install it, and was not able to get past a certain point

    I tried the .iso trick suggested above. I opened windows up in Safe mode, loaded // Tools from the image, got the 'must restart the VM' message again; reset/restarted the VM and XP started normally. Not sure what really happened, but it's working fine now, so far, and who am I to quibble about success.:) :)
  11. luca

    luca Member

    BootCamp is Corrupted after installing 3170 Parallels tools

    I upgraded Parallels tools 3/70 in a regular VM without any problem.

    On the other hand, upgrading Parallels tools 3170 for the BootCamp partition did not work well. The machine was stalled and doing nothing after a long time (1 hr). So I had to stop it and now it says the partition is corrupted. Windows will not start.

    I have a message to restart with original Windows Install Disk and type 'r' to repair.
    After doing this, I just get a DOS prompt and I did't know what to do.

    So I restored my BootCamp partition (using the fantastic Mac OS X NetRestore) and tried again with same result. I restored again and tried with 3150 and it is working normallly. Everything is fine.

    It looks to me something is broken in build 3170 regarding BootCamp.
  12. sidssp

    sidssp Hunter

    I am running WinXP VM with Boot Camp and the 3170 upgrade works the same as you described. Parallels tools upgrade was automatic. No problem at all. From what I have read so far, it seems most of the users who have problem have uninstalled Parallels tools first. So don't do it. Just let the upgrade does its job for you.

Share This Page