Parallels Tools installation problem on Ubuntu 15.04

Discussion in 'Linux Guest OS Discussion' started by ToddL1, Mar 31, 2015.

  1. MacO

    MacO Bit Poster

    Messages:
    2
    Just created a problem report ID 7058-3774. Anyone reading this from the Parallels support team?
     
  2. trifer0

    trifer0 Bit Poster

    Messages:
    2
    This sucks. So many efforts on Windows tools... and this disappointment on Ubuntu. Really a wrong politic.
     
    D.R1, MacO and GarethD like this.
  3. GarethD

    GarethD

    Messages:
    1
    +1 - this sucks. Is this going to be fixed anytime soon? Can we have an ETA?
     
    MacO likes this.
  4. KarlBre

    KarlBre Bit Poster

    Messages:
    1
    After installing Parallels Desktop 11 and updating the Parallels Tools on Ubuntu Linux 15.04 it's completely destroyed. Only gray desktop. Crashes with audio driver. Uninstall and fresh install of Parallels Tools doesn't help. Is there any testing at Parallels before launching? I don't think so. I have uninstalled now Parallels 11 and go back to Version 10. Thank you Parallels for wasting time!
     
    D.R1 likes this.
  5. D.R1

    D.R1 Bit Poster

    Messages:
    1
    Not the exact same issue as you KarlBre but close enough... Can't get Parallels Tolls to update after updating to 11. 15.04 was running perfectly on 10 with zero issues. You'd think they'd have tested 11 to make sure it still worked. Who releases an "update", charges $50 for it, and causes you to LOSE functionality?!? Shameful

    So... I figured out a way to fix it. You manually uninstall tools, then manually install them again. I'll post detailed steps in the am. Still shouldn't have had to dig through Ubuntu bug logs to find out how to install something as essential as Parallels tools. It should be able to do something like this automatically. If this were open source freeware, I wouldn't complain so much an expect to have to do some digging. That's half the fum of it, but when I pay money for a program - especially what Parallels costs for every major update - I EXPECT a level of polish and automaticity.
     
    Last edited: Aug 31, 2015
    RobbS and FrancisA1 like this.
  6. FredUntu

    FredUntu Bit Poster

    Messages:
    26
    Hi D.R1,

    Same conclusion as yours.
    I'm running PD11 (Trial fror now) with Debian 8.1 (which has now been released for quite some months and is about the mostly used Linux Distro if you consider that Ubuntu and Linux Mint are basically Debian based distros...).
    Parallels tools won't install : no copy-paste ; no drag-n-drop between environments...
    And Parallels as usual says PD10 won't be compatible with OsX El Capitan (or plays on words to let you believe it won't be), but it most probably will be !
    Oh... and as usual : no reply from Parallels or whatsoever.

    Ah... one more thing ! There's a really simple solution to this problem. It's called VMWare Fusion (same price) or even better, VirtualBox (which is free). Tried both and guess what ? Both works like a charm with Debian 8.
     
    Last edited: Sep 6, 2015
    RobbS likes this.
  7. FredUntu

    FredUntu Bit Poster

    Messages:
    26
    Hi Guys,

    Replying to myself... because maybe I found a solution.
    Here's what I did.
    Maybe you can try it too.
    Not sure it will work, because I run Debian 8.1 "Pure" (so not a Distro based on Debian, like Linux Mint or Ubuntu...).

    First thing is to make sure some required packages are installed : dkms, make, gcc and linux-headers. To install those (in case they aren't already) just run :
    sudo apt-get install dkms gcc make linux-headers-$(uname -r)

    Once it's done, mount the Parallels Tools CD... guess by now you all know how to do that.
    When the CD mounts, create a folder on your desktop (name it whatever you want).
    Open the CD window, select everything that's in it and copy it to the folder you created.

    Once you copied everything, open a Terminal, and go to the directory you just created. In terminal that would be :
    cd [drag the directory... path should copy automatically]

    Once in the directory, in the Terminal window enter :
    sudo su chmod -R 777 *
    [This allows you to enable read/write permissions on every file/folder in the folder you created and applies to subfolders. PLEASE NOTE : this might ask you to enter your password]

    Once done, type :
    sudo ./install
    [If that does not work, try this :
    - su
    ./install]

    Please note : during install, the installer reported I should install some additional packages : one was printer-driver-postscript-hp and the other was ???? Maybe related to my machine... If so, just note the name of the packages required, abort the install process and just enter :
    sudo apt-get install [name of the required package]. You should then be good to go !!!!

    This worked for me... hope it works for you :)

    All I can say is that now Parallels seems to work more than decently. I'm building my own ROM for my smartphone and PD uses about 100% of CPU resources, which allows me to build at maximum speed... Cool.

    Regards.
     
  8. OrenS

    OrenS Bit Poster

    Messages:
    1
    After many searches, installations, uninstallations, reinstallations, manual editing of bash scripts, updates etc. I managed to find the perfect solution to this problem:
    1. uninstall Parallels (This step is very important)
    2. Install Oracle VirtualBox (didn't check with VMWare but I guess it will work just as well)
    3. Install guest Ubuntu 15.10 with VirtualBox guest editions
    And that's it!
    Thank you, Parallels support team, for ignoring the problem and not wasting my time with 'solutions'. It made my path even clearer!
     
  9. FredUntu

    FredUntu Bit Poster

    Messages:
    26
    Hi OrenS,

    Doing that you're standing in the middle of nowhere...
    So I can give on an even better advice :)

    1. uninstall Parallels (This step is not mandatory, but will save some space)
    2. open "Disk utility" and create a new partition that you can format as "Free Space"
    3. download Ubuntu, Linux Mint, Debian... whatever you want
    4. create a bootalbe image using "UNetBootin"
    5. download rEFInd and run it
    6. reboot and choose to reboot from the bootable USB you created
    7. Install Linux on the "Free space" partition you created on step 2.

    You now have a dual bootin machine and no more problems :)

    Just to tell it : this is what I did. I installed Ubuntu MATE 15.10 with no problems.
    So I now have a dual booting MacPro... but that useless !
    Once you get used to Linux you don't want to go back to MAC.
    I thought my MacPro was smooth...
    Spent 10 days on Linux, booted back to Mac for some obscure reason...
    I cried all tears my body held when I saw how slow and unreactive the MacOS interface is compared to Linux !
    Let alone the almost endless customizations that Linux allows to have on your computer... compared to the TOTALLY closed MacOS which has done everything it could to even forbid the last space of liberty that existed by installing that stupid security check !

    So goes MacOS... I now have a MacOS free MacPro.
    And in the next few months, probably an Apple free computer :)

    Regards.

    FRED
     
    RuiG and OrenS like this.

Share This Page