Parallels Tools version 17.0.0 for Fedora 34

Discussion in 'Linux Guest OS Discussion' started by ThomasO11, Aug 13, 2021.

  1. ThomasO11

    ThomasO11 Bit Poster

    Messages:
    3
    Hello everybody,
    I updated to Parallels Desktop Version 17.0.0 (51461) and have successfully updated Parallels Tools on Windows 10, MacOS 10.13.6, and Ubuntu 21.04. However, when I try to update Fedora 34 to the new version of Parallels Tools, I always get an error immediately after I enter my Password for Sudo access in the Parallels Tools Installation GUI. In /var/log/parallels.log, it says that it is trying to use parallels tools version 16.5.0-49183 and I get output like

    W /PTIAgent:28496:6f50/ [PTIA_GUEST] Tools state = 1 (oldNotation = 0)
    W /PTIAgent:28496:70b9/ [PTIA_GUEST] Start installation (silent = 0 local = 0 onlyDownload = 0)

    W /PTIAgent:28496:70b9/ [PTIA_GUEST] Start child process: cmd /usr/bin/ptiagent-cmd args --install --reboot --nosingle
    W /PTIAgentCmd:29317:7285/ [PTIA_GUEST] Tools state = 1 (oldNotation = 0)
    W /PTIAgentCmd:29317:72b9/ [PTIA_GUEST] Start installation (silent = 0 local = 0 onlyDownload = 0)
    F /PTIAgentCmd:29317:72b9/ [PTIA_GUEST] Unable to download installation package: otgOpen failed
    F /PTIAgentCmd:29317:72b9/ Command failed : umount "/home/myuserdir/". ExitCode=32 ErrorCode=5
    W /PTIAgentCmd:29317:72b9/ [PTIA_GUEST] Failed to unmount image with tools installer.
    W /PTIAgentCmd:29317:72b9/ [PTIA_GUEST] Installation result = 2
    F /PTIAgent:28496:70b9/ sudo exit status code 512
    F /PTIAgent:28496:70b9/ sudo terminated with 2 status:
    F /PTIAgent:28496:70b9/ PRL_SUDO_PROMPT
    F /PTIAgent:28496:70b9/ ptiagent-cmd progress 10
    F /PTIAgent:28496:70b9/
    W /PTIAgent:28496:70b9/ [PTIA_GUEST] Tools installation failed
    W /PTIAgent:28496:70b9/ [PTIA_GUEST] Installation result = 4


    I can post the entire parallels.log file from my next restart of Fedora Linux if needed. If anyone can offer any guidance on how to install parallels tools version 17.0.0-51461 that doesn't involve "Reinstall Parallels Tools" from the parallels "Action" menu I'd appreciate it. Or is it possible to uninstall parallel tools so that I might install a fresh copy of parallels tools on my Fedora VM?
    Thanks in Advance,
    Tom
     
  2. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    1. su to root: su
    2. mount the tools cd: mount /dev/cdrom /mnt
    3. cd to the mount point: cd /mnt
    4. then type: ./install
    5. follow the prompts to remove existing tools, then reboot.
    6. after logging back in, loop back to step 1, but instead of removing existing tools in step 5, install them, then reboot again.
     
  3. ThomasO11

    ThomasO11 Bit Poster

    Messages:
    3
    Thanks for your reply Mike. Here are the results of the second step (mount the tools cd: mount /dev/cdrom /mnt)
    [root@fedora username]# mount /dev/cdrom /mnt
    mount: /mnt: special device /dev/cdrom does not exist.
    [root@fedora username]# mount /dev/sr0 /mnt
    mount: /mnt: no medium found on /dev/sr0.
    I even tried the command suggested by Parallels Knowledge Base.
    [root@fedora media]# mount -o exec /dev/sr0 /media/cdrom
    mount: /media/cdrom: no medium found on /dev/sr0.
    Plus I tried all the steps mentioned on the aforementioned page and get the same result when I try to mount the tools cd.
    So, if you have any more ideas on what I might try, I'd appreciate it.
    Thanks again,
    Tom



     
  4. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    Sounds like the CD isn't configured properly. Sounds like you may have had it set to "Disabled".

    In the Parallels Control Center, right click on your Fedora 34 and choose "Configure...". Then in the Configuration box under the Hardware tab, select "CD/DVD". Make sure "Source" is set to "prl-tools-lin.iso".

    Alternatively you can select the CD icon in a running Linux VM window and select "prl-tools-lin.iso" to make sure the CD is configured properly.
     
  5. ThomasO11

    ThomasO11 Bit Poster

    Messages:
    3
    Thanks again Mark (I apologize for calling you 'Mike' in my second post). That appears to be a problem that I had. I now have Parallels Tools version 17.0.0-51461 installed. However, now I have the problem described by ReynierP in the [patch] Support for kernel 5.13 (Parallels Tools 16.5.1.49187) thread where 'VM becomes unusable meaning it never starts just stay forever on a black screen.' The VM does boot, but I get the following message when I add the "systemd.unit=rescue.target" to the kernel at boot as suggested by @(GalaxyMaster) on Thursday (08/12/2021) I get the following output:

    Cannot open access to console, the root account is locked.
    See sulogin(8) man page for more details.
    Therefore, I can't follow the rest of the suggestion in @(GalaxyMaster)'s post. Any ideas on how to fix the root account?
    Thanks again,
    Tom
     
  6. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    Unfortunately, I may not be a lot of help, since I've not seen this.

    that said, I would think the black screen is likely an issue with the xserver, which starts very early in the boot cycle. I'm going to guess that the xserver thinks it should be using the wayland driver, which Parallels has a problem with. Unless there's a way to force it not to use wayland at boot time via a boot flag it sounds like there might be a chicken/egg situation here.

    Other than that, can try looking at the settings. I have:
    CPUs: 2, 12288 MB memory, no extended memory limit, Apple adaptive hypervisor.
    Graphics: 64MB, more space, 3D acceleration on.

    Not sure much of anything else might affect boot up other than boot flags, and I don't use any.
     
  7. HartmutR1

    HartmutR1

    Messages:
    1
    meine Maus funktioniert nicht mehr in Windows 10 nach upgrade auf PD 17
     
  8. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    362
    Das ist Linux-Gruppe, nicht Windows-Gruppe.

    That said, I am occasionally seeing something weird with the mouse in Linux. When using the terminal, sometimes the mouse becomes engaged by itself and moving it acts as if you've left-clicked and held it down, even though that was never the case. Other times the cursor disappears completely. The only way to fix either (without killing the VM) is to do a three-finger gesture to jump to another Mac desktop, then rejoin the Linux VM.

    This could in fact be a Gnome problem, but there are other indications during boot and shutdown that the process halts until it sees any mouse movement. This would seem to indicate something else going on in either the kernel or within Parallels Tools. I've only seen this happen with the mouse as yet, and have not tested with any other USB 2.0 device, be it internal or external. That is, other than the keyboard, which uses the same USB port as the trackpad. The keyboard seems to be ok but haven't really put it under stress (holding down keys, etc).
     
  9. Angelo C

    Angelo C

    Messages:
    1
    I was able to get it work by disabling GDM Wayland Sessions, which seems to be the issue.
    Prior to installing the Parallels Tools do the following:
    1. I first logged out and logged in using the Gnome XORG Login, by clicking the little gear icon in the login page when you enter your password (after clicking your name).
    2. Then you need to edit the /etc/gdm/custom.conf and uncomment this line (should probably back the file up first): "#WaylandEnable=false", which will disable Wayland logins in Gnome.
    3. Then reboot and install Parallel Tools. It should allow you to login now.
     
    Mark Fine likes this.

Share This Page