Parallels USB Problem

Discussion in 'Installation and Configuration of Parallels Desktop' started by Mara, Jun 19, 2007.

  1. dkp

    dkp Forum Maven

    When you install the Parallels tools does it end by rebooting Windows?
  2. chadrichards

    chadrichards Bit poster

    yes it does
  3. dkp

    dkp Forum Maven

    I absolutely cannot reproduce that error. It will be interesting to know what the solution is for this problem. I've read posts where similar things happen when folks have manually installed drivers that overwrite the ones that Parallels has already replaced. Parallels has had to jump through some hoops to get all this to work and if any of their installation file set has been replaced I can see where some weirdness will follow.

    One of the gripes I've had with Windows is that installers can replace components of Windows that other applications depend on. Maybe it's time for Windows to allow the equivalent of /usr/local found in Unix systems :)
  4. Purplish

    Purplish Forum Maven

    Is your internet connection working from the VM?
    Also, when you get the "New Hardware Found" message, give it at least 15 minutes to find and install the driver. This is only a problem the first time through.
  5. chadrichards

    chadrichards Bit poster

    dkp, well i have upgraded to paralles 3212 and now i am getting the error that the usb devie you are trying to use is in use by another device or something to that degree. i think i am falling into the category that many others are complaining about now.

    yes my internet connection is working through vm. I will try that. There is one thing that I should probably mention. I have not done any patches to the windows operating system for the reason that i went to a mac. I do not want to upgrade to service pack 2 since i do not want big bill to be watching.
  6. Mara

    Mara Bit poster

    It' s OK

    With the new update, the problem is solved. Thank you for your support!

    In my case it's a bit different, my problem appeared with Mac OSX 10.4.9 on my new MBP 2.2! So, it's not only the new 10.4.10 responsible.
  7. burtd

    burtd Bit poster

    I have the same problem using a flash drive. Has anyone discovered a solutin yet?
  8. fidosg

    fidosg Junior Member

    Same issue Here OS X 10.4.10 killed USB

    Sounds like I'm in the same boat, all working well, 30 mins ago, I updated my mac software to 10.4.10 and immediately I get the same "USB device...... is being used by another machine...."

    Also for flash drives....

    Does anyone have an answer to this?
    Looks like someone does:

    Just upgraded to the 3214 build and USB is back up - Good job!
    Last edited: Jun 23, 2007
  9. LDF

    LDF Bit poster

    Same problem - a solution ?

    I had exactly the same problem, just after I moved my entire configuration from a MacBook to a MacBookPro through the nice transfer procedure through a firewire Apple provides.

    What I tried that didn't work:
    - I plugged and unplugged several times
    - I closed the application that used the USB
    - I deleted the USB device and reinstalled it (in the device menu)
    - I upgraded Parallels (3188 -> 3214)

    What I did that (probably) worked (may in connection with the last action above)
    - I restarted Windows XP (may be the Mac OS, but I don't think so)

    No problem since, my barcode reader and my camera are accepted again.

    Hope it helps, sorry for the incertitude.
  10. Mara

    Mara Bit poster

    problem is going on

    as I wrote in another thread my problems still there:

    I' m still having a problem with my cardreader (reiner SCT for online banking, with hbci card). All USB devices work fine since I updated parallels, except this device.
    For me it's the only reason for using win XP on my Mac (business apps. banking and personal managment, for both apps. I've to be able to use the smartcard (banking card reader) and still I'm getting the same problems:

    " USB Device you are trying to connect to the virtual maschine in being used by another application. Close that app. or unplug the device aand plug it again. Then try to connect the device again."


    How can I find out which app. is using the device?
  11. volli

    volli Bit poster

    USB problem with REiner SCT Cyberjack

    Same problem as Mara

    I'm using Parallels 3.0 latest update on an IMAC 20" with Intel.
    I can only use my homebanking after about 20 tries to connect the usb device.

    Somehow it works after about 20 tries. I have to do this every time.

    Does anyone have a solution to this problem ?

  12. psp777

    psp777 Bit poster

    I too am having USB problems here.

    I am unable to connect to my Line 6 tone port kb37 for audio. The device is unselectable greyed out when I use the utility "Line 6 monkey" to update the usb firmware and flash memory for the device in order for it to work.

    It works fine under bootcamp but not parallels.

    Line 6 says they dont offer support for virtual device programs so i am hoping parallels gets their usb issues fixed

    Macbook pro intel core 2 dou
    windows xp
    All latest updates
  13. chadrichards

    chadrichards Bit poster

    Well I two am having a bit of a problem even after the upgrade. Even though my error message went away now it seems that I do not have the usb drivers installed in windows xp. I did re-install the parallels tools and that did not help. Can anyone tell me where the driver comes from. Does it come from windows xp or from parrallels? Is it a generic driver that I can get off another windows machine and put into parallels or is it something that is virtually run that parallels has to run. Any help would be appreciated.
  14. psp777

    psp777 Bit poster

    you make a good comment about the usb device itself. Can this be isolated and updated seperately? From a 3rd party?

    From my experience it is clear that all usb works under mac os of course...

    All usb works under bootcamp (at least my devices)

    So what is missing as far as the usb in relation to Parallels desktop? Where is the device driver?can it be isolated, switched, altered etc...?
  15. mjuchter

    mjuchter Bit poster

    I'll Eleventh That

    Since there have been firsts, seconds, thirds, and beyonds, we'll call this an "eleventh." I can't pin down exactly when it started, but the majority of my USB devices are now unusable in Parallels. Each time I try I get the message about the device being in use by one of my Macintosh applications... Even when Parallels is the only thing running on my system!

    I did check the programs that launch at startup, and none of them should be using, say, my printer/scanner combo (EPSON).

    I really need to access several USB devices under Windows so, for now, Parallels has become useless. Consider this another plea for a fix!
  16. Pmoscoso

    Pmoscoso Bit poster

    Garmin 278C

    Unable to connect my MacBook Pro with Parallels 3214 to my Garmin GPS 278C. Before upgrading I was able to connect. The only reason I bought this software was to use this device with my Mac. I am very dissappointed.:(
  17. davetroup

    davetroup Bit poster

    Possible workaround to USB problem

    I was having the exact same problem with my Garmin 396, and I just accidentally found a workaround. I had tried plugging it into the left-hand USB slot on the keyboard, as well as directly into my Mac. Both failed with the "device is being used by another application" error. Then, just for the heck of it, I plugged it into the OTHER USB slot on the keyboard. To my surprise, it works! It doesn't make sense to me, but it works. So try different USB slots, perhaps it will work for you too.
    Last edited: Jun 29, 2007
  18. Sumleilmus

    Sumleilmus Bit poster

    Alas, USB, Palm

    I was already running Moc OS 10.4.10 when I installed PD build 3188.

    I always get the message about another program using my USB device.

    Even though I set the PD prefs to autodetect USB devices, the Palm does not show up in the Device menu, and Windows XP can't find it to install it.

    I hope they fix this soon.

    The only reason I bought the software was for my Palm.
  19. dkp

    dkp Forum Maven

    They did fix it. You need to use the Update option in Parallels's Help menu and download build 3214. It was released to correct the problem introduced by Apple with 10.4.10.
  20. Sumleilmus

    Sumleilmus Bit poster

    Hot ziggety!

    Thank you.

    I had actually attempted using Parallels update as you suggest, but it took so long for the progress bar to show any activity at all that I foolishly abandoned the search.

    It's downloading now.

Share This Page