Parallels Workstation 2.1 for Mac OS X Beta6 is ready for download!

Discussion in 'Announcements' started by Andrew @ Parallels, Apr 29, 2006.

  1. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    Parallels is proud to release the Beta6 version of Parallels Workstation 2.1 for Mac OS X!

    Improvements and Fixes in Beta6:

    * USB fixes (more devices supported: PDA, scanner, etc.)
    * Shared Folders fixes (added support for guest Windows 2000)
    * Network improvements: host-only networking
    * Custom video resolutions support added
    * Image Tool introduced
    * Autoupdate introduced
    * Kernel panic in virtual memory manager fixed
    * Shutdown in fullscreen mode hang fixed
    * Virtual disk sync() problem with Linux guests fixed

    There are following known issues in Beta6:

    * Some USB devices still may not work
    * Network doesn't work in Linux guests if bridged to WiFi
    * Resume doesn't work correctly if suspend was made while playing audio inside guest
    * Fullscreen may not work for some custom resolutions

    NOTE TO CURRENT BETA TESTERS: There's a new and improved Parallels Tools package in Beta5 too. To update, open your VM, log in, click the "VM" menu, and click "Install Parallels Tools".

    Download Parallels Workstation 2.1 Build 1812.5 for Mac OS X now!
     
    Last edited: Apr 29, 2006
  2. skyking

    skyking

    Messages:
    5
    I installed beta 6 and even though my "about Parallels" indicates that I have beta 6, it is acting like beta 1 or 2. I am having trouble starting the VM, and when it does start I can't connect to the internet and I have to use the control/alt key combination to move the cursor outside the VM window. Also, the controls are back on the right side of the machine.

    Larry Lane
     
  3. Networking stopped working after upgrading to Beta 6. It was working just fine with Beta 5. After installing Beta 6 the network connection in XP now shows no valid IP address despite several attempts to redo the network setup via the setup wizard.

    VM configuration is set to use bridged network and en1: Airport/wireless. Also tried using the Default connection, but no luck on either.

    Wireless works fine in OS X.
     
  4. peterwor

    peterwor

    Messages:
    140
    Bridged networking hs stopped working in my Windiows XP guest OS after installing Beta 6.
    I WAS using en1:Airport Adapter and bridged ethernet on my MBP up until now and wih Beta 6 its totally DEAD.
    Looks like I'm not alone either. I saw the note about it not working with Linux and WiFi but I think theres an issue with Windows as well. I tried the NAT spof and that doesn't ork either.

    Help us Parallels!!!!
     
  5. skyking

    skyking

    Messages:
    5
    I reinstalled beta 4 and now I can connect to the net and everything appears to be back to normal. After several attempts, I couldn't even get beta 6 to start. (I originally got it started, but with no network connectivity)
     
  6. timfrey

    timfrey

    Messages:
    2
    Issues with Beta6

    Just installed the latest version upgrading Beta 5 and noticed a couple new things. 1st, it required a reboot which I don't recall Beta 5 asking for. 2nd the BIOS screen that flashes up still displays version 1.05 (certainly hope you don't have to create a new installation as this would be a huge downfall). 3rd, as it appears many are finding, the networking feature appears to no longer work. I've been using the wireless connection in my iMac G5 up to this point with no issues but now it's not able to connect. Have tried many different settings but to no avail. Hopefully they can solve this, and quickly!!!! Keep up the good work guys, you've got a killer app brewing here.

    T
     
  7. skyking

    skyking

    Messages:
    5
    When I installed beta 6 (and I could get it to run) I had to use the control/alt key combination to get the cursor back out of the VM and into the mac. Timfrey indicated his version displayed 1.05, I recall that mine did too. Could this be a corrupted beta???
     
  8. engrProf

    engrProf

    Messages:
    28
    me too

    Put me on the list of people for whom networking has stopped working...:( :( :(
     
  9. kaufman

    kaufman

    Messages:
    58
    Networking works for me, but I am having an issue with USB support.

    When I plug in and turn on my Dell Axim x51v, I can see it in the list of USB devices. THe first time I attached to it, windows said it was installing the drivers, but then it said that it had an issue. I tried rebooting, and it still will not be seen by activesync.

    In addition, after trying to attach the PDA, the VM lockes up during a shutdown windows.

    Getting closer, but still some work to be done.

    Michael
     
  10. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    1. Please reinstall Parallels Tools - it will fix your mouse behavior.
    2. Default toolbar position was moved back to the right side according to poll results on this forum. You can customize toolbar position using menu Edit->Preferences->User Interface.
     
  11. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    Thanks for reporting WiFi networking issue - we will check this ASAP!
     
  12. HON C TSOI

    HON C TSOI

    Messages:
    6
    No luck of gaining back with networking while in Beta 6??
     
  13. prethip

    prethip

    Messages:
    7
    bluetooth and isight

    giys where is bluetooth and isight support...
    do u think u will have that before the final version comes out...?
     
  14. Ekke

    Ekke

    Messages:
    5
    Network fix for guest OS with Airport

    This is how I got it to work:

    Look at the Parallels tool - if it says connected to network:
    Open your Network prefs in guest OS
    There you will see that TCP packages are sent but not recieved, indicating
    a TCP/IP problem.
    Open Network preferences in Mac OSX
    Get TCP/IP for "Airport"
    Get TCP/IP for "Parallels" - you will find any assigned private address there.
    Copy "Airport" settings into "Parallels" as MANUALLY (not DHCP)
    Copy settings to TCP/IP properties of guest OS
    Network is running again
    I consider this just a temporary workaround - please Parallels fix it.

    I would rather have it as a true bridge with a new IP and offering DHCP for the
    guest, or even grabbing the IP from the physical NW adaptors and rout it to
    the guest with DHCP. Too much hazzle for people who switch to different NWs
     
  15. dentate

    dentate

    Messages:
    22
    OK, I had some issues installing both Beta 5 and Beta 6 on my iMac and this is what I learned:

    I had installed antivirus software on the VM (McAfee) and I have now found that you cannot have this on. Disabling it is not enough. The antivirus protection does something to certain Windows files that Parallels--and in particular, Parallels Tools--expects to find there. The Parallels Tools doesn't work and won't install--it asks for drivers from nonexistent disks. To fix this, I had to remove the protection software, reinstall Windows XP (choosing the "Upgrade" option during install, to preserve programs and settings), and then reinstall Parallels Tools. After Beta 5 I then reinstalled the virus protection and everything worked. When the same thing happened with the Beta 6 installation, I just quit using the virus software.

    My Parallels icon on the dock no longer worked. This is because Beta 6 puts the application in a folder together with Image Tools, so I needed to add that location for the dock.

    My networking works fine on Default with Beta 6, but somewhere in all this I lost the workgroup and had to set it up again on the VM, after which it worked fine.

    Glad to report that Compressor now works as advertised. I used Image Tools first, then Compressor (attaching the CD drive to the Compressor .iso file) but I probably did not need to. This doubled the free space on my expanding disk. It does not seem to be compatible with XP's native defragmenter though which shows lots of fragmented files. Also it takes a LONG time and I had to watch the CPU monitor in the host to assure myself that all was well.

    Shared Folders seems to work now, but I still can't get my USB printer recognized.
     
    Last edited: Apr 30, 2006
  16. tacit_one

    tacit_one Kilo Poster

    Messages:
    434
    prethip,
    i was able to connect usb dongle to the guest system - it worked for me.
    actually, usb dongle is just another usb device, - it should work as soon as you connect it to your guest system (so no special support for bluetooth is really needed)
     
  17. maverick808

    maverick808

    Messages:
    167
    None of my USB devices work with every one still reporting that it is blocked. These are...

    iPAQ 2750
    iPAQ 4150
    iPAQ 5550
    i-Mate SP5
    Motorola V3
    O2 XDA 2
    Various mice

    Are any of these supposed to work yet? I notice that PDAs are listed in the list of things that might be supported. What PDAs *are* currently working?

    Also, less importantly, for me, Beta 6 has stopped networking from working.
     
  18. ralfvin

    ralfvin

    Messages:
    2
    Problem with Beta 6

    Things just kept getting better and better until Beta 6 came out. After installing Beta 6 I lost network connectivity. Is there a way to go back to Beta 5?
     
  19. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
  20. Scott Willsey

    Scott Willsey

    Messages:
    174
    Any chance we could just leave the "Announcements" threads for announcements, and the technical threads for bug/problem reports? Especially considering you posted this in 3 or 4 threads total?
     

Share This Page