PD 17 being slow after using a while on M1 mac (4GB virtual ram)

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by YangL4, Oct 28, 2021.

Tags:
  1. YangL4

    YangL4 Bit poster

    Messages:
    5
    I am sorry if this sounds a dumb question..
    I am using the 8gb ram M1 and allocated 4G virtual ram for PD17 with windows 11.
    Now, I understand this is the minimum requirement of win11, but the following behavior makes me confused.

    Each time when I start PD after a restart, it runs decently fast, and my ram usage shows a health green color in my activity monitor. However, after ~30min use of PD17, the ram get stuck in heavy load and my windows virtual machine is almost unusable.

    I am considering upgrade my ram by (selling my current mac and buying a new one). But I wonder if this issue could be solved? It seems there is some memory leak.. I don't know.
    As soon as I log out and log in back or restart, it runs smooth again.
     
  2. YangL4

    YangL4 Bit poster

    Messages:
    5
    or, alternatively, is there a "memory restart" option that's less heavy compare to a full log out? It seems related to memory usage
     
  3. YangL4

    YangL4 Bit poster

    Messages:
    5
    shall i send a tech report After the VM becomes slow?
     
  4. SWANDY

    SWANDY Pro

    Messages:
    317
    Not a solution, but something sounds off like Mike said above. I also have an 8GB M1 iMac (made the same dumb mistake again LOL) and am running Parallels 17.1.0 and Windows 11 PRO ARM, and the limit of 4GB does not seem to effect either Parallels or Windows 11. Now granted I have not tried installing any Windows programs or games that require more RAM (wanted to run Diablo 2 Resurrected but that is having other issues so I haven't even tried it yet) but don't see the slowing down that you have seen.
     

Share This Page