PD12.2 + Windows 10 creators update = Keyboard not working, explorer freezing, task scheduler crash.

Discussion in 'Windows Guest OS Discussion' started by DawidM, Apr 25, 2017.

  1. EmilW

    EmilW Bit Poster

    Messages:
    2
    @Dmitry@Parallels Can we get Parallels take on the fix/hack suggested by @MikeS14? It seems to be working better than anything coming from your end.
     
  2. LinF

    LinF Bit Poster

    Messages:
    1
    MikeS14's solution fixed my problem completely. Like the others, this problem started very mysteriously recently. I was not even running the Creators Update, nor the Anniversary Update, I was still running on the 1511 update, I did have Office and Outlook. The symptoms on 1511 were strange failures and error messages during login, sometimes the handle is invalid, sometimes SessionEnv failed, or sometimes systemprofile\desktop unavailable, or just stuck on the Welcome message. When it did login, sometimes starting a program for the first time would give the stub is bad message. I was able to install the Creators Update hoping it would correct the problem, it did not, the symptoms continued, plus the ctfmon.exe problem that started happening and Google led me here. Seems like Parallels is a common thread in this problem.
     
  3. FransH1

    FransH1 Bit Poster

    Messages:
    2
    Updated to Parallels Desktop Version 13.0.1 (42947)
    Still have the same problems. Will try MikeS14's solution now.
    >> after the change in the register Windows works normal again, the taskbar responds immediately and the keyboard responses.
    >>>> Parallels, use this to fix this!
     
    Last edited: Sep 4, 2017
  4. BurkhardP

    BurkhardP Bit Poster

    Messages:
    9
    The trouble with the task bar not responding, restarting and not reacting on keystrokes started three days ago with my Windows 10 VM running on Parallels 11.
    I updated to PD 13 but the trouble still remained. Spent des whole day today with this annoying thing.

    But MikeS14's solution solved the problem! Just changed the registry value from 3 to 0 and rebootet as described in post #36.
    Great job! Thank you!
     
  5. KevinZ2

    KevinZ2 Bit Poster

    Messages:
    1
    I'm not using windows 10 much and only just discovered the same problems here this week. MikeS14's solution seems to have worked.

    Seems to be many posts going on about this. It would be nice for Parallels to fix this once and for all.

    Thanks
     
  6. MarkT9

    MarkT9 Bit Poster

    Messages:
    2
    SOLVED! (At least for the moment.)
    This issue has been plaguing my Windows for months! I'd become resigned to the fact that it takes 10+ minutes just to sign into Windows and that I can't use the start menu and that the keyboard doesn't work in most apps. (Yes, that basically means Windows is completely unusable.)

    And just for the record, I'm a computer engineer with a specialty in operating systems. So I've worked pretty hard to try to troubleshoot, understand, and solve this problem. And every month or two, I'll try to see if I can search for someone who has any ideas on a solution, but always end up frustrated....until now!

    I applied MikeS14's recommended registry key change (see earlier post), rebooted, and Windows came up immediately, let me log in immediately, and the start menu and keyboard worked immediately. Windows is usable again!

    To the Parallels team: the thread on this topic on the Microsoft community site suggests that you may be actively modifying the registry key in question. If that's the case, please, please, please have your dev team look at how they might address this. Parallels is awesome and is definitely worth the price...when it works. But I bought it solely to run Windows, so when Windows is practically unusable, I (and many others) have no reason to continue to give you money.

    Thank you MikeS14!! And thanks in advance for a permanent solution, Parallels team!

    [ If it helps others: I'm running Windows 10 Home (version 1607 14393.1480) as a VM under Parallels 12 (12.2.1 - 41615) on a Mac (El Capitan 10.11.6). ]
     
  7. JeremyP2

    JeremyP2

    Messages:
    1
    Yes this is the problem that prevent's Task Scheduler forms starting properly. Simply changing Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\Maintenance\State\ReportedState from 3 to 0 with regedit.exe and then going to Manage Computer -> Services -> Task Scheduler and clicking start or rebooting will fix it.

    Not sure how it got messed up, and no amount of system checks or check disks will fix it, this key just needs to be manually changed.
     
    JimN2 likes this.
  8. JimN2

    JimN2

    Messages:
    1
    My Parallels 13.0.1 is now working again in Windows 10 thanks to that one registry update. Many thanks to all who worked to resolve the issue.
     
  9. RahulP1

    RahulP1

    Messages:
    1
    @MikeS14 thanks so much!
     
  10. Kramer

    Kramer Bit Poster

    Messages:
    3
    Thanks a lot, you saved my weekend. After trying to solve the problem for more than two days an nights I was just about to reinstall Win 10. Short prior I took a look in this forum and found your suggestion. It's unbelievable that one little figure can bunch a whole system in a way that even the guys from Parallels were not able to solve this issue.
    Best regards from Germany!
    Lutz
     
  11. JeffA2

    JeffA2

    Messages:
    1
    Thank you MikeS14!! As soon as I installed parallels 13 and tools, I had super slow boot up, cortana search problems and the task scheduler not working. Parallels support not so helpfully told me to go ask Microsoft. I wished I would have seen the end of this thread sooner. Changing the registry key as described and rebooting immediately solved all three problems. I was about to try to roll back to Parallels 12 and a backup of the virtual machine. You saved me a huge amount of time and effort!
     
  12. cedral

    cedral Bit Poster

    Messages:
    6
    This fixed it for me.
     
  13. PetrK2

    PetrK2 Bit Poster

    Messages:
    2
    Thank you MikeS14! Many Many thanks. You're the boss. Parallels would have had you employ. They have solved it very badly and eventually did not. Just you! Now they should understand the principle of the change and apply it to the update.
     
  14. EWGllc111

    EWGllc111 Bit Poster

    Messages:
    2
    I've had this happen to three of our systems, all starting just three weeks ago. All on 13. The first was the missing systemprofile/desktop problem and quickly went away thankfully. Not even sure what I did to fix it. Probably just restarted Windows. Then literally the next day the adjacent system developed the same problem including the "invalid handle" error. That was a three or four day affair culminating in a total reinstall of Windows. I still didn't know if it was Windows, Parallels or even our new network setup since we had just moved into a new office and I was working with some new switches. This particular system was the first system I had tried using the Bootcamp partition as the virtual machine instead of importing it or installing a new Windows VM. So I thought that may have something to do with this problem.

    Then just three days ago, the third system developed the problem. It too uses the Bootcamp partition as the VM. I'm still wondering if this has anything to do with the problem. Two days screwing with this, blood pressure rising, I came upon this post. I kept trying the Microsoft solutions I was finding to the missing systemprofile/desktop problem. Which would work, but then after a reboot or two the problem would return. I will try the solution above tomorrow when I get to work. I think I will separate the Bootcamp partition too. This particular system got stuck on a Windows update which I can't seem to clear out. A different problem, but maybe it's related. I have 15 other systems using Parallels, so I hope it doesn't happen to each one of them. How in the world did MikeS14 figure this out? I'm so glad he did. Thanks!
     
  15. EWGllc111

    EWGllc111 Bit Poster

    Messages:
    2
    No go for me. Tried editing the registry key per MikeS14's recommendations and and I get and "Error Opening Key" message (see image) and I can't change it. The maintenance scheduler is not in progress anyway. Looks like I have a different problem with the same symptoms. D**n! I really don't have time for this because I am leaving town for 6 weeks.
     

    Attached Files:

    Last edited by a moderator: Oct 30, 2017
  16. ParallelsU83

    ParallelsU83 Bit Poster

    Messages:
    1
    Many thanks, I have just applied your fix and it fixed a number of other problems that I was having (for months). However, when you say, 'forgot to UNDO the changes' what do you mean? and how would I go about it?

    Thanks again!
     

Share This Page