PD14: USB-C to USB-C file copy locks Explorer and Windows

Discussion in 'Windows Guest OS Discussion' started by MarcelloR, Aug 31, 2018.

  1. MarcelloR

    MarcelloR Bit Poster

    Messages:
    30
    Hello everybody.
    I started to notice a very strange behavior with PD 14 Business Edition (v. 14.0.0 45124), macOS X 10.13.6, MacBook Pro 2018 15", Windows 10 Pro.

    • I connected two external drives (USB-C, NTFS). One drive on the left USB-C port and one drive to the right USB-C port.
    • Start to copy (drag&drop) all files from one driver to the other (that was empty); the size of the files to copy is about 500 Gb.
    • After about 1.2/1.4 Gb, Explorer stopped to copy files: it's locked on a file (size if a few Mb). No way to cancel the operation. Killing and restarting Explorer does not work.
    • I removed the two drivers (unplugging the USB-C cable) and Explorer seems to unlock (but, of course, it fails the copy).
    • I tried to shutdown the VM: the VM does not close, I can only see a black screen and, on the Mac side, the Parallels Dekstop process does not respond anymore. I can only force the process to exit using macOS's Activities Monitor.
    • After rebooting the Mac, thinking to a random issue, I retried the full operation but instead of copying the files using Explorer, I ran ViceVersa Pro which I use when I have to move/copy a large amount of files.
    • VVPro starts to copy the files and then, after about 1.2/1.4 Gb, it halts in the same way Explorer halts. No way to cancel the operation and close VVPro until I unplug the two devices.
    • At that point, I get the control of Windows. I try to shutdown it but I get the same behavior as mentioned above: Windows does not stop the VM and the Parallels Desktop process on Mac is marked in red as "Not responding" (of course, in this scenario, when I move the mouse over the VM or PD, I get the classic colored waiting-wheel of macOS).
    • I gave-up with Windows and I tried the same operation on Mac, using Carbon Copy Cloner (both the disks are formatted with NTFS, I'm using Tuxera NTFS). It works like a charm.
    Thus, I'm going to think that there is some kind of issue with PD14 when copying large amount of data directly between to external drives connected to USB-C ports.

    Please note: I don't have any antivirus installed on the VM. Also note, the full process I described here is very dangerous because put both the VM and the Mac in an unstable state. Before making any test, I have to restore my VM from the last backup to avoid critical disk issues.
     

Share This Page