Performance problems in Windows 10 after upgrade to v14

Discussion in 'Windows Guest OS Discussion' started by DellW, Aug 27, 2018.

  1. sfiske

    sfiske Bit Poster

    Messages:
    3
    My MacPro has massive issues with Mojave 10.14.4 and latest parallels. Windows 10 has become unusable. I have the exact same setup on my MacBook Pro and it is fine. Seems to just effect a handful of Mac models, I had a old VMware Fusion license so I spun up a Windows 10 in that and it seems to work better than Parallels at the minute.
    Please fix this performance issue Parallels people, it's driving a lot of us insane.
     
  2. bokholeff

    bokholeff Bit Poster

    Messages:
    3
    Hi, I have very similar problems, and it started right after the upgrade to 14. I can start the Win10 VM but logging on takes minutes now, sometimes it does not work at all and I have to trigger a hard VM stop. When the VM is finally up and running, the CPU load on my MacBook Pro (2016, 2.7GHz I7, 16GB) goes over 100%, and many apps freeze, including the native macOS apps. Wish I could go back to pre14. Any idea how to fix these problems? Happy to provide all data needed to get this done. Regards, RolandAudacity Find My iPhone Origin
     
    Last edited: May 12, 2019
  3. SK1234

    SK1234 Bit Poster

    Messages:
    13
    I notice that rendering from Chromium is painfully slow on my box. Maximizing an instance of VS Code takes many seconds. Switching between Chrome tabs is extremely laggy. To me it looks like GPU rendering is broken or something. I'm on an iMac Pro with 8 CPUs assigned and 16GB (of 64 GB) assigned to the VM. This should be blazing fast but isn't.
     
  4. SK1234

    SK1234 Bit Poster

    Messages:
    13
    As I've read many times that switching back to v13 or switching to vmware Fusion resolves the issue, I just went ahead and installed vmware Fusion 11 (had a license key already and import is really easy). I have to say, WOW! Really snappy and feels like native Windows performance wise. This is sooo much better now. Sad I had to go to vmware Fusion. Parallels has clearly some more homework to do... I really hope that I don't see any other roadblocks with Fusion. I will use it for a couple of days.
     
  5. KorkyPlunger

    KorkyPlunger Kilo Poster

    Messages:
    106
    I am seeing this as well. After I resume my VM each morning, the guest CPU spikes to 100% as does the Parallels process, and the VM is unusable for 5-15 minutes until the CPU drops back down to normal.

    This was not happening a couple months ago under PD 14, and it's only today that I realized it may be correlated with a recent upgrade to Mojave 10.14.4, since that's the only thing that's really changed recently.

    I have filed many technical data reports under a different thread (@Dmitry@Parallels knows the one) but here's another I just generated: report #311181390

    If you need additional technical data, spindumps, or anything else, please let me know.

    -- FOLLOWUP --

    After switching to the Apple hypervisor as others have recommended, I have not seen this issue again today, and CPU use seems much better.
     
    Last edited: May 14, 2019
  6. GrantT2

    GrantT2 Bit Poster

    Messages:
    11
    After switching to the Apple hypervisor as others have recommended, I have not seen this issue again today, and CPU use seems much better.[/QUOTE]

    Is there a link to info on how to switch to0 Apple hypervisor?
     
  7. GrantT2

    GrantT2 Bit Poster

    Messages:
    11
    I discovered that Parallels Configuration is where one can select the Hypervisor, Parallels or Apple. But when I select the CPU & memory tab all of the selections are greyed out. There is a note at the top of the tab that indicates that some of the settings cannot be changed until the VM is shut down, but of course being greyed out I cannot make changes.

    Any ideas on how to get a functional Windows 10 Configuration panel?
     
  8. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,361
    Hi @GrantT2 , Please shut down the virtual machine(Parallels Desktop icon->Actions->Shut down) and refer the article https://kb.parallels.com/117287 to access virtual machine configuration. If Parallels Desktop quits when shutting down the virtual machine, please change the "On VM shutdown" option to "Keep Window open" in virtual machine configuration and follow the above steps again.
     
  9. KorkyPlunger

    KorkyPlunger Kilo Poster

    Messages:
    106
    Just as an update: since switching to the Apple hypervisor, I have not had this issue (9 days so far)
     
  10. GrantT2

    GrantT2 Bit Poster

    Messages:
    11
    Thanks Arun, that worked.
     
  11. GrantT2

    GrantT2 Bit Poster

    Messages:
    11
    It did not work for me but perhaps I will try again.
     
  12. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,361
    Hi GrantT2, Please keep us posted.
     
  13. rodneyh2

    rodneyh2

    Messages:
    1
    First post here. This issue is also affecting me. As of a bout 1-2 months ago, it just started getting worse and worse to the point where it was unusable. I just wanted to point out that the below "workaround" worked for me. Been working fine for 72 hours since trying this. I had followed some of the other advice here but it either only worked temporarily or not at all (switching the Hypervisor, downgrading to PD13 (apparently once you get in this state a downgrade doesn't help), etc.). I'm glad my system is usable again, but like other users I'm really disappointed this issue that's been around for ~ a year, and that appears to affect many users doesn't seem to be a priority to fix.

     
    Seth W likes this.
  14. MichaelR40

    MichaelR40 Bit Poster

    Messages:
    2
    I seem to have the same problem.
    I have attached the mac error log.
    Thanks,
    Mike
     

    Attached Files:

  15. MichaelR40

    MichaelR40 Bit Poster

    Messages:
    2
    Where can I find help for this problem?
     
    Seth W likes this.
  16. nanooq

    nanooq Bit Poster

    Messages:
    18
    Tried that as well...to no avail...Windows 10 still boots about 4 mins and is basically unusable for the first 5 mins (as the Mac itself). Windows 7 still boots in less than 1 minute, Ubuntu as well (but has frequent lags of about 30 secs since PD14).
    I'll either downgrade tp PD12 (strangely enough I only upgraded to PD14 because it supposedly makes W10 much faster - what a mistake, my decision and the product) or try a VMware based product.
     
  17. GrantT2

    GrantT2 Bit Poster

    Messages:
    11
    No improvements for me whatever modifications I attmpt.

    Hopefully we will all be offered a free upgrade to V15 if and wehn it appears.
     
    nanooq and HelenaA like this.
  18. HughT1

    HughT1 Bit Poster

    Messages:
    2
    Just want to add myself to the list of people struggling with this.

    I'm on an 8 core Mac Pro running the non-subscription version of Parallels 14 in Mojave 10.14.5. The experience is pretty dire.

    Windows was, at first, completely unusable. And I couldn't access Parallels Configuration settings because the VM seemed to restart Windows.

    Thanks to this note -- https://kb.parallels.com/124449 -- I managed, incredibly slowly, to change the Windows settings so that I could actually shut down.

    I was then able to access the Parallels Configuration settings.

    * Previous versions of Parallels had run happily in 4 cores. Now the 'recommended' setting is 2. I set it to that. (Subscription version may be different.)

    * I also set the RAM allocation to half of what I have available -- that is, 6144 MB (I have 12 GB total).

    * I set the Graphics memory to Auto.

    Windows 10 now runs. It's still very slow. All controls take a long time to respond. Typing is like watching grass grow. I can't say I'm happy, but at least I can do limited web testing.

    In addition, the VM's CPU Usage icon at top right is constantly red, with CPU usage showing at 100%. This can't be good.

    Like others, I have found Parallels to be quite usable in the past. I do have to laugh every year at the claims of huge increases in performance. We'd be running faster than PCs by now if they were true! But this combination -- Mojave and Parallels 14 -- seems to have set us back a long way.
     
  19. nanooq

    nanooq Bit Poster

    Messages:
    18
    ...that would basically the only way I would try PD again. I wouldn't spend a cent on PD before I'm sure it is usable.
    PD14 was a complete waste of money and even more time for me.
     
  20. GrantT2

    GrantT2 Bit Poster

    Messages:
    11
    I just received a notice that P15 is out. Does this resolve our problems with P14 or is it more of the same?
     

Share This Page