PLan 9 won't install on Parallels 8

Discussion in 'Other Guest OS Types Discussion' started by Michael Newbery, Mar 15, 2013.

  1. Michael Newbery

    Michael Newbery

    Messages:
    11
    Obviously this is a minority interest. I last asked this ages ago and got no response then, but I'll try again.

    When trying to install Plan 9 http://plan9.bell-labs.com/plan9/ the installation just hangs.

    I've tried playing will all the settings I can find, to no avail.

    Long ago, Plan 9 did run under Parallels, I used to run it. But it's stopped working and still doesn't.

    Any ideas? Anyone got it to work?
     
  2. Specimen

    Specimen Product Expert

    Messages:
    3,246
    When you say you played with all the settings you could find that isn't of much use unless you tell what settings you used exactly, but the most important one for this to work would be the Operating System type, since Plan 9 doesn't fit in any category presented there you would have to pick a generic/other one, or try a couple of options. Another thing that can do the trick is boot flags.


    Also, a simple googling turned up this:
    http://www.plan9.bell-labs.com/wiki/plan9/Virtual_machines/index.html
    http://www.plan9.bell-labs.com/wiki/plan9/Installing_in_Parallels_Desktop_on_Mac_OS_X/index.html
     
    Last edited: Mar 16, 2013
  3. Michael Newbery

    Michael Newbery

    Messages:
    11
    The Googled page is, as thw Plan 9 wiki warns you, terribly out of date. As it says:

    The 3xxx build series for Parallels works flawlessly with Plan 9. As for the 4xxx build series (Parallels Version 3), Plan 9 frequently crashes and works unreliably. Try turning off VT-x acceleration in this case. Plan 9 works on the 5xxx build series without problems.

    And that accords with my experience, that it stopped working around 6xxx and hasn't worked since.

    I have the OS set to Other/other, with no boot flags. I have not yet tried working through all the OS options to see if any work.

    The settings I have played with, as per suggestions on the Plan 9 wiki, are different options for CD-ROM boot device, different controller types for the hard drive and making the hard drive fixed size rather than expanding.

    I asked the forum in case anyone HAD tried booting Plan 9 and had managed to get it to work but hadn't posted this (anywhere that Google could find it).

    I'll see what results, if any, I get by changing OS type,
     
  4. Michael Newbery

    Michael Newbery

    Messages:
    11
    Just to follow up. I have iterated through every possible OS combination in Parallels 8.0 with identical results(*)---the boot hangs with the message

    Trying to boot from CD-ROM drive... PBSR...EI

    (*) When the OS selected is Mac OS X it pops up a message that "There is no operating system installed in this virtual machine. Please insert an operating system installation CD into the optical drive of your Mac and restart the virtual machine"
     
  5. Os underdog

    Os underdog

    Messages:
    1
    I was fighting nearly the same issue last night. I was using a slightly older version of parallels (Build 7.0.15107 (Revision 796624; September 3, 2012)) and hit the same failure. I was able to make some progress by changing where the cd was mounted. I used the first sata port (SATA 0:1) and got past the "PBR...EI" message. I don't know if it matters, but I chose the OS "other/other."

    I now have a series of messages about "trying sdC0...dosinit: can't open #S/sdC0/9fat"
    Where the "sdC0" strings vary with values like sdE0 through sdE5.

    and I'm finally left at a "Boot from: " prompt. Time to look at more of the plan 9 docs to get a clue.
     
    Last edited: Jul 31, 2013
  6. Michael Newbery

    Michael Newbery

    Messages:
    11
    Yes, I've tried that too, but it rejects all the files it finds on the CD. I'd be grateful if you do find the magic incantation to boot.
     
    Last edited: Aug 4, 2013

Share This Page