Please, where is the '@' key on a macbook pro??

Discussion in 'General Questions' started by satyor, Jun 23, 2007.

  1. satyor

    satyor

    Messages:
    35
    hi,

    i've just installed parallels 3 for mac & created a VM for windows xp

    everything seems to work fine so far apart from the fact that the keyboard's keys do not all match with the mac os ones.

    i have a macbook pro
    i am desperately trying to figure out which key i should press in order to write the "@" symbol while working on the windows xp environment (my windows xp VM)


    please help
     
  2. Robster

    Robster Kilo Poster

    Messages:
    215
    Try shift "

    Robin
     
  3. dkp

    dkp

    Messages:
    1,367
    Are you running a localized version (not the USA version) of Parallels?
     
  4. satyor

    satyor

    Messages:
    35
    thanks to both of you

    i tried shift ", no success:(

    no, i am using the us version of parallels which i downloaded & bought two days ago here:
    http://www.parallels.com/


    i hope somebody can help, since i cannot work on my windows xp VM without the "@" symbol:confused:

    thanks
     
  5. AlanH

    AlanH Kilo Poster

    Messages:
    316
    I assume you already tried Shift-2, which is where it should be marked on your Apple keyboard?

    Check the keyboard you have selected in XP. Select Start->Control Panel->Regional & Language Options->Languages->Details. The Default input language in your case should be English [United States] - US. Note that I'm guessing a bit here, as my settings are a tad different. I have English [United Kingdom] - United Kingdom [Apple Keyboard], because I have a keyboard map installed for the UK Apple keyboard.

    You may need to change the selection, or play with the Installed services panel on that tab to get your setup working.
     
    Last edited: Jun 24, 2007
  6. John Purins

    John Purins

    Messages:
    73
    3 questions:

    Are you using the standard built-in keyboard or a plug-in USB keyboard?
    In a Mac application such as TextEdit, do you get '@' when you type shift-2?
    In Windows XP what, if any, character do you get when you try to type a '@'?
     
    Last edited: Jun 24, 2007
  7. satyor

    satyor

    Messages:
    35
    hi Alan

    thanks for your suggestions

    i checked my windows xp regional options/languages/details: they are fine

    note: i am using an azerty keyboard
     
  8. satyor

    satyor

    Messages:
    35
    hi John

    thanks too for trying to help

    1. i am using my macbook pro keyboard (azerty)

    2. your second question: i get "2"

    3. in windows xp, when pressing the '@' key, i get 'exponent 2'

    To Alan (i forget to ask him in my quick reply to Alan): i don't understand what you mean by 'play with the Installed services panel on that tab to get your setup working'

    sorry, i've been a switcher for a couple of months. thanks.
     
  9. John Purins

    John Purins

    Messages:
    73
    It seems as if your shift key is not working properly on the keyboard. Do you get any of the special characters above the numeric keys, i.e. if you press shift-1, do you get an exclamation mark or does shift-3 give you a # sign?

    Try using the left shift key and then try it again with the right shift key to see if that makes any difference.

    Also, in System Preferences > Universal Access > Keyboard, have you enabled or modified any of those settings?
     
  10. satyor

    satyor

    Messages:
    35
    in mac os, pressing shift-1 gets me '1'
    in windows, shift-1 gets me '&'

    shift-3 in mac os -> '3'
    shift-3 in windows -> "

    note: my keyboard is azerty, not qwerty

    i tried using the left shift key & so forth as suggested: same result

    i have not modified anything in System Preferences > Universal Access > Keyboard

    the only keys' combination i customized is the 'apple-space': since i am working in 2 languages this command (apple-space) allows me to shift from one language's keyboard to the other very easily.

    note: i also tried to get '@' in windows using my second language keyboard, but that gave no result either.
     
  11. AlanH

    AlanH Kilo Poster

    Messages:
    316
    Sorry, I was not aware that you are using an azerty keyboard. I must have missed that in your posts. Your reference to a US version of Parallels led me to assume you are a US user. As I don't know the AZERTY layout you will need to help me. Are there any shift characters marked on your keyboard's 1 and 3 keys above the 1 and 3 characters? If so then Mac OS should display those characters when you hit Shift-1 or Shift-3. If this is not happening then your Mac is not set up correctly. You need to get that right before you can expect Parallels to pass through the correct key codes to XP.
     
  12. John Purins

    John Purins

    Messages:
    73
    Perhaps this thread will help. The thread mentions the use of some Windows keyboard mapping software that may work for you.
     
  13. satyor

    satyor

    Messages:
    35
    no problem:)

    actually the azerty keyboard keys are as follows: the different characters are located below the numbers

    so in your example, i have '1' and below '&' and '3' with " below.

    therefore i need to hit "shift" in order to write the numbers 1 and 3. the & and " characters appear when hitting the related key(s) with no need to hit "shift".

    hope that's clear;)
     
  14. AlanH

    AlanH Kilo Poster

    Messages:
    316
    Crystal clear, and now you come to mention it I do recall this layout - I think I had to use it in Italy once.

    So now that we have that cleared up, where is '@' on your keyboard, and does it print '@' when you hit it in OS X? If it does then Parallels should be passing that character code through to XP, and we need to find a way to get XP to handle it correctly. That's where my "play with the Installed services panel on that tab to get your setup working" comment comes in. You said the settings in there were "fine". I suspect they are not fine, since they don't appear to work.
     
  15. David5000

    David5000

    Messages:
    312
    This doesn't fully answer your question, but with a Mac French azerty keyboard layout, Option \ produces the at sign (@). You can find this and other keyboard characters in Keyboard Viewer, which you can access via System Preferences> International> Input> Show input menu in menu bar.

    David
     
  16. satyor

    satyor

    Messages:
    35
    thanks to all of you for trying desperately to help:) :)


    To John:

    i downloaded the file from the thread you mention. but i am not sure how to install it.
    when clicking 'apple msi' i am asked to choose an application to open the document appleFR.msi
    i tried "parallels" but it remains greyed... (both the parallels file and its contents are greyed)



    To David 5000:

    on mac os, you need to hit option-shift-/ in order to get \
    on windows xp this doesn't work, of course

    i went to System Preferences> International> Input> Show input menu in menu bar and ticked the 'keyboard viewer' box.
    question: in which "menu bar" (you mention) can the keyboard be seen?



    To Alan & every body else:
    maybe there's sth wrong there, i don't know.
    anyway, i have spent my sunday trying to solve this '@' problem which actually is Parallels's developpers' job:D
    i am therefore giving up now and requesting assistance to Parallels about it. afterall, i just bought their software...


    thanks again for your kind help:)
     
  17. John Purins

    John Purins

    Messages:
    73
    The msi file is a Microsoft Installer file... it runs under Windows and requires the Microsoft Windows Installer engine. That's probably already installed on your Windows vm but if it isn't, here's a Microsoft document about it.

    I believe you can double-click on the msi file in Windows or right-click it which will bring a contextual menu with an install option.

    Parallels is probably passing the keyboard scan codes to Windows but Windows just doesn't know what to do with them. The keyboard mapping software should resolve this.
     
  18. David5000

    David5000

    Messages:
    312
    When I mentioned hitting Option \ to get the at sign (@), that is the key combination on a MacBook Pro QWERTY keyboard. Is your physical keyboard AZERTY (as opposed to your having chosen that layout in System Preferences)? If so, the forward-slash (\) key I am referring to is the grave accent (`) key on the far right of the keyboard above "enter/return" and below "delete."

    The Mac OS menu bar is at the very top of your screen. The icon for Keyboard Viewer will appear as the flag of the country whose language you have chosen, just to the left of the time and date.

    As I mentioned, I don't have a complete answer for you, but I think the first step is for you to create the at sign (@) with an AZERTY keyboard in Mac OS. I am able to do so with a QWERTY keyboard in both Mac OS and XP Pro, but with an AZERTY keyboard I can only do it in Mac OS, so I will be interested to see what the solution is too.

    David
     
    Last edited: Jun 24, 2007
  19. David5000

    David5000

    Messages:
    312
    You may be waiting a long time. This is more likely a do-it-yourself project (with the aid of others on this forum).

    David
     
  20. satyor

    satyor

    Messages:
    35
    yes, i managed to install this soft in the windows xp VM but it is no help at all for 2 reasons:

    1. you need to set your language preferences on the french swiss keyboard which is completely different from the other french ones (french french, french belgian, etc), you are therefore lost when trying to write a simple text...

    2. a more important drawback: the program's developper says in order to get "@" you need to use the mac os keyboard right "alt" key. but i am on a macbook pro, there is no such key on it.
    i tried some other keys or combinations of keys while on the french swiss keyboard, but no way.


    To David5000:
    thanks very much, i can now see my mac keyboards, great!

    about Parallels people not answering, well, it's up to them. i do not think at all such an important missing feature should be solved by a do-it-yourself solution. we pay a good bunch of bucks for their soft and they cannot even implement the '@' key on windows xp?
    this is not very serious indeed.


    anyway, we tried our best the do-it-yourself way and we got stuck.
    so let's wait and in the meantime, let's copy-paste "@" each time we need to use it on the windows xp VM:mad: :mad:
     

Share This Page