Poor Linux Support in 3186

Discussion in 'Parallels Desktop for Mac' started by Supadude, Feb 27, 2007.

  1. Supadude


    Has anyone else noticed their Linux distro run significantly worse in 3186. I am running Fedora Core 6 and Parallels constantly runs at 80% CPU usage with Linux idle. I was already annoyed that in 1970 I would get random 100% CPU usage with Linux idle, but this is even worse. Also I had an external hard drive that use to work fine in 1970, but I can no longer get it to work in 3186.

    I am really getting frustrated at the lack of Linux support. This upgrade has been several steps down for me. 1970 was annoying, but 3186 is a show stopper for me.
  2. dominic.giles


    Sadly I see the same thing... in a linux virtual machine cpu is consistently at 25% (I've rebuild the kernel and modified the hertz setting, this dropped the CPU usage by a little)

    There appears to be a problem and I hope now that Parallels have got the production build out the door they might be able to find time to investigate this issue.

  3. Supadude


    This really annoys me as I was looking forward to this release to fix some of the older problems. But it appears they are moving backwards.
  4. dm3


    I've had similar problems in Windows, with VM reporting 0% CPU util, parallels consuming 20-60% of CPU.

    But at least in Windows, I've been able to flip settings to get CPU util back down to around 10%. The culprit has turned out to be the USB2.0 support. If I disable USB support in the VM configuration, Parallels CPU usage drops dramatically. I also ended up disabling keeping the Parallels icon in the dock updated, and even disabled sound. My Parallels CPU utilization is now typically <10% which is close to the 5-10% I was getting with build 1970.
  5. alanbs


    How many posts of this topic will there be ....

    As was mentioned, this high cpu usage is a complete show stopper. If you look around, there are many threads on this subject with many posts. What use is your laptop if its battery life is cut in half as a result of running Parallels?

    As a result, I would not advise anyone to use Parallels especially given that I would guess a large number of Mac owners have laptops. In my mind, fixing this is absolutely more critical than most other issues I have read about. Posts on this subject have been around for months and yet nothing is fixed. In my mind, this implies that the Parallels Team does not consider this a top priority.

    I have a reasonable knowledge of OS internals and virtualization (although I wouldn't claim to be an expert) and I am convinced that you shouldn't have 20-30% usage when your guest system has been sitting idly with no hardware intensive tasks.

    I will be as enthusiastic with praise as others have been when this issue is fixed, but until then, I will regret having spent $80 on a product not worth using and have no plans to encourage others to use this software.
  6. Synchro


    I've found that parallels occasionally pops up and starts eating 100% CPU even when VMs are paused (not just idle). It stops after a while and goes back to normal. It's been doing this for a long time - it used to be accompanied by crashes, but that was fixed a few versions ago.
  7. limec


    That's why people like me are looking forward to VMWare for Mac. Parallels have so far ignored Linux users, treated like second-class citizens.
  8. DougO

    DougO Bit Poster

    The FC6 clock is still running faster on build 3186. This plays havoc when building software and using CVS - lots of files with a future time stamp. The time on the VM Linux FC6 running under RC3 runs MUCH faster than the time on the main MacBook Pro. For example, when the Mac clocks runs for 120 minutes, the same elapsed time on FC6 is 189 minutes. Setting the FC6 time to a NTP server dows not help. It just sets the initial time of day. Tends to vary when Parallels is minimized vs. running in front.

    Machine Name: MacBook Pro 15"
    Processor Name: Intel Core Duo
    Processor Speed: 2 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache (per processor): 2 MB
    Memory: 2 GB

    So, where are the Linux tools? Were not they supposed to be in "the next major release"?

    Throw us a bone here...
  9. palter


    This is a known problem with the 2.6 kernels when running under virtualization. (It happens with VMWare as well as Parallels.)

    Try adding


    to the boot parameters for your kernel.
  10. DougO

    DougO Bit Poster

    This worked. Thank you very much.

  11. mykmelez


    Yes, I see this in both 3186 and 3170. As a result, my battery tends to last only half as long, at best. I'll try disabling USB 2.0 and see how that affects things.
  12. mdickey


    3188 & Linux

    My idle CPU was 70-80% on my MacBook Pro (2Ghz dual core) with CentOS 4.4. I disabled USB, etc. and now it's 20-30%. Much better but still unacceptable. Sounds like Windows users are having the same problem with the latest builds. Wish I could find a copy of 1970 to downgrade to...
  13. Tyland1200

    Tyland1200 Parallels Team

    Fedora Core 6 is not a support build within Parallels, Fedora Core is always in Beta mode and Parallels cannot support third party apps espically in Beta mode. It is difficult for any company to support third party apps.
  14. mdickey


    Parallels vs. VMware Fusion

    I ran a few tests comparing the performance of Parallels 3188 to VMware Fusion Beta 3, which finally allows you to disable debugging information. The results indicate that Parallels still beats the competition, and that the "idle CPU" usage problem happens within VMware as well. VMware's support for multiple cores is promising, but if Parallels comes out with this in their next release (and does it well), I suspect they will maintain the lead for some time.
  15. constant


    VMWare beta EULA prohibits the publishing of benchmarking.

    Were you aware of this?

    Do you understand the risks in doing this?
  16. logandzwon


    What do you work for microsoft or something? None of your post makes any sense, other then the blanted lie about fedora core being a beta.
  17. mdickey


    Fix for high CPU of idle Linux guest

    I can't speak for Windows, but there is a fix for high (20%+) CPU when a Linux guest is idle. This seems to be related to the HZ setting in the Linux kernel which is normally set to 1000. For some reason this high frequency causes extra grief for VM software, at least for both Parallels and VMware. I changed this setting to 100 in my Linux guest and saw the CPU usage drop to under 5%. Here is a good thread on the problem (CentOS forums):


    If like me, you're too lazy to recompile your kernel, there are also (patched) third-party kernel RPMs available at (be aware that this is risky, though; it's safer to recompile):

  18. jmpdude


    Linux (CentOS) USB Drive Support?

    I use Parallels to run CentOS (a freely available version of Red Hat Linux) to host a set of cross-compiler development tools I need. Once Parallels and CentOS are up and running, I just log into CentOS from Mac OS X locally.

    When Parallels introduced USB 2.0 support last Fall (2006), it was great because I could finally use a USB drive to go back and forth between CentOS running on a real PC and the one running on my Mac.

    However, something seems to have broken with respect to USB 2.0 support. As of build 3188 of Parallels, my USB 2.0 drive stopped working. When it was working, it would show up at /dev/sda1, and I would then mount it manually using

    mount -t ext3 /dev/sda1 /media/usbdisk

    from the command line. It worked great; just like my physical Dell PC. But, then, build 3188 came along, and it stopped working (nothing shows up a /dev/sd* at all). Recently, I signed up for the 3.0 beta program with build 4022. I downloaded the new version and converted my virtual machine to the new format, but USB 2.0 mounting under Parallels and CentOS still doesn't work.

    I was using CentOS 4.4. But, recently, CentOS released 5.0. So, under Parallels build 4022, I updated from CentOS 4.4 to 5.0. But, again, that still didn't work.

Share This Page