Poor scrolling experience Linux Mint 20.3

Discussion in 'Linux Guest OS Discussion' started by LucaZ, May 31, 2022.

  1. LucaZ

    LucaZ Bit Poster

    Messages:
    8
    Hello everyone,
    I am experiencing poor scrolling in Linux Mint Cinnamon since several versions.
    In short, when I scroll, the page doesn't scroll in linear mode, but it feels really buggy. Sometimes it scrolls too fast. I link a video to show the effect.
    With Ubuntu (same kernel version as Linux Mint), no problem.
    Also tried to install a fresh Linux Mint VM from Parallels Desktop, but same effect.
    Any suggestion?
    Many thanks
    Kernel Version: 5.4.0-113 (same with kernel 5.13.x)
     

    Attached Files:

  2. Asish@Parallels

    Asish@Parallels Staff Member

    Messages:
    153
    Hello, We would suggest you upgrade the Parallels Desktop to the latest build 17.1.4, and then refer to this KB article to install Parallels Tools manual installation in Linux virtual machine and check.
     
  3. LucaZ

    LucaZ Bit Poster

    Messages:
    8
    Thanks for your reply.
    Tried what suggested, I updated to latest Parallels Desktop's release and reinstalled Parallels Tools, but pretty nothing has changed. Still having a bogus and sticky scroll, especially on Firefox...
     
  4. serv

    serv Parallels Developers

    Messages:
    809
    Luca, try this:
    - shut down your VM
    - open config.pvs (it's inside the VM bundle) in a text editor
    - locate this fragment
    <SmoothScrolling dyn_lists="">
    <Enabled>1</Enabled>
    </SmoothScrolling>​
    - change 1 to 0 and save
     
  5. LucaZ

    LucaZ Bit Poster

    Messages:
    8
    Thanks for your suggestion, but actually it was already set to 0, I found that in another thread.
    Maybe an incompatibility due to Cinnamon?
     
  6. serv

    serv Parallels Developers

    Messages:
    809
    what if you try setting SmoothScrolling to 1, just for the sake of experiment...
     
    lf9 likes this.
  7. LucaZ

    LucaZ Bit Poster

    Messages:
    8
    Thank you @serv for your reply.
    Just tried to change SmoothScrolling from 0 to 1, but nothing has changed.
    I post my Mac specs below if it could help:
    MacBook Pro 15-inch 2018 with macOS Catalina 10.15.7
    2,9 GHz Intel Core i9 6 core
    32 GB 2400 MHz DDR4
    Radeon Pro 560X 4 GB

    P.S.: the VM always uses the Radeon graphics card
     
  8. serv

    serv Parallels Developers

    Messages:
    809
  9. LucaZ

    LucaZ Bit Poster

    Messages:
    8
    Dear serv,
    I just generated a report, with the following ID: 400432688
    Thank you and have a nice week-end,
    Luca
     
  10. lf9

    lf9 Bit Poster

    Messages:
    1
    @serv changing from 0 to 1 within AlmaLinux 9.0 did solve this issue. Just wanted to add this.
     
  11. LucaZ

    LucaZ Bit Poster

    Messages:
    8
  12. LucaZ

    LucaZ Bit Poster

    Messages:
    8

Share This Page