Possible Solution To Parallels 4 Upgrade Problems

Discussion in 'Installation and Configuration' started by sharkmeat, Nov 12, 2008.

  1. sharkmeat

    sharkmeat

    Messages:
    6
    So if you are like the vast majority of us stuck in a loop during the VM upgrade process from v3 to v4 here is a possible solution. I cannot guarentee that everything has been upgrade but so far my v4 VM has been working OK.

    After trying "Backup & Convert" for the first time and the upgrade does not complete the v4 upgrade try the following.

    1) In Parallels 4 goto the menu File>Run Parallels Transporter...

    2) Parallels Transporter will open click Continue

    3) Select Express and click Continue

    4) Select Virtual Machine and click Continue

    5) Select Virtual Disk and click Continue

    6) Click Choose and navigate to your old Virtual Machine (VM) hard drive image. Please note that the new structure of version 4 may make the old VM hard to find but you are looking for a large file normally around 30GB called something similar to winxp.hdd. You may even have to navigate inside this file to another file with the exact same name. Just keep navigating down until you can't go any further. Once you have selected your old .hdd file click Continue

    7) Parallels transporter will now migrate the .hdd image to a new VM

    8) When finished make sure to check "Start the new VM" (or something similar I forgot to right it down but there is a check box you need to check before you click Finish)

    9) The upgrade process will start again. If you get the "Manual Upgrade" message click yes and proceed with the manual upgrade. If Windows pops up a message about reactivating click "No" - if the mouse doesn't work use the arrow keys. After Step 2 of the upgrade you may even get another error message saying the VM cannot be upgraded - don't let up - keep going. You will probably get the "Windows Reactivation" message again - click "No" (this time the mouse will probably work) - cancel all the "New Hardware Detected" windows and anything else that pops up - be very patient and it should automatically start up with Step 3 - just wait and be patient. Step 3 should upgrade the "Virtual Hardware" and takes a loooong time. You'll probably have to go through all the errors again as stated above before Step 4 will automatically start.

    10) Your nearly there - it's so great that Parallels has instructions and support documents for this :) Step 4 installs the latest version of Parallels Tools. Probably the quickest of the steps. You should then be presented with "Your virtual machine has been successfully upgraded" - I beg to differ on the description ;) but you should have a working VM.

    11) One more thing - you'll probably have to reactivate Windows :( which will probably mean you will have to phone Microsoft 1-888-571-2048 for them to activate it over their automated telephone system. Remember you are activating on only ONE machine, it has only ever been installed on ONE machine and you have had a significant hardware upgrade when asked these questions during the upgrade process.

    12) Everything should now be up and running - I've tried a few applications and no trouble so far.

    So I hope this helps with those stuck in the upgrade loop - wow what an easy upgrade that was!!! NOT.
     
  2. LexCan

    LexCan

    Messages:
    5
    This Worked - Thank You!!!!!

    24 hours later, and absolutely NO THANKS TO PARALLELS, I finally have Windows XP Pro running again for the two or three apps I can't get for Mac OS.

    Version 4 finally worked using the process above. Somehow a bunch of Time Machine backups got hosed as Parallels took over my external backup drive - haven't quite figured that one out yet - but I'm just relieved that tomorrow I get to work again.

    As mentioned elsewhere on the forum and the 'net - this is possibly THE worst software "upgrade" experience I have ever had since starting with personal computing 30+ years ago.
     
  3. random77

    random77

    Messages:
    16
    This has worked for me so far.....but i cannot finnish since I dont have a valid activation key (3.0 to 4.0 issue) and tech support has not responded to my tocket (in 2 days). God this is a painful experience.
     
  4. denpashonen

    denpashonen

    Messages:
    29
    I also had issue converting my PD 3 VM to PD 4 VM. It halted on my first conversion attempt and directed me to manually intervene. I was immediately prompted with re-activation warning on my Win XP but I ignored this along with the prompt for "New Hardware Found" warning. The PD Tools restarted by its own but after few minutes the process hung and stated that the conversion had failed.

    Before my second try, I started my Win XP session from a backup I created earlier on another MBP with PD 3 installed. I uninstalled both Parallel Tools and Kaspersky Internet Security that was previously installed on my PD 3 VM. The conversion was halted again, but this time I did not ignore the Windows re-activation prompt and I obtained an authorized key from Microsoft and activated my copy of Win XP. The conversion on second pass was ultimately successful.

    I'm not sure whether the solution was activating the Win XP or removal of either PD 3 Parallel Tools and/or Kaspersky.
     
  5. larryr3455

    larryr3455

    Messages:
    5
    Thanks for you instruction Sharkmeat but I can't find the backup. I'm certain I selected the backup option but the winxp.hdd file does not exist. I've looked for it with spotlight with no success. Any ideas what to do with a missing backup?
     
  6. billc80015

    billc80015

    Messages:
    21
    After wasting more than two days on Parallels .. Yes, I finally have my VM back and working great ... wow ... unbelievable. The solution was so nice and simple and it works so perfectly ... wonder why I stressed one single bit ... wonder why I paid $80 ... then another $30 just for the opportunity to listen to Parallels support onhold messages (which repeat very apologetic messages every 30 seconds .. its sad but its almost like all customer support investment is been put into helpless welcome to everything Parallels and remember to pay emails and of course annoying onhold messages). For those planning to call ... just don't .. not worth it even if they were paying you .. in this case i actually had to pay $30. Anyway to cut to the chase ... I finally got fed up ... just wondered if just maybe ... good old VMWare could at least rescue my image that had been made unusable by Parallels 4. Downloaded VM Fusion 2 told it I want to import Parallels VM (had to delete some files on hd to make room since it needed to copy my whole 30 Gig VM Image) ... that process ran for about 45 mins ... Got a popup saying import of image was successfull ... pushed the start VM button and voila ... I was back in business ... Oh, just had one more Parallels problem to deal with ... aparently Parallels had managed to sneak its tools onto my VM so the Parallels tools installation installed it when my windows rebooted, this caused my keyboard to not function ... but no problem ... just went into add/remove programs unistalled the tools ... then went to device manager and uninstalled all keyboard/mouse devices ... restarted the VM and every just works perfectly ... its noticeably much faster than my old Parallels V3 ... Can't comment on V4 coz that one just doesn't even work ...lol .... Networking, bluetooth, camera, dvd, usb, .... everything just works ... so what took me more than two days of stress was solved within 1 hour (including image conversion) and I did not lose one bit of data ... all my programs .. even my visual studio dev environment .. sql server db, all java dev environments and app servers, IIS, Apache, Tomcat, c/c++ Symbian dev and embedded dev environments ... everything just works ... Now that's what I call cool. That's amazing .. especially since Parallels cannot even work with the very image that it created ... kind of sad.

    If you decide to try going that route and need help .. feel free to ping me ... by the way I am using a trial version of VM Fusion .. so yes .. a still, so far, free product has done more for me than the $110 that i gave to dear Parallels. So if anything ... at least if you have data that you want to recover from your VM that was screwed up by parallels at least VMWare Fusion can help you recover your data for free ... even if you end up not buying the license .. Now that's what I call Cool ... Sorry Parallels chearleaders ... please don't throw anymore eggs ... these are just Facts ....
     
  7. xprmntlav8r

    xprmntlav8r

    Messages:
    1
    >>>>9) The upgrade process will start again. If you get the "Manual Upgrade" message click yes and proceed with the manual upgrade. If Windows pops up a message about reactivating click "No" - if the mouse doesn't work use the arrow keys. After Step 2 of the upgrade you may even get another error message saying the VM cannot be upgraded - don't let up - keep going. <<<<<

    I've gotten to this point 5 times. When I get the error message saying the VM cannot be upgraded, I have only the choice to click the OK box which opens the browser to the help window. At the same time the VM goes to the page where you can choose Safe Startup, Normal Startup, etc with a countdown to auto startup in Normal mode. The VM continually starts and comes back to this same position (Safe Start, Normal Start, etc). So how do you keep going?

    I've tried deleting 3rd party virus checker, uninstall Parallels Tools with no luck.

    Any suggestions on how to get past this point (step 2 of 4)?
     
  8. BeaverGeek

    BeaverGeek

    Messages:
    5
    Win XP SP3, PDM 3.0 -> 4.0 failed misserably.

    Yikes, I'm having the same problem (Win XP SP3). What a disaster. The forums are on fire with angry people trying to upgrade to 4.0; I wish I would've read these before making the decision to purchase it.

    Parallels please fix this, I'm downgrading back to version 3.0 until you get this fixed.
     
    Last edited: Nov 16, 2008
  9. rgilmartin

    rgilmartin

    Messages:
    2
    I tried that method and it worked for me as well

    After running transporter, the 'regular' upgrade program was able to complete (still with the 'manual continuation' message, which didn't actually require any manual intervention). So, for the moment, all is generally ok (generally meaning not particularly), but Parallels Tools doesn't work (with respect to the mouse), even though its been 'installed' and number of times.

    Anyway, many thanks to you for the massive assist (and no thanks to Parallels support).

    Roger
     
  10. cfparallels

    cfparallels

    Messages:
    1
    This didn't work for me

    In the end I received the same Unable to upgrade message in Step 2 that I have received 3 times now. I think it's off to VMWare for me. Incredible waste of time with no useful information from the company.
     
  11. Apple-Z

    Apple-Z

    Messages:
    11
    When I tried to upgrade my Boot Camp VM (you don't have a "backup and upgrade option), it failed during the process. The progress bar on the splash screen with the Parallels new features got about 1/3 of the way and hung up, and eventually I got an error message. I don't know if the initial failure was due to insufficient HD space (I had about 7 GB free and a 20 GB Boot Camp partition), but if it was, you would think that a detail like that would not have been overlooked before the new version was released !

    I tried the Transporter method and also tried the "Create New" method as proposed by one of the Parallels Staff postings, but these didn't work either. I was stuck with a VM that I couldn't do anything with.

    Rather than try to reinstall Parallels 3, I downloaded the free trial of VMWare Fusion 2, and imported my Boot Camp partition. It asked me to load Win XP for the import and it went off without a hitch.

    Fusion started up and I had my Boot Camp partition back :) I decided to give Parallels another try with the partition and this time it worked... So now I have access to my Boot Camp partition through both products, which will give me a month to evaluate Fusion.
     
  12. iTomac

    iTomac

    Messages:
    10
    Parallels 3 made my Mac Mini slow down to excruciating pace; it took 20-30 seconds to do anything even in regular Mac stuff like opening a Mac OS X Leopard applications, searching for files with spotlight, just opening folders, anything. So I removed 3.0 to the best of my ability. My Mac Mini is no longer that bad but it is still slower than it was before I installed Parallels 3 in the first place. I am constantly seeing beach balls. (1) would I be able to use the method you describe to install 4.0 since I removed 3.0? (2) Does Parallels 4.0 slow down your Mac at all?

    After purchasing Parallels 3 and then having to buy a Windows XP OS disk for over $100, I hate to waste that money by not trying to use the 4.0 upgrade; however I am so discouraged by what Parallels 3 did by paralyzing my Mac, I hate to "trust" them again by paying them for the upgrade knowing that people are having problem even installing the upgrade and you had to find the fix yourself because the company isn't solving these problems. I'm just afraid I'll waste more money and still have a agononizingly slow Mac.

    Advice please? Thank you!
     
  13. Billsoxs

    Billsoxs

    Messages:
    2
    OKay - I just upgraded cause Parallel 3.0 does not work with snow leopard and this is still a problem 1+ year out. I found a way around the loop - use force quit and then restart the machine each time it hits the loop. Basically it looks like it is fixing something related to the OS (XP for me) and at the end of each 1/4 it craps out. Let the progress bar reach 1/4 of the way each time - then give it a bit more time (so you know it is in the loop) and hit the force quit. (This is a scary thing to do but I could find nothing else to do.) 3 times doing this and I seem to be good to go. (Note I had not run XP for 6 to 8 months so it was not up to date.)
     
  14. Philippe Depatie

    Philippe Depatie

    Messages:
    1
    Force quit does it

    Thanks Billsoxs. I experienced the same problem, hanging between each of the 4 steps. Force quitting and restarting the VM did it.
     

Share This Page