Prevent Parallels from launching when opening a file

Discussion in 'General Questions' started by martin26, Dec 15, 2019.

  1. martin26

    martin26 Bit Poster

    Messages:
    8
    I dont want parallels to open and boot windows when I open a file in my mac, even if it is for a windows program. At least it should ask me before doing it, it is really annoying.

    I cannot find anywhere to configure this.
     
    bik, BrianM25 and aliy2 like this.
  2. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hi, please check settings at Parallels Desktop -> Preferences -> General -> un tick Star Parallels as a service.
    Also please check the virtual machine settings: VM configuration -> Option -> Start up and shut down -> choose at "Start automatically" Never and check the issue.
    Let us know how does it work for you.
     
  3. martin26

    martin26 Bit Poster

    Messages:
    8
    Thanks for your reply, can you please point me to the mentioned setting?
    both for "un tick Star Parallels as a service" and "VM configuration -> Option -> Start up and shut down"

    upload_2019-12-16_11-48-27.png
     

    Attached Files:

  4. DasertK

    DasertK Bit Poster

    Messages:
    8
    I am also waiting for Maria@ Parallels's reply.
     
    bik and aliy2 like this.
  5. martin26

    martin26 Bit Poster

    Messages:
    8
    hello?
     
  6. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Sorry for the delay guys,
    did you set up start up to "never" in VM configuration?
     

    Attached Files:

  7. martin26

    martin26 Bit Poster

    Messages:
    8
    where are those configs? I already showed you the only window I have found.
     
    bik and aliy2 like this.
  8. martin26

    martin26 Bit Poster

    Messages:
    8
    are you really interested in giving us support?
     
    aliy2 likes this.
  9. martin26

    martin26 Bit Poster

    Messages:
    8
    i finally found the way to set it to "never", click con the gear icon on the control center window, which you can find in the menu:
    upload_2020-1-4_14-20-32.png
    upload_2020-1-4_14-18-53.png


    it still wont do what i want which is a simple confirmation of wether I want to open virtual windows or not.

    terrible support by the way.
     
  10. martin26

    martin26 Bit Poster

    Messages:
    8
    I figured out a way for Mac not to suggest any windows apps when using spotlight. This solved the issue.
    upload_2020-1-4_14-24-57.png
     
  11. aliy2

    aliy2 Bit Poster

    Messages:
    1
    I can't add the windows icon here. It appears inactive when I click on +
     
  12. IanW11

    IanW11 Bit Poster

    Messages:
    3
    I found it!
    Right click your VM in control center > configure > options tab > select applications on the left > uncheck "Share Windows Applications with Mac"

    Share Windows Applications with Mac.png
     
    SasaM and Maria@Parallels like this.
  13. bik

    bik Bit Poster

    Messages:
    1
    the said options on the said menus DO NOT EXIST. I don't think I'll be buying anything from you lazy guys. I can't even find away to post to this forum except via this "reply". I feel like saying "come back bill all is forgiven"
     
  14. AaronR12

    AaronR12 Bit Poster

    Messages:
    1
    I found an alternative to disabling that feature. Sometimes it is nice for parallels to open a Windows only file but I hate when it opens a file and it tries to load Windows when it could have just opended with an Mac app.

    SOLUTION: Just require a password to change VM states. This was you can just press cancel if the file opens with the wrong app and use the Open With.. option from the option menu to select the Mac app you want to open the file with. (Be sure to set the app as the default for that file type too.)

    1. Enable "Require password to: Change virtual machine state from "My Boot Camp"/"Windows 10" Configuration > Security.
    Screen Shot 2022-02-15 at 6.28.52 PM.png

    Screen Shot 2022-02-15 at 6.24.03 PM.png
    When your Mac tries to open a file for windows you need to type your login password or it will not start. if you didn't mean to use Windows just press cancel and no funny business trying to stop windows from taking over your Mac.
    Screen Shot 2022-02-15 at 6.34.32 PM.png
    OPTIONAL: Change your file's association to prevent the issue from occuringin the future.
    1. locate the file that causes the Mac to open Windows unexpectedly and use the "Open With..." option from the option menu.
    Screen Shot 2022-02-15 at 6.25.53 PM.png
    2. Select Other... so you can choose a new default app to open the file.
    Screen Shot 2022-02-15 at 6.25.47 PM.png
    3. Enable "Always Open With" then select the app you want to use for the file and select it from the Application folder.
    Screen Shot 2022-02-15 at 6.41.13 PM.png
    The previously desribed method from the earlier post is what I tried initially. However, it will stop this behavior for all apps; even ones that can only be opened in Windows. I find it easier to confirm that I want to open a Windows file by typing my password instead.
     

Share This Page