Prevent Parallels from putting a VM in another Desktop in Mission Control/Exposé?

Discussion in 'Installation and Configuration' started by WheatW, Mar 22, 2014.

  1. WheatW

    WheatW

    Messages:
    12
    Mac OS X Mavericks 10.9.2, Parallels Desktop 9.0.24217, virtual machine with Windows 8.1.

    I have never liked Mission Control or Exposé, never felt the need for them, and don't like using them.

    When I start my Parallels virtual machine, it automatically puts the virtual machine in "Desktop 2" on Mission Control/Exposé. I don't want this.

    How can I prevent this from happening? I don't know if it's a Mission Control setting or a preference setting in Parallels.

    Are their preferences I need to change in Parallels under "Virtual Machine: Configure..." or in the Parallels Preferences? I find all of Parallels' "Sharing" and "Coherence" settings to be confusing, and I don't understand how they affect the use of Mission Control and Exposé.
     
  2. tthrift

    tthrift

    Messages:
    3
    While I was trying to figure out how to make my windows vm display on 2 new desktops,
    I ran across the behavior that you might want.

    If your machine has only 1 Desktop running in Mission Control.

    Try items 3, 4 and 5 of http://kb.parallels.com/118728

    When I do that on my machine,
    the windows vm boots into a single window on the sole "Desktop 1".
    The vm window can be run full screen.

    Good Luck,
    -Terry-




     
  3. Looran@Parallels

    Looran@Parallels Parallels Support

    Messages:
    309
    Hi WheatW,

    Please follow the steps outlined below to prevent Parallels Desktop top start on Desktop 2 on Mission Control:

    1) Go to Applications on the Mac side and start Mission Control app:
    2) Delete all spaces.

    To delete a space you can hold the ALT button and press the cross.

    3) Restart Parallels Desktop
    4) Start the Virtual Machine

    Add removed Spaces if you like. The Virtual Machine window will appear in the 1st space.

    Thanks,
    Looran
     

Share This Page