Preventing Parallels From Starting After Bootcamp Re-Start, etc. ? (Sr. Citizen Question, Please)

Discussion in 'Installation and Configuration' started by RobertR18, Aug 11, 2018.

  1. RobertR18

    RobertR18 Bit Poster

    Messages:
    23
    Hello,

    Sr. Citizen now, very, and if someone could help me out with this, would truly be most
    appreciative. Have spent quite a few hours on it, but still no luck. Running High Sierra.

    The folks at the Parallels help center have responded very quickly, but none of their suggestions works.
    Can't help believing they just send a canned response from a book on what seems to be the "closest" answer.
    Or, something in High Sierra is "different," and their answer is predicated on a much older OS, and has never been revised, or verified for High Sierra.
    And, some of the boxes and options that appear, for me, are not "exactly" what Parallels folks say. But, very responsive, which is nice.

    Have tried everything they suggested, and combinations of, but nothing works.
    I have appended my initial question(s) to them below, and their responses.

    Again, if anyone can guide me thru this, in detail, would really appreciate it. At my age, although I hate to admit it, not too sharp with this "stuff" anymore.

    I would truly like to understand this, and to be able to set Parallels up the way I want.
    Obviously, as usual, I'm missing something.
    --------------------------------------------------------
    Running High Sierra.
    Have both Parallels and Bootcamp working. Both work fine.

    Several folks in family (elderly) use the iMac, and is confusing for them, so what I want to accomplish is the following:

    I do not want Parallels, or its icons to show on desktop Dock under any circumstances.
    If I want to use parallels, I imagine I can start it easily via the Finder.

    The problem(s):

    If I shut off the Mac, and re-boot, the two Parallels icons (Parallels Control panel it's called, I think, and one for W10) always show up on in the Dock when restarting, and apparently running, as they both have the grey dot underneath.
    Also happens if I re-start from W10 (via Bootcamp) to go back to Mac OS.

    The small Parallels icon in the top Mac OS bar shows also, which is fine.

    I Force Quit on the two Dock icons, and Parallels disappears. Fine.
    *But upon restarting, they are (always) back, bouncing up and down, and then settling down, and apparently running.

    *What's really annoying, is that at least half the time, or more, the W10 screen ALSO is switched to (automatically) by Parallels !

    **So, please, how do I totally prevent Parallels from showing up, or
    running, in any form, or the W10 screen showing, upon any kind
    of a re-start/boot to the Mac OS ?

    Have tried several options (and most everything) in the
    Parallels pull-downs, but nothing seems to work; they always re-appear, often with W10 re-starting too.

    Again, if i want to use Parallels, I will get to it via the Finder, or...
    I do want to keep the Parallels program on the iMac, for possible future use.
    ============================================
    Answer from the Parallels folks:
    Please follow the below steps to disable Windows virtual machine and Parallels Desktop icons which is displayed on the Dock:

    1. If the Parallels Desktop icon is visible at the top of the screen, click Parallels Desktop icon > Preferences > General Tab > Virtual Machine Dock Icons
    2. Please choose "None" to disable Windows virtual machine and Parallels Desktop icons in the Dock.

    If you do not want Windows virtual machine to start automatically after restarting Mac please follow the below steps:

    1. Open Windows virtual machine Configuration
    2. Select Options Tab > Startup and Shutdown > Set the option Start Automatically as "Never".

    Please follow steps in the KB article https://kb.parallels.com/117287 to open Windows virtual machine configuration.
    -------------------
    BTW: That Gear icon they mention never shows up.

    And, the Configuration/Options/ Startup and shutdown screen has a yellow banded msg. that
    says. Some of the settings on this page cannot be changed until the virtual machine is shut down.
    *Not sure what to do next ?

    Thank you very much,
    Bob
     
  2. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    448
    Hi RobertR18. Please start the virtual machine. Select Actions (from the Mac menu bar) -> Shut down. Then refer this article and set the 'Start Automatically' option to 'Never'. Also, make sure that Parallels Desktop application is not added to the 'Login items' so that it will not be started when you restart your Mac.
     

Share This Page