prl_vm_app yomping all my cpu time

Discussion in 'Installation and Configuration' started by ichi, Nov 12, 2008.

  1. Birdman

    Birdman

    Messages:
    64
    Besides from the two CPU issue, I noticed that the prl_vm_app has some strange status saying "No Response" showed on the activity monitor as attached for only one CPU configured.

    The Windows XP is working but quite strange as there is no task always show no response.
     

    Attached Files:

  2. Nicolas Fletcher

    Nicolas Fletcher Bit Poster

    Messages:
    51
    In reply to Birdman... I am not a support professional, nor an employee of Parallels, so I'm not sure I can truly help. I am a power user, with common sense... but that is all.

    I'm not sure what your guest OS is... but if it is Windows XP, then you are also offered the opportunity when updating the driver to select go on-line to check... Also, I am guessing that we might be using a different Mac (I have a MacBook black), and the driver seems to refer to the specific intel processor in our machines.

    I suggest you raise the a case with Parallels... there is no charge if you do so on the website and wait a day or so for them to get back to you.

    Nic.
     
  3. Birdman

    Birdman

    Messages:
    64
    Hi!

    Many thanks for your reply.

    Actually, I got the solution mostly from you guys nice PD customers;-)

    I found that the PD4 (3540) is now ore stable when set to opti. for Mac OSX instead of VM.

    I do not know why but is now up and running in spite of the no response status shown on the Activity Monitor.

    Thanks!
     
  4. ebatte

    ebatte

    Messages:
    20
    Suggested by another user in another thread:

    1. Uninstall Parallels Desktop 4.0
    2. Login as another user and install PD4 while logged in as that user.
    3. Log back in to your normal user account and run PD4

    I did this and no longer have excessive cpu usage by prl_vm_app or the Parallels Desktop process. I should note that in my case when I reinstalled I was logged in as root, but I don't think it matters. Also, I did not have to re-import or convert my virtual machines. I am using one that I already converted to 4.0 and it works great!! Super low cpu usage!!

    Good luck!

    I'm going to post this as a separate thread so others will find it easier.
     
  5. Birdman

    Birdman

    Messages:
    64
    Hi! ebatte,

    Many thanks for the reply.

    Will try to see if it is fixed.

    BTW, where is the said another thread talking the re-installation of PD4 in another users?

    Thanks!
     
  6. Juankr

    Juankr

    Messages:
    22
    No works.... that´s incredible!! 85º when starts!!!
     
  7. ebatte

    ebatte

    Messages:
    20
    Juankr,
    A similar thing happened to me when installing the latest update and I discovered that you can't reinstall using any account that has already been used to install Parallels. Create a new user account with admin privileges, then uninstall Parallels, log in as the new user you just created, reinstall Parallels, log back in as yourself, start Parallels.

    This has worked for me twice now so I think it should work for you, too.
     
  8. Birdman

    Birdman

    Messages:
    64
    Hi! ebatte,

    Thanks for sharing the solution. But it did not work for me per your steps.

    Now I decide to cease the operation for PD4 and go back to PD3 or other VM application until more stable PD4 is available.

    Thanks!
     
  9. Juankr

    Juankr

    Messages:
    22
    Thanks ebatte!

    When i install parallels in a new account can i delete the new account?? i don´t like have 2 differents sessions
     
  10. patimages

    patimages

    Messages:
    40
    Hi,

    with the last 2 latest builts of parallels desktop 4, I am having huge troubles with very high cpu load caused by the prl_vm_app process (see attached). Lets hope your team hear this... For info, I tried reinstalling from another account, no luck. I checked the drivers in xp, all is fine.

    I reported this problem with ID 15253 but no answer... I really do hope to hear from you or will do like some of my colleagues : switch to wmware as I cannot work under this conditions : the laptop is literally burning up and the battery dying in a matter of minutes!!!

    specs:
    running leopard 10.5.5 and xp and built 3040.

    Hardware Overview:

    Model Name: MacBook Pro
    Model Identifier: MacBookPro4,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.5 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 6 MB
    Memory: 4 GB
    Bus Speed: 800 MHz

    Performance Counters View Utility v4.0.3540.209168
    Copyright 2008 Parallels, Inc.

    My Boot Camp - 23:03:45 +10 sec
    devices.ide0.aligned_writes 0
    devices.ide0.fsync 0
    devices.ide0.new_blocks_created 0
    devices.ide0.read_requests 0
    devices.ide0.read_total 0
    devices.ide0.unaligned_writes 0
    devices.ide0.write_requests 0
    devices.ide0.write_total 0
    devices.usb.ehci.activity 0
    devices.usb.ehci.ioasynccallback 0
    devices.usb.ehci.process_frame 0
    devices.usb.ehci.processpkt 0
    devices.usb.ehci.vcpusignal 0
    devices.usb.ehci.vcpusignal.aa 0
    devices.usb.ehci.vcpusignal.flr 0
    devices.usb.ehci.vcpusignal.int 0
    devices.usb.ehci.vcpusignal.pcd 0
    devices.usb.ehci.vcpusignal.ue 0
    devices.usb.uhci.activity 0
    devices.usb.uhci.ioasynccallback 0
    devices.usb.uhci.process_frame 0
    devices.usb.uhci.processpkt 0
    devices.usb.uhci.vcpusignal.total 0
    kernel.ide.irqs 51233
    kernel.paging.vcpu0.cr3_change 0
    kernel.paging.vcpu0.cr3_flushtlb 0
    kernel.paging.vcpu0.cr3_read 0
    kernel.paging.vcpu0.cr3_write 0
    kernel.paging.vcpu0.pf.genexc 0
    kernel.paging.vcpu0.pf.invalid 0
    kernel.paging.vcpu0.pf.mspc 0
    kernel.paging.vcpu0.pf.pagefault 5
    kernel.paging.vcpu0.pf.prot 7
    kernel.paging.vcpu0.pf.success 1
    kernel.paging.vcpu0.pf.wmapped 0
    kernel.usb.ehc.irqs 0
    kernel.usb.uhc.irqs 0
    kernel.vcpu0.activity.guest_mcs 0
    kernel.vcpu0.activity.guest_proc_halt 0
    kernel.vcpu0.activity.idle_percent 100
    kernel.vcpu0.activity.mon_artloop_halt 0
    kernel.vcpu0.activity.mon_mcs 9494
    kernel.vcpu0.activity.quest_acpi_halt 0
    kernel.vcpu0.activity.send_halt_msg 0
    kernel.vcpu0.activity.send_halt_msg_delay 0
    kernel.vcpu0.async_thr_activate 3
    kernel.vcpu0.guest_switch_sd 0
    kernel.vcpu0.guest_switch_svm 0
    kernel.vcpu0.guest_switch_vtx 411
    kernel.vcpu0.hardware_interrupt 11
    kernel.vcpu0.irq_process 20288
    kernel.vcpu0.mode_switch 0
    kernel.vcpu0.mon_ret_to_host 49
    kernel.vcpu0.mon_ret_to_host_switch 50
    kernel.vcpu0.pic.setintrequest 124812
    kernel.vcpu0.sendapirequest 26998
    kernel.vcpu0.sendapirequest_lastcmd 0
    kernel.vcpu0.vtx_interrupth 321094
    kernel.ws.effective 0
    kernel.ws.pagein 0
    kernel.ws.pageout 0
    kernel.ws.pages 196961
    net.nic0.activate 0
    net.nic0.bcast_in 0
    net.nic0.bytes_in 0
    net.nic0.bytes_out 0
    net.nic0.mcast_in 0
    net.nic0.pkt_dropped_in 0
    net.nic0.pkt_err_in 0
    net.nic0.pkt_err_out 0
    net.nic0.pkts_in 0
    net.nic0.pkts_out 0
    net.nic0.send_buffer_notifications 0
    video.frames 0
    disp_server - 23:03:45 +10 sec
    mgmt.commands 0
    mgmt.error_commands 0
     
    Last edited: Nov 22, 2008
  11. John@Parallels

    John@Parallels

    Messages:
    6,343
    New update was published, which is right now available at http://forum.parallels.com/showthread.php?t=31764
    The most of problem were fixed.
    Please navigate to that link, and download build 3540
    In post there are various instructions, how to fix problems.
     
  12. Juankr

    Juankr

    Messages:
    22
    I have install build 3540 but nothing!
    I already have the problem... Me mac is burning!
     
  13. patimages

    patimages

    Messages:
    40
    Got something... Here is how on core 2 duo macbook pro 2.5 GHz:
    1- start pd4 (but not windows).
    2- go to configure/cpu->change cpu to 1, press ok and wait till it is updated. restart pd4.
    3- go to configure/cpu->change cpu to 2, press ok and wait till it is updated. restart pd4.
    4- repeat steps 2 and 3 (don't know why but works).
    5- start pd4 and windows: prl_vm_app will spike at startup but then remain below 50%. It is better than before when prl_vm_app would take the whole cpu power while windows did nothing.
    However, if an application requires some cpu in windows (powerpoint opening big files, etc), prl_vm_app will still saturate the cpu (which is not normal : I have one of the latest and most powerful macbook pro...).

    So, it is a small step but support is still requested.

    PS: Do not know whether it matter but I uninstalled my antivirus, ran this cycle (1-5) and only then did I reinstall my antivirus. Also, I had switched my taskbar to the classic version and changed that to the xp version before to run this cycle (1-5). Whether this is of importance is unknown but who knows...
     
    Last edited: Nov 23, 2008
  14. Birdman

    Birdman

    Messages:
    64
    Hi! patimages,

    Thanks for more info. for the high CPU usage issue and we know it is the real problem for the unstable PD4 (3540).

    I will only wait for your green light to proceed one last try for testing the upcoming PD4 version for stable usage of my WinXP running on my MacBook!
     
  15. patimages

    patimages

    Messages:
    40
    It works ok for me birdman! still fairly tough on the cpu but fine.
    if you are on PD3, stay on it. I just fought so much with PD4 that I did not want to bother downgrading. However, to anybody who does not want to pay to just test a bad soft, I would wait a better release...
     
  16. cyclone

    cyclone

    Messages:
    7
    I am having the same problem - 100% CPU for as many processors as I configure the VM to use (I'm on a 4-CPU Mac Pro), with little or no Windows CPU activity. I do get the yellow exclamation point but when asking Windows to update driver it says it's already running the latest, and there's no rollback option. I submitted a ticket #625710 with a log from the performance counters utility, but have gotten no response. Note that this is with a converted PD3 VM. Happy to help troubleshoot.
     
  17. pythonzz

    pythonzz Parallels Team

    Messages:
    47
    Our engineer has already replied to you asking to reattach the output.
    Please check your mailbox.
     
  18. Juankr

    Juankr

    Messages:
    22
    any solution?
     
  19. cyclone

    cyclone

    Messages:
    7
    I solved this by going to device manager / Processors, then right-clicking on Intel CPU and selecting uninstall, then right-clicking on Processors and doing a hardware scan, which reinstalled the CPU (with no exclamation point). Upon shutting down and restarting the session the CPU usage was normal (low).
     
  20. Juankr

    Juankr

    Messages:
    22
    no works for me..
     

Share This Page