Problem in accessing shared files and folders under /media/psf

Discussion in 'Linux Guest OS Discussion' started by niemand, Nov 11, 2008.

  1. niemand

    niemand

    Messages:
    1
    I just upgraded to Parallels 4.0 and created a new Fedora Core 9 VM. It works otherwise OK, but when I try to access shared folders (mounted under /media/psf in Fedora) using for example the ls command, it hangs. The strange thing is that if I use the strace command to see what the ls process is doing, ls continues and finishes it job as expected. The same thing happens with other commands too, so the problem is not in ls.

    Any idea what is the problem?
     
  2. jrhodes

    jrhodes

    Messages:
    3
    I noticed a similar problem. I am running a CentOS 5.2 guest and I can access most files under /media/psf. However, I have one directory that ls hangs on. I have noticed that the DirectoryService process on OSX starts using about 50% of the %cpu and stays there until I use ctrl-C to cancel the ls command. The programs prl_vm_app and automount use the remaining 50% of the %cpu. Also, stopping and restarting PD4 does not seem to help.
     
  3. tbo

    tbo

    Messages:
    6
    I just installed Ubuntu 8.10 and cannot seem to get folder sharing working, because it tells me tha I do not have permission to view the contents. I thought this "smart folder thing" would do the job...
    How do you set the permissions correctly?
     
  4. Lupestro

    Lupestro

    Messages:
    2
    I also cannot access the folders in /media/psf

    I'm using Parallels build 4.0.3522.

    In hopes that it might help, I even tried adjusting my Linux user to have the same UID as my Mac user, but to no avail. I am having the same issue whether it is accessing my home area on the main drive or the two shared FAT32 firewire volumes. It tells me "You do not have the permissions necessary to access the contents of Home" (or whatever folder I choose). Looking at permissions shows me folder access of "create and delete files" but file access of "---".

    What did I miss?
     
  5. sanpago

    sanpago

    Messages:
    1
    setting permissions of shared folder

    In /etc/fstab, I have replaced:

    none /media/prl prl_fs defaults,shared 0 0

    with:

    none /media/prl prl_fs defaults,users,uid=1000,gid=1000 0 0

    and it works.

    Notes: 1000 is my uid and gid.
     
  6. Lupestro

    Lupestro

    Messages:
    2
    Thanks! That did it for me!

    ... but I'll let the original poster designate whether this constitutes an answer... :)
     

Share This Page